Bug Report False Alarm /Solved - Audio Sync Offset - Not working in 23.1.0 (64-bit, windows)

Robertsmania

New Member
I notice that my audio is no longer synced when I record or stream with OBS 23.1.0 x64 on Windows 10.

I tried adjusting the Sync Offset on various audio inputs in the Advanced Audio Properties dialog box, and have convinced myself that they make no difference. All the audio comes through without delay. I know for certain that this used to work.

Then I went to another system and installed OBS 23.1.0 fresh (that computer did not have it before) and confirmed that there too the specified Sync Offset is ignored.

Searching the forum, I do find posts from as recent as March 2019 where people mention the feature as working, so I'm hoping its just recently gone sideways?

https://obsproject.com/logs/_8-Hbnp_wdxOXwRE

Repro steps:
1. Start OBS and add an Audio Input Capture device to a scene.
2. Right click in the Mixer and select Advanced Audio Properties.
3. On the Audio Input you created, specify a positive value that should be fairly obvious in the Sync Offset field (1000).
4. Observe that sound shows up on the mixer level indicator immediately with no delay.
5. Start Recording and make sounds with a video reference (webcam, desktop or video).
6. Play the video file back and observe that the sound is not delayed.
7. Quit OBS and restart, then repeat steps 4-6 to double check and make sure behavior is consistent after a restart.
 

Attachments

carlmmii

Active Member
I can confirm that the visual mixer indication shows no change with respect to the delay set. However, the recording absolutely adheres to the delay setting.

I'm not sure if the visual response is something that has changed from prior versions though.
 

Robertsmania

New Member
Upon further investigation it appears the issue I am seeing is a byproduct of running OBS and VoiceAttack at the same time.

Both applications are trying to use the mic device and that competition seems to affect whether OBS can impose the delay?

If I start OBS first and then VoiceAttack, it seems to record/stream properly with the intended delay and VoiceAttack still works using the mic for speech recognition.

Sorry for the false alarm.
 

kestrel4

New Member
I found I needed to remove the Source, Audio Input Capture, and and then re-add it. The Sync Offset had been applying the settings to the wrong microphone. I had changed the output format to mp4 and maybe that had something to do with it
 
Top