View Issue Details

IDProjectCategoryView StatusLast Update
0000608OBS-StudioMedia Source Pluginpublic2017-08-08 14:29
ReporterColterTVAssigned ToFenrir 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionunable to reproduce 
PlatformWindowsOSWindowsOS Version10
Product Version0.15.0 
Target VersionFixed in Version 
Summary0000608: Audio doesn't output to stream from media and VLC sources
DescriptionThis is an intermitent issue.

Sometimes, when you play a video through the media/VLC source, the audio bar will move but people on stream won't actually get sound from that source.

Steps To ReproduceSwitch to a scene with media/VLC source and try to confirm if you get audio from it on the stream. In some cases, you won't.

This happened to me many times and some friends as well.

There's also a post on the forum asking for help on this very issue. Example: https://obsproject.com/forum/threads/2nd-media-source-no-audio.53832/
Additional InformationIt would be great to have this fixed as you have no way to tell if the video sound is actually reaching your viewers.

A possible fix for this would be having video audio to output to desktop, that way it would be easy to confirm that you are actually getting sound off it.

Thank you
TagsNo tags attached.

Activities

c3r1c3

2016-08-31 00:08

reporter   ~0000977

Last edited: 2016-08-31 00:09

View 2 revisions

Just to add a note.

If the video you're playing isn't in spec (like having a MP4 file with h.264 video and MP3 audio), you'll get no audio and/or inconsistant results during playback.

Why?

Because the file isn't in spec.

So (in general) double check the codecs used to make the file in playback.

ColterTV

2016-08-31 00:30

reporter   ~0000978

I understand that, but with VLC standalone it NEVER happens. One should expect the same behaviour out of the VLC source.

And never happened to me in OBS Classic either. Thats why I'm inclined to believe there's a bug somewhere (hence this report)

FrankerC

2016-10-21 18:09

reporter   ~0001150

Last edited: 2016-10-21 18:10

View 2 revisions

Can confirm this is still an issue, half the time the audio in an MP3 source will play and half the time it doesn't - both times the audio bar in OBS shows activity for said source.

If "in spec" means "not using MP3s" then don't allow people to add them as sources in the first place.

Fenrir

2017-08-05 06:10

manager   ~0002408

Can you provide a sample file that exhibits this problem? I'm not able to replicate with any of my own files.

ColterTV

2017-08-07 21:02

reporter   ~0002438

Hello. It's been a while since this issue was happening.

Now with the audio monitor feature I haven't experienced this issue anymore. I just output to desktop and it is working ok.

Fenrir

2017-08-08 14:29

manager   ~0002439

Thanks for the update. Going to close this, but do please reopen if the issue occurs again.

Issue History

Date Modified Username Field Change
2016-08-30 22:21 ColterTV New Issue
2016-08-31 00:08 c3r1c3 Note Added: 0000977
2016-08-31 00:09 c3r1c3 Note Edited: 0000977 View Revisions
2016-08-31 00:30 ColterTV Note Added: 0000978
2016-10-21 18:09 FrankerC Note Added: 0001150
2016-10-21 18:10 FrankerC Note Edited: 0001150 View Revisions
2017-08-05 06:10 Fenrir Note Added: 0002408
2017-08-05 06:10 Fenrir Category - Uncategorized - => Media Source Plugin
2017-08-07 21:02 ColterTV Note Added: 0002438
2017-08-08 14:29 Fenrir Assigned To => Fenrir
2017-08-08 14:29 Fenrir Status new => closed
2017-08-08 14:29 Fenrir Resolution open => unable to reproduce
2017-08-08 14:29 Fenrir Note Added: 0002439