View Issue Details

IDProjectCategoryView StatusLast Update
0000510OBS-StudioFeature Requestpublic2019-02-23 03:32
ReporterScott AAssigned Tododgepong 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformOBS MultiplatformOSAll SystemsOS VersionAll Versions
Product Version 
Target VersionFixed in Version0.16.6 
Summary0000510: Add RealSense Support for Auto (Depth Generated) Green Screen Effect Similar to XSplit
DescriptionCurrently XSplit supports RealSense cameras ability to perceive depth and allows for an auto green screen effect. While OBS Studio can read the RealSense SR300 devices (Depth, RGB, Virtual Driver), it doesn't have an option to apply the effect automatically like XSplit. It would be nice if such a feature was supported.
Steps To Reproduce1. Have a RealSense camera with the appropriate drivers
2. Launch OBS Studio
TagsNo tags attached.

Relationships

duplicate of 0000561 resolveddodgepong Add support for realsense devices (cameras with 3D sensors) 

Activities

Scott A

2016-05-19 07:07

reporter   ~0000809

Just realized I should disclose that I work at Intel to be on the safe side. Still requesting this feature as a streamer though who loves OBS, but also loves the effect and hates the current feature disparity in regards to this effect between OBS and XSplit.

LtRoyalShrimp

2016-06-06 22:23

reporter   ~0000848

Bump. Would love to see this as well. I have a F200.

JTB3

2016-09-19 06:27

reporter   ~0001034

Last edited: 2016-09-19 06:28

View 2 revisions

(+1) I'd also love to see RealSense support in OBS! There is a new wave of RealSense webcams and devices being released (e.g. Razer Stargazer Webcam) along with at least 6 other comparative software products now supporting RealSense. Having chroma-key capabilities without the need for a physical green/blue screen is VERY enticing!

Daniel Caves

2016-10-03 16:10

reporter   ~0001095

(+1) Would be great if we could get RealSense to work on OBS Studio as I have just got the Razer Stargazer and don't really feel like using xsplit as i don't get on with it

PhoenixHawk

2016-10-05 18:21

reporter   ~0001105

(+1) I also just received my Stargazer and would love to use it as a green-screenless camera with OBS. So please add support for RealSense.

AtticusVulpes

2016-10-20 03:24

reporter   ~0001147

I'm in the stargazer camp and would love to have support for it!

Issue History

Date Modified Username Field Change
2016-05-19 06:51 Scott A New Issue
2016-05-19 07:07 Scott A Note Added: 0000809
2016-06-06 22:23 LtRoyalShrimp Note Added: 0000848
2016-09-09 14:49 Jim Relationship added duplicate of 0000561
2016-09-19 06:27 JTB3 Note Added: 0001034
2016-09-19 06:28 JTB3 Note Edited: 0001034 View Revisions
2016-10-03 16:10 Daniel Caves Note Added: 0001095
2016-10-05 18:21 PhoenixHawk Note Added: 0001105
2016-10-20 03:24 AtticusVulpes Note Added: 0001147
2016-11-24 04:10 dodgepong Status new => resolved
2016-11-24 04:10 dodgepong Fixed in Version => 0.16.6
2016-11-24 04:10 dodgepong Resolution open => fixed
2016-11-24 04:10 dodgepong Assigned To => dodgepong
2019-02-22 19:35 Fenrir Category Image Source Plugin => Image/Slideshow/Color Source Plugin
2019-02-22 22:07 Fenrir Category Image/Slideshow/Color Source Plugin => Image/Slideshow/Color Source
2019-02-23 03:32 Fenrir Category Image/Slideshow/Color Source => Display Capture Source (Windows)
2019-02-23 03:32 Fenrir Category Display Capture Source (Windows) => Feature Request