View Issue Details

IDProjectCategoryView StatusLast Update
0001257OBS-Studiolibobspublic2019-04-14 18:13
ReporterAlexDanielAssigned Tocg2121 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformOBS StudioOSLinuxOS VersionAll Versions
Product Version21.1.2 
Target VersionFixed in Version24.0.0 
Summary0001257: Missing support for F25-F35 keys
DescriptionI'm unable to use keys F25-F35 in OBS.
Steps To Reproduce1. Go to Settings/Hotkeys
2. Select some action
3. Press F35 key on your keyboard
4. Nothing happens :(
5. However, pressing keys from F1 to F24 do set up the shortcut correctly.
Additional InformationSee this code: https://github.com/obsproject/obs-studio/blob/ce89ae105721b160c7e6412600b6b42af1c802b1/libobs/obs-nix.c#L400-L425

Basically, it maps OBS_KEY_F* to XK_F*, but only from 1 to 24. Most keyboards only have F1-F12, but keys up to F35 are valid.

Moreover, OBS_HOTKEYS are defined up to F35, meaning that generally they should be supported: https://github.com/obsproject/obs-studio/blob/4c61ae9513deeb331e6621237f4344257b10ebb9/libobs/obs-hotkeys.h#L32-L68

The same issue should be reproducible on Windows because obs-windows.c also has keys defined only up to F24. I guess same should be checked for obs-cocoa.c.
TagsNo tags attached.

Activities

H4ndy

2018-07-24 18:25

developer   ~0003368

Last edited: 2018-07-24 18:37

View 2 revisions

Windows is limited to F1 to F24 (as defined in WinUser.h of the Windows SDK)
Mac is limited to F1 to F20 (as defined in Events.h of the macOS SDK) and F21 to F24 are already defined as INVALID_KEY in obs-cocoa.h

For Linux, X11 keysymdef.h has indeed support for F1 to F35.

So creating a Pull Request can only add support for those upper F keys for the Linux build of OBS.

cg2121

2019-03-31 08:44

developer   ~0004423

PR: https://github.com/obsproject/obs-studio/pull/1795

Jim

2019-04-01 03:45

administrator   ~0004434

I seriously want a picture of your keyboard.

dodgepong

2019-04-01 04:07

administrator   ~0004435

It's less about the keyboard and more about having external devices that let you assign hotkeys that don't overlap with normal keyboard keys.

AlexDaniel

2019-04-01 10:37

reporter   ~0004442

Also, keyboard ≠ layout. You can assign these keys anywhere you want (especially on linux). For example, imagine F20-F29 on your numpad, it makes sense to do that if you want to make sure that other apps don't react on global obs shortcuts.

cg2121

2019-04-14 18:13

developer   ~0004498

https://github.com/obsproject/obs-studio/commit/9930b294b9f855f4ae6464cc22f12b746f05990c

Issue History

Date Modified Username Field Change
2018-07-24 15:45 AlexDaniel New Issue
2018-07-24 18:25 H4ndy Note Added: 0003368
2018-07-24 18:37 H4ndy Note Edited: 0003368 View Revisions
2019-02-24 02:02 Fenrir Assigned To => Fenrir
2019-02-24 02:02 Fenrir Status new => acknowledged
2019-02-24 02:02 Fenrir Severity minor => feature
2019-03-31 08:44 cg2121 Note Added: 0004423
2019-03-31 17:43 cg2121 Assigned To Fenrir => cg2121
2019-04-01 03:45 Jim Note Added: 0004434
2019-04-01 04:07 dodgepong Note Added: 0004435
2019-04-01 10:37 AlexDaniel Note Added: 0004442
2019-04-14 18:13 cg2121 Note Added: 0004498
2019-04-14 18:13 cg2121 Status acknowledged => resolved
2019-04-14 18:13 cg2121 Resolution open => fixed
2019-04-14 18:13 cg2121 Fixed in Version => 24.0.0