View Issue Details

IDProjectCategoryView StatusLast Update
0001018OBS-StudioOBS Studio UI (Qt)public2019-04-08 14:11
ReporterThomas De SchampheleireAssigned Tocg2121 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOBS StudioOSLinuxOS VersionAll Versions
Product Version20.0.0 
Target VersionFixed in Version 
Summary0001018: 'Escape' hotkey is displayed as empty box, giving the impression that there is no hotkey
DescriptionWhen 'Escape' is used as hotkey, the UI does not give a textual representation of that hotkey, unlike other special keys like Home, End, PageUp, etc. The only visible evidence that a hotkey is set, is that the 'Clear' button is not grayed out, but this is totally not obvious.

I was facing seemingly random recording stops, without error in the log file. I had already emptied all the hotkey boxes, and did not knowingly set any other hotkeys. However, it seemed the 'Stop recording' still had an 'Escape' hotkey set.
I don't know if this is the default, or that this is a setting I inherited from the person whose profile I copied.

If the UI had shown that there was an Escape hotkey, I'd have solved the problem much sooner and wouldn't have lost several minutes of recording (actually in total about an hour). It's unclear to me if there is a reason or if it's rather an oversight that the Escape key is not correctly translated to a string.

In addition to the fix of the Escape key, I would suggest adding a default string in case the key-to-string translation gives no result, something like '<unknown>' so that any other missing keys would at least give an indication.

Since the impact is large and because I found at least one other person that has had the same problem at [1], I marked Severity as 'major'. Feel free to reduce it if you think otherwise.

[1] https://obsproject.com/forum/threads/when-i-hit-escape-the-stream-stops.49956/
Steps To ReproduceGo to Settings -> Hotkeys -> (any hotkey), hit 'Esc' button.
Notice that nothing is shown, but Clear button is activated.
Additional Information02:23:39 PM.791: Processor: 4 logical cores
02:23:39 PM.791: Processor: Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
02:23:39 PM.791: Physical Memory: 7862MB Total
02:23:39 PM.791: Kernel Version: Linux 4.12.5-gentoo
02:23:39 PM.791: Distribution: Gentoo Unknown
02:23:39 PM.791: Portable mode: false
02:23:39 PM.805: OBS 20.0.1 (linux)
TagsNo tags attached.

Issue History

Date Modified Username Field Change
2017-09-12 12:39 Thomas De Schampheleire New Issue
2019-02-23 05:29 Fenrir Category OBS Studio UI => OBS Studio UI (Qt)
2019-03-31 10:17 cg2121 Note Added: 0004424
2019-03-31 17:43 cg2121 Assigned To => cg2121
2019-03-31 17:43 cg2121 Status new => assigned
2019-04-08 14:11 cg2121 Note Added: 0004471
2019-04-08 14:11 cg2121 Status assigned => resolved
2019-04-08 14:11 cg2121 Resolution open => fixed