Resource icon

YATCP - Yet Another Twitch Chat Plugin .51

#1
quasarinova submitted a new resource:

YATCP - Yet Another Twitch Chat Plugin - Add a Twitch chat overlay to your stream

Requires CLRHost Plugin(included in archive) to operate

I realize that another plugin is being developed for Twitch chat overlay. I'm not trying to steal sickbattery's thunder, I think he's got something great on his hands. However, I started working on this a bit before he posted his up and just now feel that it's worth someone else's time other than mine.

Basically, it all comes down to the fact that I want a chat overlay that resizes when I change scenes(which isn't really easy with the...
Read more about this resource...
 
#3
There seems to be a bug in your plug in, or maybe my system is missing something?

The log is getting flooded with: 16:08:01: CLRVector2::Tick() failed to invoked on managed instance: 0x80131604
The log doesn't get flooded when I disable your plug in ... so, I guess it's yours.
Update:Is my CLR Host plug in out of date? Well, I'll have to wait until tomorrow. My girlfriend is going to kill me if I don't stop coding for today :D ...

quasarinova said:
Basically, it all comes down to the fact that I want a chat overlay that resizes when I change scenes
You mean, when your plugin is a global source? Could you explain it a little bit more?

quasarinova said:
Known Problems:
Can't detect a dc(you can force it to reconnect with a settings change)
I don't know if mine is able to handle this either oO ... with dc you mean disconnect? Mine at least should show a message ... I will have to check that :D.

Did you write your own IRC client? Wow. I'm just using https://launchpad.net/ircdotnet ...
 
#4
sickbattery said:
There seems to be a bug in your plug in, or maybe my system is missing something?

The log is getting flooded with: 16:08:01: CLRVector2::Tick() failed to invoked on managed instance: 0x80131604
The log doesn't get flooded when I disable your plug in ... so, I guess it's yours.
Update:Is my CLR Host plug in out of date? Well, I'll have to wait until tomorrow. My girlfriend is going to kill me if I don't stop coding for today :D ...
It is mine. I've been using a solution stemming from the hacky starboard implementation, which invokes the Ui thread. I'l have to see what's going on. Like I said its pretty rough.

quasarinova said:
Basically, it all comes down to the fact that I want a chat overlay that resizes when I change scenes
You mean, when your plugin is a global source? Could you explain it a little bit more?
Kind of. You can't change the size as a global source, but it keeps its history. With individual sources it clears the history, but you can change sizes. I'm OK with either,but am working on a solution to keep chat amongst individual sources(as a toggle).

quasarinova said:
Known Problems:
Can't detect a dc(you can force it to reconnect with a settings change)
I don't know if mine is able to handle this either oO ... with dc you mean disconnect? Mine at least should show a message ... I will have to check that :D.

Did you write your own IRC client? Wow. I'm just using https://launchpad.net/ircdotnet ...
Irc is pretty simple if you are just reading. The only way I know to know if you disconnected is if sending data fails, but I only ever send a PONG command when we receive a PING. I'm working on it though:)
 
#5
OK, I found out that my plugin does not work with the advertised current version of CLRHost, instead I've been using the one packaged with the CLRBrowser. It does not have this error with it. I'm going to take off my link to the CLRHost(but still mention it) and change my upload to contain the newer library. Hopefully Faruton releases an official update:)

Anywho, if you use the files in the new archive, everything should be good.
 
#7
Could you post a log and/or crash dump?

Barring that, does it crash right away when the plugins in use (preview and/or stream)? If it takes it a little bit of time it's probably an unhandled exception with my irc code(i know about this... I'll fix it in the next version). Make sure you are using your OAuth token, not your twitch password and that your user name is all lowercase. If it still crashes, I really need the log and dump.
 
#8
quasarinova said:
Could you post a log and/or crash dump?

Barring that, does it crash right away when the plugins in use (preview and/or stream)? If it takes it a little bit of time it's probably an unhandled exception with my irc code(i know about this... I'll fix it in the next version). Make sure you are using your OAuth token, not your twitch password and that your user name is all lowercase. If it still crashes, I really need the log and dump.
I've seen to got it working now, it looks great imo. The only thing is missing is showing the mod icons if that's possible. Loads pretty quickly too.
 
#9
That's great.

I'll see what I can do about the mod icons. Can't promise how long it'll be before I get there, but I'll add it to the list of features I want to add.
 
#11
DirectorGunner said:
How do we support you for this?
What do you mean? If you want to know how you can help, requesting features and reporting any bugs you find is really all I need. After I clean up my code a bit, I'll probably open up the source.

And any plans to implement the current viewer count?
I could, but it'd be hard to figure out where to put it, the way I'm currently doing the chat.
 
#12


As you can see above, your plugin is causing this menu drawing issue in both OBS x64 and OBS x32, I confirmed it.

I'm using Windows 7 x64 on a brand new 2013 macbookpro via bootcamp.
Drivers to enable apple hardware in Win7 work perfectly. I also have Klite codec mega pack installed.

Any ideas why your plugin file would cause this issue within the OBS application?


Edit:
quasarinova said:
DirectorGunner said:
How do we support you for this?
What do you mean? If you want to know how you can help, requesting features and reporting any bugs you find is really all I need. After I clean up my code a bit, I'll probably open up the source.

And any plans to implement the current viewer count?
I could, but it'd be hard to figure out where to put it, the way I'm currently doing the chat.
What I mean is donations :)
 
#13
DirectorGunner said:


As you can see above, your plugin is causing this menu drawing issue in both OBS x64 and OBS x32, I confirmed it.

I'm using Windows 7 x64 on a brand new 2013 macbookpro via bootcamp.
Drivers to enable apple hardware in Win7 work perfectly. I also have Klite codec mega pack installed.

Any ideas why your plugin file would cause this issue within the OBS application?
I don't have a mac running bootcamp, so it's hard for me to deduce. When does the problem occur? Is it from startup, after you open up settings, after you preview/stream? The only part in my code that I think could cause this is me invoking, but that doesn't happen unless my plugin is active in a scene being rendered. Could you possibly post the log of when this happens?
 
#14
Every thing looks okay as soon as OBS loads, but as soon as I move my mouse to the top onto the menu the menu then ghost doubles like in the picture... it still works.. it's just I have to select a tiny little place between the 2 menu bars for any menu selection. I suspect now, after tinckering.. that it actually might have something to do with CLRHost.. but dunno.. I'd be glad to post a diag if you tell me how. I'm newish to OBS. And thank you for being so kind and helpful!
 
#15
I've added this plugin into my OBS setup and set up a global source, added my twitch username and my oauth password, but I'm not seeing any chat come up when I preview the stream.

Note: I'm connected to my IRC chatroom using hexchat and typing things in there. Are two connections allowed like this??
 
#16
DirectorGunner said:
Every thing looks okay as soon as OBS loads, but as soon as I move my mouse to the top onto the menu the menu then ghost doubles like in the picture... it still works.. it's just I have to select a tiny little place between the 2 menu bars for any menu selection. I suspect now, after tinckering.. that it actually might have something to do with CLRHost.. but dunno.. I'd be glad to post a diag if you tell me how. I'm newish to OBS. And thank you for being so kind and helpful!
This post should be helpful for finding where the log file is.

thefold said:
I've added this plugin into my OBS setup and set up a global source, added my twitch username and my oauth password, but I'm not seeing any chat come up when I preview the stream.
Well, if it's not crashing, it's definitely connecting. Perhaps the chat channel is wrong? Make sure you are sending messages directly from chat on your channel or by joining #yourusername(so if you are TheFold on twitch it should be #thefold). Also, make sure the size is good on it. I've had obs put it at a small size...no where near my settings before and I had to reset the size of it through right clicking it's source->Position and Size->Reset Size before.

I need to add a function to join a chat channel of choice in your settings and am adding logging to it tell what's going wrong easier, they should be in the next version.

Note: I'm connected to my IRC chatroom using hexchat and typing things in there. Are two connections allowed like this??
It will do multiple connections correctly. In fact, I use hexchat to watch my own chat while streaming and will send a message or two from it as well.
 
#17
This is a nice plugin, it's missing a few things to help improve the font readability. Mainly the ability to make the font bold and an outline for that font. It would also be nice if we could set the transparency, as well.
 
#18
Bosenator said:
This is a nice plugin, it's missing a few things to help improve the font readability. Mainly the ability to make the font bold and an outline for that font. It would also be nice if we could set the transparency, as well.

Id recomend changing the default font, arial is never easy to read on anything lol. I personally use the roboto font (free font from google, used for android 4.4) or the ubuntu font at size 16. it makes things much easier to read.
 
#19
I personally don't use Arial either and prefer Calibri at size 14 or 16. However, I just put it at Arial as that seems to be the default font everywhere>.< I can change it, but it's gotta be one installed with Windows if it's a default.

As for readability. I can do bold pretty easily. I can also give options on transparency. Outlines might be a problem(I've basically hacked a wpf richtext box to render and do most of the formatting for me), but Bold and the Transparency are easy. I should have sometime the next few days to finish the changes I was making and release it.

Again, I just released this form of it due to me feeling it met the bare minimum of features needed for public consumption. I'm glad you guys like it, though, makes me want to continue working on it(I will get it up on GitHub or something sooner or later, as the concept of closed source plugins for an open source program such as this makes my head hurt, only haven't done so yet as I'm embarrassed by the state of my code).
 
#20
quasarinova said:
thefold said:
I've added this plugin into my OBS setup and set up a global source, added my twitch username and my oauth password, but I'm not seeing any chat come up when I preview the stream.
Well, if it's not crashing, it's definitely connecting. Perhaps the chat channel is wrong? Make sure you are sending messages directly from chat on your channel or by joining #yourusername(so if you are TheFold on twitch it should be #thefold). Also, make sure the size is good on it. I've had obs put it at a small size...no where near my settings before and I had to reset the size of it through right clicking it's source->Position and Size->Reset Size before.

I need to add a function to join a chat channel of choice in your settings and am adding logging to it tell what's going wrong easier, they should be in the next version.

Note: I'm connected to my IRC chatroom using hexchat and typing things in there. Are two connections allowed like this??
It will do multiple connections correctly. In fact, I use hexchat to watch my own chat while streaming and will send a message or two from it as well.
Thanks for the response. I was still having problems and I worked out that I needed to use the CLRHostPlugin that came with YATC even though I had the one downloaded from the main CLRHostPlugin site.
 
Top