Bug Report Window Capture (XComposite) only showing OBS' menu and titling every window as "unknown"

meetowl

New Member
If I try to attach a window capture to my mixer, it gives me a X of "unknown" windows with either black / OBS menu as the output, X being the amount of windows I currently have open. Sometimes, the first time I open the menu for the window capture it gives me a randomly chosen window (such as thunderbird), it later disappears and goes back to either being a black screen / the OBS menu.
The issue occurs in both prepackaged (AUR) versions and building from obs-studio on github.

Attached is a screencap of the capture menu.
Here is the terminal output while adding a new window source:
#####
info: User added source 'Window Capture (Xcomposite)' (xcomposite_input) to scene 'Scene'
info: xcompcap: [window-capture: 'Window Capture (Xcomposite)'] update settings:
title: unknown
class: obs
info: xcompcap: [window-capture: 'Window Capture (Xcomposite)'] update settings:
title: unknown
class: obs
info: xcompcap: [window-capture: 'Window Capture (Xcomposite)'] update settings:
title: unknown
class: obs
info: xcompcap: [window-capture: 'Window Capture (Xcomposite)'] update settings:
title: unknown
class: obs
info: xcompcap: [window-capture: 'Window Capture (Xcomposite)'] update settings:
title: unknown
class: obs
info: xcompcap: [window-capture: 'Window Capture (Xcomposite)'] update settings:
title: unknown
class: obs
#####


OBS 21.1.1-243-g8b6d437a on Arch Linux
xorg-server 1.20.0-9
GTX 760 w/ nvidia 396.24-18
libxcomposite 0.4.4-3
lib32-libxcomposite 0.4.4-3
 

Attachments

  • Screenshot from 2018-07-22 20-48-33.png
    Screenshot from 2018-07-22 20-48-33.png
    50.1 KB · Views: 118

Programie

New Member
I have the same issue on KDE. In my case It is caused by the regional system settings: I'm using English as system language and Germany as regional setting which results in a invalid locale "en_DE". Changing the region to something like United States and the detailed settings (Numbers, Time, etc.) to Germany fixes that for me.

But how does that affect the window selection?
 

Attachments

  • Screenshot_20190112_173530.png
    Screenshot_20190112_173530.png
    115.4 KB · Views: 306
  • Screenshot_20190112_173837.png
    Screenshot_20190112_173837.png
    101.7 KB · Views: 299

Robaz

New Member
I have the same problem latest KDE and OBS.
I played a bit with the settings and the detailed ones have no effect on this only the region setting causes this if it's not set to en_us
 
Top