AZZACSB

New Member
I don't know why, i built my new pc recently (last week), and at first it recorded videos and played Call of Duty Black Ops 3 fine, like OBS didn't even struggle (and neither did the graphics card).
But one day, it just stopped being normal and has been playing up ever since, I've spent literally days looking for a solution, taking parts out of my pc and putting them back in, and i keep getting the same result :/... Oh and also i'm playing on medium settings in game and it's still struggling...
PLES.jpg


Specs:
Monitor - HP 2211x @60hz
CPU - I7-8700k @3.70Ghz
GPU - GTX 1080 TI SC2
RAM - DDR4 16GB @3200MHz
PSU - 750W
MOTHERBOARD - ASUS Z370 Maximus x hero D4 ATX

wtf.jpg
 

AZZACSB

New Member
Oh yeah! sorry thought i was missing something...

20:26:28.598: CPU Name: Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz
20:26:28.598: CPU Speed: 3696MHz
20:26:28.598: Physical Cores: 6, Logical Cores: 12
20:26:28.598: Physical Memory: 16310MB Total, 11756MB Free
20:26:28.598: Windows Version: 10.0 Build 17763 (revision: 195; 64-bit)
20:26:28.598: Running as administrator: false
20:26:28.598: Aero is Enabled (Aero is always on for windows 8 and above)
20:26:28.598: Windows 10 Gaming Features:
20:26:28.598: Game Bar: Off
20:26:28.598: Game DVR: Off
20:26:28.598: Game DVR Background Recording: Off
20:26:28.600: Sec. Software Status:
20:26:28.603: Windows Defender Antivirus: disabled (AV)
20:26:28.603: AVG Antivirus: enabled (AV)
20:26:28.603: AVG Antivirus: enabled (FW)
20:26:28.603: Windows Firewall: disabled (FW)
20:26:28.603: Windows Defender Antivirus: disabled (ASW)
20:26:28.603: AVG Antivirus: enabled (ASW)
20:26:28.603: Browser Hardware Acceleration: true
20:26:28.603: Portable mode: false
20:26:28.682: OBS 22.0.2 (64-bit, windows)
20:26:28.682: ---------------------------------
20:26:28.694: ---------------------------------
20:26:28.694: audio settings reset:
20:26:28.694: samples per sec: 48000
20:26:28.694: speakers: 2
20:26:28.849: ---------------------------------
20:26:28.849: Initializing D3D11...
20:26:28.849: Available Video Adapters:
20:26:28.851: Adapter 1: NVIDIA GeForce GTX 1080 Ti
20:26:28.851: Dedicated VRAM: 3077570560
20:26:28.851: Shared VRAM: 4256313344
20:26:28.851: output 1: pos={0, 0}, size={1920, 1080}, attached=true
20:26:28.853: Loading up D3D11 on adapter NVIDIA GeForce GTX 1080 Ti (0)
20:26:28.890: D3D11 loaded successfully, feature level used: 45056
20:26:29.455: ---------------------------------
20:26:29.455: video settings reset:
20:26:29.455: base resolution: 1920x1080
20:26:29.455: output resolution: 1920x1080
20:26:29.455: downscale filter: Lanczos
20:26:29.455: fps: 60/1
20:26:29.455: format: NV12
20:26:29.455: YUV mode: 709/Full
20:26:29.457: Audio monitoring device:
20:26:29.457: name: Speakers (Realtek High Definition Audio)
20:26:29.457: id: {0.0.0.00000000}.{bc4f8fca-d960-4a97-8009-53c0f0d1b144}
20:26:29.457: ---------------------------------
20:26:29.558: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
20:26:30.239: [AMF] AMF Test failed due to one or more errors.
20:26:30.239: Failed to initialize module 'enc-amf.dll'
20:26:31.502: NVENC supported
20:26:32.575: Couldn't find VLC installation, VLC video source disabled
20:26:32.950: No blackmagic support
20:26:33.428: ---------------------------------
20:26:33.428: Loaded Modules:
20:26:33.428: win-wasapi.dll
20:26:33.428: win-mf.dll
20:26:33.428: win-dshow.dll
20:26:33.428: win-decklink.dll
20:26:33.428: win-capture.dll
20:26:33.428: vlc-video.dll
20:26:33.428: text-freetype2.dll
20:26:33.428: rtmp-services.dll
20:26:33.428: obs-x264.dll
20:26:33.428: obs-vst.dll
20:26:33.428: obs-transitions.dll
20:26:33.428: obs-text.dll
20:26:33.428: obs-qsv11.dll
20:26:33.428: obs-outputs.dll
20:26:33.428: obs-filters.dll
20:26:33.428: obs-ffmpeg.dll
20:26:33.428: image-source.dll
20:26:33.428: frontend-tools.dll
20:26:33.428: enc-amf.dll
20:26:33.428: coreaudio-encoder.dll
20:26:33.428: ---------------------------------
20:26:33.429: LoadLibrary failed for 'obs-browser': The specified module could not be found.
20:26:33.429: (126)
20:26:33.429: ==== Startup complete ===============================================
20:26:34.282: All scene data cleared
20:26:34.282: ------------------------------------------------
20:26:34.974: WASAPI: Device 'Speakers (High Definition Audio Device)' initialized
20:26:34.975: [WASAPISource::WASAPISource] Device '{0.0.1.00000000}.{2a41c2cf-0bce-4843-aef2-2abf6a4a8b29}' not found. Waiting for device
20:26:34.975: Source ID 'browser_source' not found
20:26:34.975: Failed to create source 'Chat live'!
20:26:34.975: Source ID 'browser_source' not found
20:26:34.975: Failed to create source 'Subscribers'!
20:26:35.043: adding 21 milliseconds of audio buffering, total audio buffering is now 21 milliseconds
20:26:52.310: Source ID 'browser_source' not found
20:26:52.310: Failed to create source 'Browser'!
20:26:52.313: Switched to scene 'Game'
20:26:52.356: ------------------------------------------------
20:26:52.356: Loaded scenes:
20:26:52.356: - scene 'Screen capture':
20:26:52.356: - source: 'Display Capture' (monitor_capture)
20:26:52.356: - source: 'Video Capture Device 2' (dshow_input)
20:26:52.356: - scene 'Gameplay':
20:26:52.356: - source: 'Game Capture' (game_capture)
20:26:52.356: - source: 'Video Capture Device 4' (dshow_input)
20:26:52.356: - scene 'Game':
20:26:52.356: - source: 'Game Capture 2' (game_capture)
20:26:52.356: - source: 'Facecamz' (dshow_input)
20:26:52.356: - scene 'Screen capture pc games':
20:26:52.356: - source: 'Game Capture 3' (game_capture)
20:26:52.356: - filter: 'Scaling/Aspect Ratio' (scale_filter)
20:26:52.356: - filter: 'Chroma Key' (chroma_key_filter)
20:26:52.356: - source: 'Browser' (browser_source)
20:26:52.356: - source: 'Webcam' (dshow_input)
20:26:52.356: - filter: 'Chroma Key' (chroma_key_filter)
20:26:52.356: - scene 'display':
20:26:52.356: - source: 'Display Capture 2' (monitor_capture)
20:26:52.356: - scene 'Stream':
20:26:52.356: - source: 'Elgato' (dshow_input)
20:26:52.356: - monitoring: monitor and output
20:26:52.356: - source: 'Display Capture 3' (monitor_capture)
20:26:52.356: - source: 'Game Capture 4' (game_capture)
20:26:52.356: - filter: 'Scaling/Aspect Ratio' (scale_filter)
20:26:52.356: - source: 'Facecam' (dshow_input)
20:26:52.356: - source: 'Subscribers' (browser_source)
20:26:52.356: - source: 'Color Source' (color_source)
20:26:52.356: - source: 'Chat live' (browser_source)
20:26:52.356: ------------------------------------------------
20:26:53.496: Facecamz: data.GetDevice failed
20:26:53.496: Facecamz: Video configuration failed
20:27:00.342: ---------------------------------
20:27:00.342: [DShow Device: 'Elgato'] settings updated:
20:27:00.342: video device: Elgato Game Capture HD
20:27:00.342: video path: __elgato
20:27:00.342: resolution: 1280x720
20:27:00.342: fps: 60.00 (interval: 166666)
20:27:00.342: format: UYVY
20:27:00.343: using video device audio: yes
20:27:00.343: sample rate: 48000
20:27:00.343: channels: 2
20:27:00.343: audio type: Capture
20:27:51.791: [game-capture: 'Game Capture 2'] attempting to hook process: BlackOps3.exe
20:27:51.794: [game-capture: 'Game Capture 2'] using helper (compatibility hook)
20:27:52.417: [game-capture: 'Game Capture 2'] hook not loaded yet, retrying..
20:27:54.807: [game-capture: 'Game Capture 2'] attempting to hook process: BlackOps3.exe
20:27:57.508: [game-capture: 'Game Capture 2'] capture stopped
20:27:58.824: [game-capture: 'Game Capture 2'] attempting to hook process: BlackOps3.exe
20:27:58.841: [game-capture: 'Game Capture 2'] capture stopped
20:28:02.841: [game-capture: 'Game Capture 2'] attempting to hook process: BlackOps3.exe
20:28:02.857: [game-capture: 'Game Capture 2'] shared texture capture successful
20:29:02.024: [game-capture: 'Game Capture 2'] d3d11 shared texture capture successful
20:29:02.041: [game-capture: 'Game Capture 2'] shared texture capture successful
20:29:06.792: [game-capture: 'Game Capture 2'] ----------------- d3d11 capture freed ----------------
20:29:07.041: [game-capture: 'Game Capture 2'] d3d11 shared texture capture successful
20:29:07.057: [game-capture: 'Game Capture 2'] shared texture capture successful
20:29:15.813: [game-capture: 'Game Capture 2'] ----------------- d3d11 capture freed ----------------
20:29:15.976: [game-capture: 'Game Capture 2'] d3d11 shared texture capture successful
20:29:15.990: [game-capture: 'Game Capture 2'] shared texture capture successful
20:29:18.022: ---------------------------------
20:29:18.696: [NVENC encoder: 'recording_h264'] settings:
20:29:18.696: rate_control: CBR
20:29:18.696: bitrate: 50000
20:29:18.696: cqp: 0
20:29:18.696: keyint: 250
20:29:18.696: preset: default
20:29:18.696: profile: main
20:29:18.696: level: auto
20:29:18.696: width: 1920
20:29:18.696: height: 1080
20:29:18.696: 2-pass: true
20:29:18.696: b-frames: 2
20:29:18.696: GPU: 0
20:29:18.696:
20:29:26.235: ---------------------------------
20:29:26.235: [FFmpeg aac encoder: 'Stream'] bitrate: 160, channels: 2, channel_layout: 3
20:29:26.235:
20:29:26.768: ==== Recording Start ===============================================
20:29:26.768: [ffmpeg muxer: 'adv_file_output'] Writing file 'C:/Users/Cools/Videos/2018-12-25 20-29-18.mp4'...
20:29:32.395: [game-capture: 'Game Capture 2'] ----------------- d3d11 capture freed ----------------
20:29:32.558: [game-capture: 'Game Capture 2'] d3d11 shared texture capture successful
20:29:32.574: [game-capture: 'Game Capture 2'] shared texture capture successful
20:35:42.342: [game-capture: 'Game Capture 2'] ----------------- d3d11 capture freed ----------------
20:35:42.524: [game-capture: 'Game Capture 2'] shared texture capture successful
20:35:44.005: [game-capture: 'Game Capture 2'] d3d11 shared texture capture successful
20:36:43.656: [ffmpeg muxer: 'adv_file_output'] Output of file 'C:/Users/Cools/Videos/2018-12-25 20-29-18.mp4' stopped
20:36:43.656: Output 'adv_file_output': stopping
20:36:43.656: Output 'adv_file_output': Total frames output: 23010
20:36:43.656: Output 'adv_file_output': Total drawn frames: 22723 (26213 attempted)
20:36:43.656: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 3490 (13.3%)
20:36:43.657: ==== Recording Stop ================================================
20:36:43.664: Video stopped, number of skipped frames due to encoding lag: 22173/26205 (84.6%)
20:36:43.855: warning: 2 frames left in the queue on closing
21:11:50.974: [game-capture: 'Game Capture 2'] capture window no longer exists, terminating capture
21:11:50.975: [game-capture: 'Game Capture 2'] capture stopped
 

Attachments

  • 2018-12-25 20-26-28.txt
    10.2 KB · Views: 32
D

Deleted member 121471

Try the following to troubleshoot what the source of your problem is:

1) On OBS main windows, create a new scene collection and only add "game capture" as a source, nothing else.
2) Limit your ingame FPS through FPS limiter or vsync.
3) Change YUV Colour Space and Range to 601/Partial.
4) When using NVENC as your encoder, use CQP instead of CBR. A CQP value of 20 as a test should do the trick.
5) Change your recording format to .mkv or .flv. In the eventuality of any issue that terminates a .mp4 recording, the resulting file is unrecoverable. After finishing your session, you can press "File"-->"Remux recording" to change the container of the final recording to .mp4, if you really need to.
6) DDU your nvidia drivers might be required if none of these helped.
 

AZZACSB

New Member
I have a feeling it was my drivers that are playing up and maybe not OBS, since i've done steps 1,2,3,4 and 5 and it still lagged (step 4 actually caused my whole pc to crash :o) So i've uninstalled the drivers and reinstalled them (hopefully this will work) since my pc feels faster anyway :o
 
Top