Webcam input freezing while using VirtualCam

dcellars

New Member
Hey everyone!

I'm having a problem with my video input (webcam) freezing. The only way to get it unfrozen is to restart OBS.

I teach online using OBS as a virtual webcam. I used it for months with a cheap low resolution Logitech camera with no issues. Then I switched to a high resolution wide-angle webcam from some little Chinese brand, and it worked well for a week or so, but then suddenly my video would freeze in the middle of class, stuck eternally on a single frame. The issue is only with the camera input. I can switch scenes and make the camera input visible and invisible, but there is no way to get it unfrozen without fully closing and restarting OBS. Restarting OBS always resolves the issue, though sometimes it would happen again soon after restarting OBS. At first I thought it was a problem with OBS and browsed the forums for advise, and tried lowering my resolution and frame rates to no avail. I changed every possible setting and nothing would prevent recurrence of the issue. Later, I found strangely that if I was to physically touch my webcam, for example, to adjust the angle, it would often freeze at the moment I touched it. I was able to replicate this quite consistently: just give the camera or cable a little bit of a shake and it would freeze in OBS, requiring a restart of OBS. Thereupon I decided that it must be a physical problem with the new camera, so I switched it for a new one, but today I left OBS running after class and coming back to my computer I noticed that the same problem occurred again with the new camera! I am at a loss. Attached is the log file. It occurred in the last 45 minutes of this log, after my class was over. The computer did not go to sleep during that time, I was just on Facebook.

Please advise. Just let me know if you want me to try anything or need any other info. This is my first post; I hope I've explained things clearly!

- Devon
 

Attachments

  • 2020-08-18 07-31-36.txt
    14.5 KB · Views: 120

dcellars

New Member
bump. Had the problem again this evening. image freezing in class and needing to open and close OBS (pretty annoying). lowered the resolution and framerate and plugged the cam into a USB port of its own (it was in a hub before). we'll see if this makes it any better. also the webcam's cable is only usb 2.0
 

dcellars

New Member
Still having this problem. I just noticed that the green light on my webcam which indicates it is in use will turn off when it crashes in OBS.
 

rem437

New Member
Hey, dcellars. You ever get this figured out? Having the same problem with my set up (also teaching) and it's also incredibly annoying to have to restart OBS. Makes me look and feel unprofessional....
 

dcellars

New Member
Hey, Rem! I seem to have figured it out, as I haven't had the problem for a couple months, but I'm not sure what I did to fix it. I turned my camera quality settings down and I made a new 'Profile' on OBS (Profiles are streaming settings, like screen size, etc.) so my output resolution is lower. I don't know what exactly it was that fixed the problem, but let me send you as much info as I can about my current setup and hopefully you can recreate it on your end:

Attached are an export of my current Profile and screenshots of my camera settings and video setting. Good luck!
 

Attachments

  • lo_res_profile.zip
    722 bytes · Views: 131
  • 2020-11-02 07_00_01-Properties for 'new wide angle cam'.png
    2020-11-02 07_00_01-Properties for 'new wide angle cam'.png
    20.5 KB · Views: 801
  • 2020-11-02 07_02_47-Settings.png
    2020-11-02 07_02_47-Settings.png
    23.4 KB · Views: 783
Top