Resource icon

Video Transition / Stinger Transition 0.2.2

Warmuptill submitted a new resource:

Video Transition / Stinger Transition - Use a video to transition from one scene to the next.

With this plugin you can use videos as transitions between scenes.

Installation:
  • Extract the folder
  • Merge the "obs-studio" folder with the obs-studio folder of your OBS Studio installation. (For example C:\Program Files (x86)\obs-studio)
Now you can add a new transition type "Stinger Transition" by clicking the small plus sign in the Scene Transitions section of OBS.
After entering a name for the transition the properties window will open where you...
Read more about this resource...
 
Little feedback.

I tried alpha webm and they will not show up transparent.

Is your ffmpeg version maybe too old?
Maybe also check this https://github.com/jp9000/obs-studio/commit/679c32086d4363565c221b8be2b99c0023e77a35

The Media Source in OBS can display them fine.

Example file: https://puu.sh/u8Bsj.webm

---

I'm asking about this because they produce a lot less CPU usage and run smoother than mov's with pngs
Oh thanks for the advice! I was just linking against the dependencies folder of OBS linked here, so i don't know which version that is.
I will definitively look into it later.
 

Rodney

Forum Moderator
You'll probably have to force it to use libvpx like in that commit for it to work properly with VP8/VP9 in webms.
 
Wow, can you make this for Mac as well? Would be so great!!!
Yes, there shouldn't be anything preventing it from working on Mac. Just want to get it work properly - at least to a point where I dont think i will need to update it anytime soon - before I build it for Mac, since that is quite annoying for me to setup.
 

haganbmj

New Member
Pretty sweet looking plugin - I'll have to start making some transitions to use it with.
Ran into a crash with OBS 17.0.2 (both 32bit and 64bit) and with my compiled, week old, 64bit dev build. Windows 10.

Action: Attempt to create a new transition.
The menu opens up but indicates that there are no options available, then crashes after a small pause.

00:32:15.197: device_pixelshader_create (GL) failed
00:32:15.197: Could not find stinger_transition.effect
00:32:15.197: Failed to create source 'StingerTransition'!


Crash Log: http://pastebin.com/raw/qd9kEwb5

Verified that the effect is available at the following path:
obs-studio\data\obs-plugins\stinger-transition\stinger_transition.effect

I'll keep fiddling with it. I might have a misconfigured installation.
 

Phara0h

New Member
This is cool and all but it doesn't seem to work right in Studio Mode. It plays the transition but switches to the other scene on frame 1. But hopefully in the future this can be fixed.
 
Works perfectly, just no sound yet but I'm assuming you're working on that.
Yup, I will try to add sound.

This is cool and all but it doesn't seem to work right in Studio Mode. It plays the transition but switches to the other scene on frame 1. But hopefully in the future this can be fixed.
It should be working in studio mode (see the above video posted by Rodney). Can you send me the video file you are using for the transition, so I can try to recreate the issue on my end?
 

Rodney

Forum Moderator
It seems that sometimes after creating a transition the frame for changing the scene is not correctly set. Reopening the properties and changing + saving it again usually fixes that.

I also noticed that the pokeball transition I used in my test video is about two frames off. I extracted all frames using ffmpeg and the one with full coverage of the screen should be 66 but I have to use 68 in order for the transition to occur at the correct time. I got the video from someone on IRC, I'll check the logs and see if I can post it here.

Edit: this might be related to another thing I noticed, it seems the last two frames of a transition are played when I change scenes before the video starts from the beginning. I can get an example video of that later. With some transitions that don't have "clean" last frames this results in a short flash of whatever is on the screen.

Edit #2: Here's a demo of what I'm talking about:

Edit #3: I also might have found a memory leak after testing a bunch of videos :p
 
Last edited:

Warchamp7

Forum Admin
When you select the video to use, could the transition frame default to the middle of the video instead of frame 1? That'd be really handy.

Also, a way to bulk add stingers all at once would be awesome too

Otherwise, I'm super excited to finally have this functionality :D
 
It seems that sometimes after creating a transition the frame for changing the scene is not correctly set. Reopening the properties and changing + saving it again usually fixes that.

I also noticed that the pokeball transition I used in my test video is about two frames off. I extracted all frames using ffmpeg and the one with full coverage of the screen should be 66 but I have to use 68 in order for the transition to occur at the correct time. I got the video from someone on IRC, I'll check the logs and see if I can post it here.

Edit: this might be related to another thing I noticed, it seems the last two frames of a transition are played when I change scenes before the video starts from the beginning. I can get an example video of that later. With some transitions that don't have "clean" last frames this results in a short flash of whatever is on the screen.

Edit #2: Here's a demo of what I'm talking about:

Edit #3: I also might have found a memory leak after testing a bunch of videos :p
Thanks for testing the plugin so thoroughly! I really appreciate it!

Still trying to find the source of the cut frame being set to 1 even if there is a valid video.
The pokeball transition is fully covering the screen on frame 67 for me (counting from 1 onwards). The transition cutting one frame too late should be resolved in the next update (used a < instead of <=, thanks for pointing this out!)
I also made sure to clear the first frame when a new transition is started / the end of a transition is reached to avoid the issue of showing a frame of the ending of the transition.
Also found the source of the memory leak (at least I think so). A texture was created but could not be freed because i forgot to use "obs_enter_graphics".

Im gonna fiddle around with some audio stuff and will update the plugin again tomorrow.

When you select the video to use, could the transition frame default to the middle of the video instead of frame 1? That'd be really handy.

Also, a way to bulk add stingers all at once would be awesome too

Otherwise, I'm super excited to finally have this functionality :D
I will give both of these suggestions a try. But I don't have an idea on how to do the bulk adding, yet. Thanks!
 

Gearomatic

New Member
Hmm, It seems like I'm doing something wrong, but I don't know what.

I extracted the Zip, Merged the folders together, and I don't seem to get the option to add the transition:

I even went back and retried it using a different zip extractor, and reinstalling OBS

Any Quick tips that I could do to see whats up? I have other addons that seem to work fine, so it is seems to be something in the way I set this up. W7 + 17.0.2 64bit
 
Hmm, It seems like I'm doing something wrong, but I don't know what.

I extracted the Zip, Merged the folders together, and I don't seem to get the option to add the transition:

I even went back and retried it using a different zip extractor, and reinstalling OBS

Any Quick tips that I could do to see whats up? I have other addons that seem to work fine, so it is seems to be something in the way I set this up. W7 + 17.0.2 64bit
Does the log file say anything about the plugin failing to load?
 

Warchamp7

Forum Admin
Hmm, It seems like I'm doing something wrong, but I don't know what.

I extracted the Zip, Merged the folders together, and I don't seem to get the option to add the transition:

I even went back and retried it using a different zip extractor, and reinstalling OBS

Any Quick tips that I could do to see whats up? I have other addons that seem to work fine, so it is seems to be something in the way I set this up. W7 + 17.0.2 64bit
That's the quick transition add menu, it lets you add one of your existing transitions to the quick transition list in the center there.

upload_2017-2-20_11-7-0.png


You want this menu on the bottom right for creating a new transition
 

Gearomatic

New Member
This is the only things that jumps out at me:

Code:
10:51:11.502: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/chrome_elf.dll' not found, loading of module failed
10:51:11.551: [AMF Encoder] Unable to load 'amfrt64.dll', error code 126.
10:51:11.590: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libcef.dll' not found, loading of module failed
10:51:11.594: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libEGL.dll' not found, loading of module failed
10:51:11.597: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libGLESv2.dll' not found, loading of module failed
10:51:11.600: Failed to load 'en-US' text for module: 'obs-browser.dll'
10:51:12.024: Couldn't find VLC installation, VLC video source disabled
10:51:12.042: No blackmagic support
10:51:12.066: [Media Foundation encoder]: plugin is disabled for performance reasons on Windows versions prior to 8

Full here: https://gist.github.com/36a8e8ffa7ed10b88402cd4376f800cc

I have been Noticing that OBS likes to Freeze on exit now as well. not %100 sure that its new
 
Top