Question / Help Unexplained audio latency (SOLVED)


New Member
Hey guys hope all is well with you all today! :)

I'm having some issues with recording games recently and I'm wondering if someone with a little more knowledge can help me work out the issue(s). So basically my games had been recording perfectly fine until a few weeks ago where I would experience pretty bad lag and micro-stutters whilst recording along with crackling audio latency in conjunction with this. Prior to this happening I was able to stream and record simultaneously at 1080p 60fps with no issues then one day, BAM! it all stopped and I would struggle to even do a local recording at 720p 30fps!.

If I am not recording (or streaming) I get no issues with my games with no lag/stutter or audio latency but the second I attempt to do a local recording or stream (both together and separately) or even have OBS running in the background doing nothing whilst a game is running I get this horrible micro-stutter, frame drop issue (drops to around 39 average fps from an average of 55fps when not recording) and audio latency combination. I'll list the things I have tried so that you can all see whats been attempted so far;

- Fresh install of windows.
- Removed every trace of dust from machine (fans, radiator...everything).
- Tried connecting via Ethernet directly as opposed to WIFI to get a more solid connection.
- Full antivirus scan pulled back nothing (naturally as it was a fresh install) but wanted to eliminate everything.
- Updated graphics drivers and even rolled back to the most stable build.
- Ran in various resolutions and lowered graphics settings to see if it was an issue with CPU/GPU even at the LOWEST settings it still happened?!?!
- Applied fresh thermal paste to CPU and GPUs
- Moved games onto SSD no difference.
- Defragged all drives.
- Checked task manager for stats whilst gaming (CPU usage at 11%, memory at 28%, disk at 1% and GPU at 100%).
- Turned crossfire on, and off on all games to no avail.
- Cleared redundant files on both primary and secondary drives and they are currently both sitting at 50% storage capacity so plenty of space on both drives.
- Moved the file where the game recordings are generated and stored from HDD to SSD.
- Changing my webcam resolution that I record myself with.
- Clean install of graphics drivers (wiped all traces of previous drivers and installed the latest version)

Here are my specs;

- CPU: Intel Core i7-5960X Eight Core Processor.
- GPU: (x2) 8GB AMD Radeon R9 390 cards crossfired.
- Motherboard: Gigabyte X99-Gaming Motherboard.
- RAM: 16GB Kingston Hyper-X Predator Quad-DDR4 3000MHz X.M.P (x2 8GB sticks).
- Cooling System: Corsair H80i GT Hydro Series.

I've also put a short video clip on YouTube which will hopefully give a demonstration on how the game looks/sounds when attempting to record (this is just a local recording and not a stream by the way);

- (when the door opens in this clip you can hear what I mean by the audio latency and you can also see some of the micro-stutter as well).

Log file;

21:40:05.366: CPU Name: Intel(R) Core(TM) i7-5960X CPU @ 3.00GHz
21:40:05.367: CPU Speed: 3000MHz
21:40:05.367: Physical Cores: 8, Logical Cores: 16
21:40:05.367: Physical Memory: 16219MB Total, 13453MB Free
21:40:05.367: Windows Version: 10.0 Build 17134 (revision: 345; 64-bit)
21:40:05.367: Running as administrator: false
21:40:05.367: Aero is Enabled (Aero is always on for windows 8 and above)
21:40:05.367: Windows 10 Gaming Features:
21:40:05.367: Game Bar: Off
21:40:05.367: Game DVR: Off
21:40:05.367: Game DVR Background Recording: Off
21:40:05.368: Sec. Software Status:
21:40:05.370: Windows Defender Antivirus: enabled (AV)
21:40:05.370: Windows Firewall: enabled (FW)
21:40:05.371: Windows Defender Antivirus: enabled (ASW)
21:40:05.371: Browser Hardware Acceleration: true
21:40:05.371: Portable mode: false
21:40:05.476: OBS 22.0.2 (64-bit, windows)
21:40:05.476: ---------------------------------
21:40:05.488: ---------------------------------
21:40:05.488: audio settings reset:
21:40:05.488: samples per sec: 44100
21:40:05.488: speakers: 2
21:40:05.499: ---------------------------------
21:40:05.499: Initializing D3D11...
21:40:05.499: Available Video Adapters:
21:40:05.500: Adapter 1: AMD Radeon (TM) R9 390 Series
21:40:05.500: Dedicated VRAM: 4269682688
21:40:05.501: Shared VRAM: 4208533504
21:40:05.501: output 1: pos={0, 0}, size={3840, 2160}, attached=true
21:40:05.503: Loading up D3D11 on adapter AMD Radeon (TM) R9 390 Series (0)
21:40:05.535: D3D11 loaded successfully, feature level used: 45056
21:40:06.310: ---------------------------------
21:40:06.310: video settings reset:
21:40:06.310: base resolution: 3840x2160
21:40:06.310: output resolution: 1280x720
21:40:06.310: downscale filter: Bicubic
21:40:06.310: fps: 30/1
21:40:06.310: format: NV12
21:40:06.310: YUV mode: 601/Partial
21:40:06.312: Audio monitoring device:
21:40:06.312: name: Default
21:40:06.312: id: default
21:40:06.312: ---------------------------------
21:40:06.358: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/chrome_elf.dll' not found, loading of module failed
21:40:06.362: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
21:40:06.932: [AMF] Version 2.4.2 loaded (Compiled:, Runtime:, Library: 1;4;10;0;;201810101752;CL#1617073).
21:40:07.040: [AMF] [Capability Manager] Testing Direct3D 11 Adapter 'AMD Radeon (TM) R9 390 Series (VEN_1002/DEV_67b0/SUB_4e91043/REV_0080)':
21:40:07.040: H264/AVC: Supported
21:40:07.040: H265/HEVC: Not Supported
21:40:07.135: [AMF] [Capability Manager] Testing Direct3D 9 Adapter 'AMD Radeon (TM) R9 390 Series [\\.\DISPLAY34] (VEN_1002/DEV_67b0/SUB_4e91043/REV_0080)':
21:40:07.135: H264/AVC: Supported
21:40:07.135: H265/HEVC: Not Supported
21:40:07.135: [AMF] [H265/HEVC] Not supported by any GPU, disabling...
21:40:07.221: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libcef.dll' not found, loading of module failed
21:40:07.236: LoadLibrary failed for '../../obs-plugins/64bit/libEGL.dll': The specified procedure could not be found.
21:40:07.236: (127)
21:40:07.236: Module '../../obs-plugins/64bit/libEGL.dll' not loaded
21:40:07.261: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libGLESv2.dll' not found, loading of module failed
21:40:07.286: [obs-browser]: Version 2.1.5
21:40:07.301: LoadLibrary failed for 'nvEncodeAPI64.dll': The specified module could not be found.
21:40:07.301: (126)
21:40:07.635: Couldn't find VLC installation, VLC video source disabled
21:40:07.652: No blackmagic support
21:40:07.670: ---------------------------------
21:40:07.670: Loaded Modules:
21:40:07.670: win-wasapi.dll
21:40:07.670: win-mf.dll
21:40:07.670: win-dshow.dll
21:40:07.670: win-decklink.dll
21:40:07.670: win-capture.dll
21:40:07.670: vlc-video.dll
21:40:07.670: text-freetype2.dll
21:40:07.670: rtmp-services.dll
21:40:07.670: obs-x264.dll
21:40:07.670: obs-vst.dll
21:40:07.670: obs-transitions.dll
21:40:07.670: obs-text.dll
21:40:07.670: obs-qsv11.dll
21:40:07.670: obs-outputs.dll
21:40:07.670: obs-filters.dll
21:40:07.670: obs-ffmpeg.dll
21:40:07.670: obs-browser.dll
21:40:07.670: image-source.dll
21:40:07.670: frontend-tools.dll
21:40:07.670: enc-amf.dll
21:40:07.670: coreaudio-encoder.dll
21:40:07.670: ---------------------------------
21:40:07.670: ==== Startup complete ===============================================
21:40:07.680: All scene data cleared
21:40:07.680: ------------------------------------------------
21:40:07.937: WASAPI: Device '7.1 Surround Sound Headphones (ASUS XONAR PHOEBUS)' initialized
21:40:07.961: WASAPI: Device 'Microphone (Blue Snowball)' initialized
21:40:07.999: adding 23 milliseconds of audio buffering, total audio buffering is now 23 milliseconds
21:40:08.420: Switched to scene 'Scene'
21:40:08.420: ------------------------------------------------
21:40:08.420: Loaded scenes:
21:40:08.420: - scene 'Scene':
21:40:08.421: - source: 'Game Capture' (game_capture)
21:40:08.421: - source: 'Browser' (browser_source)
21:40:08.421: - source: 'Slogan and Logo' (group)
21:40:08.421: - source: 'Social Media' (group)
21:40:08.421: - source: 'Webcam and Overlay' (group)
21:40:08.421: - source: 'Character' (image_source)
21:40:08.421: - filter: 'Color Correction' (color_filter)
21:40:08.421: ------------------------------------------------
21:40:08.509: CalculateFileHash: Failed to open file 'C:\Users\Bobby\AppData\Roaming\obs-studio\updates\whatsnew.json':
21:40:08.568: ---------------------------------
21:40:08.568: [DShow Device: 'Webcam'] settings updated:
21:40:08.568: video device: Logitech HD Pro Webcam C920
21:40:08.568: video path: \\?\usb#vid_046d&pid_082d&mi_00#6&cf61f2d&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\{bbefb6c7-2fc4-4139-bb8b-a58bba724083}
21:40:08.568: resolution: 640x480
21:40:08.568: fps: 30.00 (interval: 333333)
21:40:08.568: format: I420
21:40:08.687: adding 23 milliseconds of audio buffering, total audio buffering is now 46 milliseconds

Its probably also worth mentioning that these issues also happen on other recording software's such as XSplit, Bandicam and AMD ReLive so the problems I'm having are not just limited to OBS. Anyways I hope I've covered everything needed to help solve this!

Cheers guys and thanks for reading! :)
Last edited:


New Member
OK guys here's an update! :) So basically after exhausting all options I finally decided to focus on fixing potential hardware issues instead. Upon doing some testing using temp monitoring software (HWMonitor) whilst trying to stream and record I was noticing that my CPU temps were waaayyy too high so I decided to take out my water cooling system and replace it with cheap heatsink I brought off Amazon for testing purposes to see if my water cooled system had failed.

Low and behold my temperatures dropped when under load by around 30 degrees!!! So I started to do a stream test whilst also recording at the same time and not only was the recording and stream successful but there was no micro-stutter or audio latency at all and I did the test for well over 45 minutes when usually the stuttering would occur regularly after around 10 minutes into play.

To surmise I believe what was happening was that my CPU was getting so hot that I was experiencing CPU thermal throttling in game which I misinterpreted as a recording/streaming issue which caused the dropped frames and audio stutter that you can see in the video.

So my advice here is if anyone is having a similar problem to what is being demonstrated in the video I would recommend monitoring your temps and if they are high and you are using a water cooled system then you may have a faulty pump and you may want to consider getting a cheap heatsink which matches your CPU socket type (this can easily be found out by using a software called CPU-Z and looking at the package information) and once installing the heatsink try rerunning your recording/stream to see if you lose the frame drops/audio lag. Anyways I hope this helps someone eventually, happy streaming guys!
Last edited:


Active Member
you are using a water cooled system then you may have a faulty pump and you may want to consider getting a cheap heatsink which matches your CPU socket type
The reason might be even simpler. It might be that you simply did not mount and fix the heatsink correctly onto the CPU in the first place. The surfaces must be absolutely clean. No fingerprint, no fluff. Fluffs extend the gap between heatsink and CPU, lowering the heat conduction.
If you replace a heatsink, surfaces must be cleaned thoroughly from the previous heat-conductive paste, for example with rubbing alcohol.
If a CPU with a mounted heatsink was turned on once, you must not put off and remount the heatsink without thorough cleaning and applying fresh heat-conductive paste, because once a paste was heated, it is changed physically (baked) and remounting with baked paste leaves tiny air bubbles. And air bubbles don't conduct heat.
Even if you did not turn it on, one should clean and put on fresh paste, because remounting with existing paste on both surfaces will produce air bubbles within the paste.

Sorry for my rambling, but one time I will write a monograph about mounting heatsinks for sure.