Question / Help Sudden choppy audio on stream output

Im having this issue, the stream will run fine fo about 40 minutes and then it will have this glitch. Almost sounds like the audio Bit rate drops?

Any Fixes for this yet?

Our audio and video is coming from a Blackmagic Ultrastudio Recorder 3G into Our new M1 Mac Mini into OBS streaming to Castr.

Examples of problem:
starts around here and only gets worse as the video goes on: https://youtu.be/WnlWUVJsR_4?t=2624

Here you hear it and then we turn the stream off and on, on OBS for a split second, and it fixes it? https://youtu.be/_s7idqS5uRc?t=3108

Thanks in advance for any help
 

OllieBeanz

New Member
I had this issue as well and it took forever to track down. In the end it was making sure all sample rates are equal and disabling any unused audio devices. Essentially it seems like OBS get's maxed out on how much audio bandwidth it can process. I made a video showing my fixes, hope it helps.

 

TheBatHuman

New Member
This may help some people, but probably not all as I think there are sometimes different problems creating the same issue. For example, differences in sample rate between audio devices and latency settings if using a program like VoiceMeeter. For me, though (At least this time around) the problem was different;

Instead of adding audio sources in Streamlabs OBS through the audio options menu I added my audio sources into Scenes through "Capture Audio Device". I did this so I could control the audio levels of my inputs per scene rather than have them all active/the same level in every OBS scene - and also because, as someone who uses VoiceMeeter with a fair amount of audio inputs/outputs, I was having trouble trying to add all of the different audio sources in the audio options menu due to there being limited Mic/Aux Input options.

To fix the stutter (Which usually came about 4-5 hours into a stream, and, though not confirmed, I imagine was exacerbated by switching between scenes) I deleted ALL of my audio inputs in each scene and had to just add them all through the general options menu in OBS.

This solved the issue, however it's annoying because I no longer have greater control over the audio sources in my scenes and I am also down two audio sources due to the OBS limitations in the options.


Hopefully this adds one more solution to the audio stuttering issue. All the best!
 

midimarc

New Member
I was having this issue with NDI as a source (choppy audio). I checked everything: sample rates, bit rates, audio bit rate. I was at my wit's end, then clicked Properties for NDI source, and changed the "Sync" setting from "Source" to "Network" and boom! Clean audio!
 

Attachments

  • Screen Shot 2021-07-08 at 7.01.24 PM.png
    Screen Shot 2021-07-08 at 7.01.24 PM.png
    520.9 KB · Views: 198

scrane

New Member
had similar crackly audio when streaming to YouTube. Audio runs to PTZ NDI/HX camera then computer(M1 Mac) then OBS to stream.
Eliminated: audio source/ properties/ Bandwidth...changed 'highest' to 'lowest' or 'Audio only'. Wish I knew why.
 
Top