Question / Help Stream Echo with Dolby Surround. (Logitech G430)

Status
Not open for further replies.

Kristoffer Delin

New Member
When i stream with OBS i get this very wierd echo that i've never experienced before, as you can hear on this recording:
https://www.youtube.com/watch?v=2sJ8aU46I78&feature=youtu.be
(i recorded a stream just as an example of how the sound is)
http://www.twitch.tv/beefyjonez/v/21629071 and this is my latest cs:go stream, same issue.

This is also recorded using OBS and you can clearly hear that it's different:
https://www.youtube.com/watch?v=X_e7s7b6Tqs

(No it's not a rendered video file, this is actually me recording the vegas preview with OBS to skip the hour rendering time).

This problem started to appear when i decided to try a new pair of corsair headset void USB.
The sound in that headset were so bad i went back to my G430, thats when all of this started.
One funny thing about this is that when i disable my own 7.1 (in my headset) the recording is fine, i don't get this echo.

I have tried to reinstall OBS, reinstall the headset drivers.. ive tried everything and this problem really makes me want to stop recording and streaming.

I attached the Log file from when i recorded this.

/Beefyjonez
 

Attachments

dping

Active Member
When i stream with OBS i get this very wierd echo that i've never experienced before, as you can hear on this recording:
https://www.youtube.com/watch?v=2sJ8aU46I78&feature=youtu.be
(i recorded a stream just as an example of how the sound is)
http://www.twitch.tv/beefyjonez/v/21629071 and this is my latest cs:go stream, same issue.

This is also recorded using OBS and you can clearly hear that it's different:
https://www.youtube.com/watch?v=X_e7s7b6Tqs

(No it's not a rendered video file, this is actually me recording the vegas preview with OBS to skip the hour rendering time).

This problem started to appear when i decided to try a new pair of corsair headset void USB.
The sound in that headset were so bad i went back to my G430, thats when all of this started.
One funny thing about this is that when i disable my own 7.1 (in my headset) the recording is fine, i don't get this echo.

I have tried to reinstall OBS, reinstall the headset drivers.. ive tried everything and this problem really makes me want to stop recording and streaming.

I attached the Log file from when i recorded this.

/Beefyjonez
in windows recording devices (right click on the speaker icon) select your mic and to go properties, there enhancements tab and disable all enhancements
 

Kristoffer Delin

New Member
in windows recording devices (right click on the speaker icon) select your mic and to go properties, there enhancements tab and disable all enhancements
its not my microphone that gets an echo, thats the only thing that doesnt have a echo.
and yea ive tried what you said anyway and it didnt change anything.

thanks for the suggestion tho
 

TheNerdShow

New Member
When i stream with OBS i get this very wierd echo that i've never experienced before, as you can hear on this recording:
https://www.youtube.com/watch?v=2sJ8aU46I78&feature=youtu.be
(i recorded a stream just as an example of how the sound is)
http://www.twitch.tv/beefyjonez/v/21629071 and this is my latest cs:go stream, same issue.

This is also recorded using OBS and you can clearly hear that it's different:
https://www.youtube.com/watch?v=X_e7s7b6Tqs

(No it's not a rendered video file, this is actually me recording the vegas preview with OBS to skip the hour rendering time).

This problem started to appear when i decided to try a new pair of corsair headset void USB.
The sound in that headset were so bad i went back to my G430, thats when all of this started.
One funny thing about this is that when i disable my own 7.1 (in my headset) the recording is fine, i don't get this echo.

I have tried to reinstall OBS, reinstall the headset drivers.. ive tried everything and this problem really makes me want to stop recording and streaming.

I attached the Log file from when i recorded this.

/Beefyjonez
So do you have a external mic and a mic on your headset? It sounds like you are getting sound from two sources at once. Also try to uninstall any drivers from the corsair headset and see if that helps.
 

dping

Active Member
its not my microphone that gets an echo, thats the only thing that doesnt have a echo.
and yea ive tried what you said anyway and it didnt change anything.

thanks for the suggestion tho
you could do the same thing for your headset and see if that fixes it. Also leave your audio encoder to AAC. its more compatible with software for editing and youtube.
 

Kristoffer Delin

New Member
So do you have a external mic and a mic on your headset? It sounds like you are getting sound from two sources at once. Also try to uninstall any drivers from the corsair headset and see if that helps.
No the microphone I have on the headset is the only microphone I have and it's also the only enabled device.

It's not external and it's all in like this USB sound card.

Yes everything from corsair is removed, and I contacted their support and they say that their software doesn't change any settings in Windows either.

So my problem is really difficult and I can't find any answers or anyone that have had anything even close to my issue
 
Last edited:

Kristoffer Delin

New Member
you could do the same thing for your headset and see if that fixes it. Also leave your audio encoder to AAC. its more compatible with software for editing and youtube.
Well the thing is that the only options I have is to disable my surround sound and that does help me with my issue, but that's like the whole point of this thread, I want to be able to use my 7.1 while streaming. Other then that there is no enhancements to disable.
 

dping

Active Member
Well the thing is that the only options I have is to disable my surround sound and that does help me with my issue, but that's like the whole point of this thread, I want to be able to use my 7.1 while streaming. Other then that there is no enhancements to disable.
When you uninstall your headset drivers, do it in programs and features first, then go to device manager, right click on the headphones in there and click uninstall, make sure you check remove driver. reboot (very important), then install the latest G430 drivers/software for the headset.

EDIT: you might have to plug back in the corsair headsets to uninstall the driver. but there is something that it changed or else you wouldn't have this issue. its probably some conflicting 7.1 settings. not sure, this is just a guess.
 

Kristoffer Delin

New Member
When you uninstall your headset drivers, do it in programs and features first, then go to device manager, right click on the headphones in there and click uninstall, make sure you check remove driver. reboot (very important), then install the latest G430 drivers/software for the headset.

EDIT: you might have to plug back in the corsair headsets to uninstall the driver. but there is something that it changed or else you wouldn't have this issue. its probably some conflicting 7.1 settings. not sure, this is just a guess.
OK thanks, I will try this all in the morning.
Will update when it's done, thanks for the tip!
 
Status
Not open for further replies.
Top