Source Record

Source Record 0.2.6

Cepas28

New Member
Hello. The plugin is great, thank you for that @Exeldro ! But I noticed one issue while recording my 4-5 hour length streams with it to avoid the alerts on the screen. The recording starts fine, but after a while the audio starts to drift away from the video, at the end of it the audio might get delayed for as long as 2-3 seconds. With the help of Deivedux in OBS Discord we managed to figure out something. We think that it might be skipped frames issue, cause OBS would by default repeat a frame in place of a skipped one, but the Source Record seems to actually skip it and places the next rendered frame instead. So in this case audio is still being recorded for the skipped frames, although they were ignored by the video recording part of the plugin. And thats probably how at the end of a such long recording I have an audio delay of 2-3 or even more seconds, cause I imagine frames are being skipped more than once during such long recording.

Here is a link to the videos that helped us figure this out: https://we.tl/t-D5SBaaCRAy

The one named Gameplay is recorded with Source Record and you can see that it fast forwards those frames that were not fast forwarded in the original OBS recording. Due to that the audio gets delayed when you listen to the player steps.

If the link expires before you can see it, please contact me, so I can send them to you again, cause I have them on my PC.
 

ckbcowboy

New Member
Is there any way in OBS to be able to press "Start Streaming" but instead of it streaming the OBS output, have it stream a single source with the Source Record filter on it and Stream settings enabled?

I have the filter all set up, and it works great (thanks!!) but I'm finding it awkward to actually stream. I'd rather not set the filter "Stream mode" to Recording or Virtual Camera, because I use them for other things. I've tried setting it to Always and toggling the filter on/off, but I can't seem to find any way to see that the filter is actually on or off, short of opening up the Filters panel for the source, which isn't really practical while streaming.

Any ideas? Thanks!
 

Vaesive

New Member
Experiencing some funkiness that I'm hoping someone can point me to what's going on.
I have my Main recording which just records everything on the scene that OBS is showing and I have a Game recording that just records the game I'm playing.
The issues I'm seeing are 1. The game recording is much more blown own that the main recording and 2. the game recording seems to be at a different speed for some reason? No dropped frames between the 2 recordings but when I imported both the recordings into 2 different video editors the gameplay recording got out of sync with the main recording over a short amount of time. Ideas?
 

Hjohnson757

New Member
Is there documentation on using the replay buffer feature? This is the killer feature I've been waiting for, but when I tried to use this like the regular replay buffer, nothing happened though I know that the source is being recorded.

THANK YOU, EXELDRO!
Did you ever figure this out? I am having a similar problem.
 

ckbcowboy

New Member
@Exeldro I'm trying to stream and record a scene and I've noticed a few things:

1. If I set Encoder to "NVIDIA NVENC H.264 (new)" it only streams/records my Program output, not the scene that I've put the filter on. If I set it to "NVENC", it streams/records the scene.
2. No matter what audio sources I put in the scene, or if I enable "Different Audio" and select a source there, it only streams/records the Program audio.
 

Uxmbra

New Member
Awesome plugin!, Would love to see the implementation of multi-track recording. otherwise, amazing plugin!
 

noneil

New Member
Hello,

I am running OBS 27.0.1 on Mac mini M1. I've installed source record plugin and activated the source record filter, but when I to use source record, it crashes OBS. When I deactivate source record in the filter, OBS acts as normal. Can this be fix?

Thank you,
Nick
 

GaroShadowscale

New Member
@Exeldro first off, thank you for creating such an amazing plugin! If it works, this is amazing! I have to have 2 separate instances of OBS to achieve what you're enabling with this plugin.

Unfortunately I have the same issue that @Cepas28 and @Vaesive are experiencing. The audio becomes more and more desync'd with the video for longer recordings.

I tried multiple things:
1) I used the "NVIDIA NVENC H.264/AVC (via FFmpeg) encoder" and unchecked the "Different Audio" box. With this method, I recorded just my camera and gameplay separately. I also used standard OBS recording to record my multitrack audio with everything combined. I put all 3 files in Da Vinci Resolve and both source record video durations were shorter than the standard OBS recording, which looks like @Cepas28 's issue where source recording might be skipping frames.

2) I used the "NVIDIA NVENC H.264/AVC (via FFmpeg) encoder" and checked the "Different Audio" box. This time I used audio track 1 (microphone) with my camera source recording and audio track 2 (Gameplay audio) with my gameplay source recording. The audio duration matched the video duration, but somehow the video and audio still get more and more desync'd over time.

3) I tried the same thing as step 2, but I just used the regular NVENC encoder this time (not the "new" one, because I'm aware that the new one has issues). Unfortunately it had the same exact problem
 

DignifiedRain

New Member
As some of the others have stated. No matter what encoder I used, the audio ends up shifting 5-15 seconds after skipping a few frames during the recordings. I have tried every option encoder, adjusted all the settings.

This is a great plugin, and I REALLY want to use it. Let me know what I can send you to help.
 
D

Deleted member 351566

As some of the others have stated. No matter what encoder I used, the audio ends up shifting 5-15 seconds after skipping a few frames during the recordings. I have tried every option encoder, adjusted all the settings.

This is a great plugin, and I REALLY want to use it. Let me know what I can send you to help.
I am having the same issues as above, my audio desyncs overtime.

I am using NVENC, and using the 2nd audio track option to pull in audio, the 2nd audo track fixed audio sound issues but still desyncs off video over time.
 

ckbcowboy

New Member
Looking back at some recent streams since I switched over to using the source record plugins, I can see that the audio is WAY out of sync with the video. So, yeah, I'm having the same problem. Next time, I'll record a video of the main OBS output so I can compare the two and see if that one is in sync.
 

Bluescreen

New Member
Same issue with the audio desync problem here! It's a really awesome plugin, but the sound is highly off after a couple hours of streaming. In the last 30 minutes of my recording, sound was even gone completely.

Are there any updates to the sound issue, yet?
 

DJKoeller

New Member
@Exeldro Having some trouble with the replay buffer. I've been using the replay buffer WITHOUT Source Record for a while now but now I really want to use it with this plugin instead. So I've got my source record setup for my camera and checked the box for Replay Buffer but when I save a replay, it still just saves the entire scene that I am using instead of just the source. I'm sure I'm missing something, still trying to learn about all this. Any advice?
 

ckbcowboy

New Member
Hmmn, I don't think I can use this until the audio latency / sync issue gets fixed. Bummer. Let me know if there's anything I can do to help debug the issue.
 

Recruitlings

New Member
I'm on a 2017 MacBook Pro running all the latest versions of the Mac OS, OBS, and Source Record. This is a fantastic plugin! I live stream sports and I've been looking to add instant replay to my live streams that excludes my scoreboard overlay. I am having two strange occurrences when I hit the replay button. The scoreboard overlay is always recorded and the first second of the replay is always a still frame of the previous clip. I could make the stinger transition longer I suppose, but it's already 2 seconds long. I've tried changing the buffer durations to eliminate the previous still to no avail. I am recording the replay buffer to the internal drive of my computer. Is anyone else having similar issues to mine?
 

tiagoventura

New Member
man, thank you very much to code this plugin, i was searching a solution for multiple source recording, this plugin is exactly what i was looking for...

sugestion: can you give support to install your plugin on Prism Live Studio? PLS PLS PLS
 
Top