Question / Help [SOLVED] No sound from desktop audio during video playback..

EpiclyEpic5

New Member
I wanted to include both of my most recent logs as to what may be causing this issue. It seems that whenever I record anything, the audio bar bounces back and forth like it is receiving audio from my playback device (Steelseries Headset). However, when I play the recording back through, I can only hear what's coming out through my microphone and nothing else. I've already looked through other forums to see if I could find a fix that would work, but I haven't really come across anything that has resolved this issue for me personally. I must be missing something blatantly obvious. Any help is greatly appreciated.

What I've done to troubleshoot so far:
- Made sure OBS is up to date.
- Tried restarting OBS multiple times.
- Running the program as an administrator.
- Changing around the settings in the audio tab for both my microphone and headset to default (and vice versa).

Also here is an image of my settings under the audio tab...
vyxqps.jpg
 

Attachments

  • OBS Last Log.txt
    7 KB · Views: 248
  • OBS Current Log.txt
    5.7 KB · Views: 147

EpiclyEpic5

New Member
Okay, so it seems after doing more research about this problem I've found that this is a media player issue.

I was using the default Windows 10 media player, which I found after searching through similar issues on this forum, only plays what is put into the first track. Inclined to have separate audio tracks for editing, I found what worked for me was going under the mixer, clicking the gear icon and going to 'Advanced Audio Properties.' I set up OBS so it would record both my mic audio and desktop audio in the first track and then additionally checking off the box for my mic in track 2 and my desktop audio in track 3, so I could assess them individually later on via post-processing.
ke67er.jpg

Using VLC media player as others suggested on here was a good way to test that I was in fact recording the audio (because I was getting a signal and the green bar was moving back and forth in the mixer), but it just wasn't coming through over the media player I was consistently using.
That being said, I think it's safe to say my issue is solved. I've run a couple test recordings and everything is coming through clearly now. If anyone else comes across the same problem, I hope this works for you too. :)
 
Top