Question / Help OBS Stuck at 0 kb/s. weird errors on logs



This started last week, happens every other day... i cant pinpoint the issue.
suddenly OBS drops to 0 kb/s, internet is still working. when i click "stop stream" and click start stream again the problem persist. The only way to fix it is close OBS, open it again, and click 'start streaming again'... but after a while it happen again...
i tried changing twitch ingest server and turning windows firewall off, but still the problem ocurrs.

after reading the logs i've found out a weird thing.... i think this happen after OBS changes to a particular scene:

21:17:15.050: User switched to scene '##DBD Casino'
21:17:15.947: error:   Input contains (near) NaN/+-Inf
21:17:15.947: [FFmpeg aac encoder: 'Track1'] avcodec_encode_audio2 failed: Invalid argument
21:17:15.947: warning: 3 frames left in the queue on closing
21:17:15.947: Error encoding with encoder 'Track1'
21:17:59.110: [obs-websocket] transition begin
21:17:59.121: User switched to scene '#Game Play DBD'
21:18:00.036: error:   Read error at pos. 437 (0x1b5)
21:18:00.042: warning: Could not update timestamps for skipped samples.
21:20:31.667: [rtmp stream: 'adv_stream'] User stopped the stream

other thing i noticed is that after changing profile (from 60fps/3500kbps to 45fps/3000kbps) the problem stopped.

here are the logs:
LOG 1 (error timestamp 21:17:15.050 )
LOG 2 (error timestamp 21:42:03.716 )


Forum Admin
So, the two things that jump are are (obviously)

21:17:15.947: error: Input contains (near) NaN/+-Inf


21:18:00.036: error: Read error at pos. 437 (0x1b5)

I can see one of a few things being the cause here. Either you have a failing harddrive, and trying to load some sort of local media is corrupting and sending bad audio/video to the encoder and the encoder just stalls out, or you have some other kind of hardware failure (probably RAM in this case).

I would recommend making sure that all your drivers are up to date, and try to run a memtest86 when you have time to eliminate the RAM failure.


ty for reply!

i norrowed down the Read error at pos. 437 (0x1b5) to a particular .webm file (file1.webm) . i redid a different webm to remplace file1.webm and i got a similar error: Read error at pos. 741 (0x2e5)

i tried to re-encode the webm file with a different program to discard an encode error but got the same results. others things i tried: disable hardware acceleration, change the webm location (other hdd, pendrive). still error.

last thing i did was use the original .mov file (44mb) instead the webm file (200kb) on OBS and this time there is no error.

but i think using big mov files on OBS is not a good option...
maybe obs is having trouble handling this type of files?
Last edited:


So, the two things that jump are are (obviously)

21:17:15.947: error: Input contains (near) NaN/+-Inf

hi @Fenrir well i finally fixed OBS being stuck at 0kb/s.

as you said the encoder stall out trying to load some sort of local media. in this case a scene has a media source with an mp3 in it, doesnt matter what mp3 was in it, the encoder stall out... and the logs show this error:
error: Input contains (near) NaN/+-Inf

why the FFmpeg encoder can play a random mp3? i dont know.

i fixed it installing CoreAudio AAC encoder
after that i dont get the error: Input contains (near) NaN/+-Inf anymore, no more OBS at 0kb/s. Yay!

...but i dont know if its a coincidence or what but now my stream has no audio when viewers use 360p or 160p! on Twitch.
Audio on stream works ok at 720p & 480p but at 360p/160p there is no sound.

Twitch reencode went nuts cause im using CoreAudio AAC encoder instead FFmpeg? i dont know.
Last edited:


Forum Admin
Can you upload one of the files that was causing this issue? I'd like to do some testing on my end.