Resource icon

obs-ndi - NewTek NDI™ integration into OBS Studio 4.9.1

pollen97

New Member
Thank you very much for your plugin!I have tested it and it works perfectly while we use office 2016 on windows7. At the same time, while we use office 2019 on windows10, it also displays a blank window. Could you give us any suggestions? We are looking forward to hear good news from you! Thank you very much!
 

Narcogen

Active Member
If Office 2019 is from the Microsoft store, OBS won't be able to capture it except via display capture. Nothing to do with NDI.
 

Provensis

New Member
Hey,
I got a problem. I run NDI on a PC and a Macbook. When I only got my webcam it works perfectly, 1080p 60fps no problem. But when I put a Screen recorder or GameCapture on, it freezes and only the audio works.
No errors or anything.

PC is gaming computer, Macbook is encoder computer.
They got the same version of NDI. It worked for a couple of months ago.
 

Nile1230

New Member
Hey,
I have been using obs and the NDI plugin for about a month now for my youtube channel. We use skype and then add the NDI of the guest so everyone has their own window. Now when I try to add another guest to the show I get a black screen. This is happening on 4 different computers we use for production. Was there an update that has now cause this to be incompatible? Please help if you know a fix.
 

MartiieZ

New Member
Screen Shot 2562-04-24 at 14.55.51.png


I got this error when I install NDI 4.6.0 on my Mac (Mojave)
 
Last edited:

kalle2k_tv

New Member
Is there a way to manually limit the bitrate streamed at on the Main PC? When I'm on the stream PC doing encoding the stream freezes, but when setting it to low bandwidth mode it is fine. Only issue is that low bandwidth looks HORRIBLE and lowers the res.
 

ArtK

New Member
Palakis submitted a new resource:

NDI Input/Output plugin for OBS Studio - NewTek NDI™ integration into OBS Studio



Read more about this resource...
OBS 23.1.0 (PC Windows 7 Home Premium) Using NDI w Skype. Some latency issues - Should I select Latency Mode Low (experimental)? Would be helpful to understand this more fully. ALSO understand Skype does not yest offer separate audio streams, any way to capture each participant's audio stream separately? Thanks.
 
Heya,

Small issue I've ran into, not sure how to fix.

Using latest obs and NDI plugin, with latest NDI framework installed (May release).
When set up, the Gaming PC is able to transmit audio but the streaming PC only receives a green screen when using Main output.
With Preview output I get video but no audio.

OBS Logs show an error (around the time NDI is being initialized) stating that libobs has a size limit (160kb) but it was trying to load something that is 178kb - NDI then reports a failure to load.

Will attempt to downgrade, but was wondering if you'd encountered this issue and were mid-fix?
 

Malic

New Member
When I run NDI and use the bandwidth highest setting on the stream computer, the video works fine *as long as the stream is not active* but the moment that the stream is started, the stream does not connect, the stream computer freezes up to the point that the mouse is not moveable, ect. On Twitch the stream goes up for individual frames, and then cuts out again... enough to trigger the temp disconnect feature Twitch now has.

If the setting is set to lowest, it works fine, but the quality is horrible.

I was trying to send a 1080p signal though the network. My router is a 1gbit connection, so I am not being limited by that.

It can send a 720p signal though the network at highest bandwidth settings just fine.
 

stormerjack

New Member
I am having an issue. I have my character in OBS and everything is fine but as soon as i minimize adobe character animator the character in OBS freezes. I have tried running it as admin too.
 

Narcogen

Active Member
I am having an issue. I have my character in OBS and everything is fine but as soon as i minimize adobe character animator the character in OBS freezes. I have tried running it as admin too.
Please post in the support forum for the relevant platform-- this thread is about release updates for a 3rd party plugin (NDI).
 

Narcogen

Active Member
There is a place to report issues on GitHub:

https://github.com/Palakis/obs-ndi/issues

However, you didn't actually mention the plugin at all in your post so I wasn't sure you were using it.

Since you seem to be using that to send an NDI signal to OBS, I'm guessing what is happening is that the feed doesn't update any more when you minimize the window; sort of like what happens to a window capture when you minimize the window.
 

shutyertraps

New Member
I'm brand new to OBS and am going nuts trying to figure out the following issue...

I'm am wanting to livestream my podcast partner's camera with mine. All signs pointed to using Skype as the best capture option for his cam, and downloading the NDI plugin to make it work. I did just that, I went into Skype and activated NDI, I created a new scene for that camera feed in OBS and selected NDI as the source. Essentially every step the YouTube videos showed. Only problem is, all I see is a black screen with a little red square in the upper left corner. I tried dragging that square, in case I was just needing to expand the window or something, and it disappears.

I am running a Windows 10 machine, the latest version of OBS (23.1). I am looking for any suggestions to get me past this issue. As I said, I've no experience with OBS and have left all the settings pretty much at default. Or maybe there's an even better suggestion as to how to get a remote camera feed into OBS?
 

Narcogen

Active Member
And when choosing NDI as a source, you see a list of available sources and chose from that the name of the NDI feed supplied by Skype? And then tested with an active call?
 

shutyertraps

New Member
Yes, I did see the list of available sources and selected the name of the NDI feed supplied by Skype from an active call.

Of note, in my Skype window I see the camera feed of the active call and when I go into OBS and select that 'scene' (let's call it Skype Cam), over on the Skype side of things a small pop-out window appears with a duplicate of the camera feed image I'm trying to get in OBS. If I close that window and then select Skype Cam again in OBS, that pop-out window once more appears.
 

Khaduran

New Member
I have a problem where it looks like my nvidia drivers crash on my streaming PC when encoding with nvenc(new) and do something simple like opening chrome or anything else graphical from the streaming pc. Monitor becomes black, stream crash (still running after recover, green artifact instead of the ndi capture (sometimes)) and monitor recovers just like a drivers crashed. This does not happen if I run a normal window capture or display capture instead of NDI capture

Gtx 1660 card
Latest nvidia drivers
Freshly installed windows 10

Edit: Stream can go well for hours until I do something else on the streaming PC that might be gpu intense.
 
Last edited:

Narcogen

Active Member
Yes, I did see the list of available sources and selected the name of the NDI feed supplied by Skype from an active call.

Of note, in my Skype window I see the camera feed of the active call and when I go into OBS and select that 'scene' (let's call it Skype Cam), over on the Skype side of things a small pop-out window appears with a duplicate of the camera feed image I'm trying to get in OBS. If I close that window and then select Skype Cam again in OBS, that pop-out window once more appears.

I'm guessing that Skype is putting up a preview window for the NDI feed, and perhaps closing the window is shutting down the feed until you add it back in OBS again? Is it necessary to close the window?
 
Just an update:
Completely removed all traces of NDI and OBS, full restart.
Reinstalled OBS, NDI SDK, Plugin

All fixed.

Heya,

Small issue I've ran into, not sure how to fix.

Using latest obs and NDI plugin, with latest NDI framework installed (May release).
When set up, the Gaming PC is able to transmit audio but the streaming PC only receives a green screen when using Main output.
With Preview output I get video but no audio.

OBS Logs show an error (around the time NDI is being initialized) stating that libobs has a size limit (160kb) but it was trying to load something that is 178kb - NDI then reports a failure to load.

Will attempt to downgrade, but was wondering if you'd encountered this issue and were mid-fix?
 
Top