Question / Help OBS doesn't recognize AVerMedia LGP Stream Engine [resolved]

Status
Not open for further replies.
#1
AVerMedia released a Stream Engine so that the LGP can be used as a video capture device on OBS. After installing the drivers and software for AVerMedia's Live Gamer Portable and then installing OBS, everything seems to be fine. The Stream Engine shows up in the Device Selection list. I streamed a little yesterday trying to test it and figure out the settings I need to have for a good looking and sounding stream.

After closing OBS and re-opening it, OBS doesn't seem to want to recognize AVerMedia's Stream Engine as a Device anymore. Anyone else having this issue? The only way I have found so far to fix the problem is to uninstall OBS and AVerMedia's software, remove anything leftover from the uninstalls, reinstall AVerMedia's Software including the Game Engine, and then reinstalling a fresh OBS. Then the Stream Engine will show back up in the list, but after closing OBS and reopening it, it's gone and not a selection anymore.

Can someone help me figure out a much easier way to fix this problem? Thank you.
 
#2
Re: OBS doesn't recognize AVerMedia LGP Stream Engine

People have been discussing this on the LGP forums since the Beta started, heres one example ; http://forum.avermedia.com/index.php?th ... #post-2990 . So I would imagine a safe bet also would be to check up on some of their experiences as well. Also you can post of your experiences with the Stream Engine Beta here : http://forum.avermedia.com/index.php?th ... aring.573/ So that they can see it.

I will not be able to personally test it until I receive my LGP in a couple of days either, I am curious if I will encounter similar issues. Also just as a question, have you fully updated the LGP to the newest firmware etc? [ http://forum.avermedia.com/index.php?th ... age-1.471/ ] You do NOT have to upgrade your LGP if it works for you or do not wish to possibly encounter any issues stated in the thread, but just a mention.
 
#3
Re: OBS doesn't recognize AVerMedia LGP Stream Engine

I'm sort of in the same boat. The stream engine is awesome when it works with OBS. (Tried with Xtrash aka Xsplit) it shows up all the time on that list, but does not add. Anyhow, opening and closing it for me when currently installed is absolutely fine, but when you restart it, it doesn't show up at all, forcing you to uninstall and reinstalling LGP Stream Engine.

From what I've been reading, apparently the application/device is being least prioritized (occupying the source of LGP Stream Engine), therefore not showing up when you restart, so when you reinstall, it comes back up as a "first on the list" kinda thing. There's something on each of our computers that is occupying that spot for the Stream Engine. So unless AverMedia fixes this program as soon as possible, this is how we generally have to deal with it. Trust me, I stream, it's a pain.
 

Fizzi

New Member
#4
Re: OBS doesn't recognize AVerMedia LGP Stream Engine

I was having the same problem and I think I figured out the cause and current workaround.

For me, Stream Engine seems to be conflicting with Skype (it may also have something to do with Skype + my webcam). I'm using Windows 7 64-bit and a Logitech C250 Webcam.

When Stream Engine does not show up in OBS do the following:
1) Close OBS and Skype.
2) Reopen OBS - Stream Engine should now show up.
3) It should be safe to reopen Skype now.

Hope this helps.
 
#5
Re: OBS doesn't recognize AVerMedia LGP Stream Engine

Fizzi, you are a GOD! That is precisely the problem! Quitting Skype makes the LGP interface show up. You have no idea how happy it makes me that I can stream with OBS instead of XSplit.
 

DeuS

New Member
#6
Re: OBS doesn't recognize AVerMedia LGP Stream Engine [resol

This is for all the people that will come after and find this thread, I had the same problem as above, OBS would not detect the stream engine, and I tried what Fizzi said which is disable Skype and didn't work.

Please check your webcam software, It turns out I my HP webcam had something running in the background called HP button manager, I shut that down and everything worked.

Other than that think of any other kind of device thats connected that can output video and might be interferring with LGP. Hopefully this will help someone in the future
 
#7
Hello, sorry for waking up the dead one, i recentl;y bought avermedia and i have the same problem as you all and closing skype helped for couple times but now it doesnt i cant get it to detect the stream engine. I have no idea what is causing it, i am trying to close everything that i can imagine, no luck so far. I dont have a webcam or anything.

I dont want to sel this card because of stupid problem like this. No idea which programm or stuff could i try. Should i reinstall stream engine?


EDIT: Thx for helping, reinstalling stream engine helped.
 
Last edited:
#9
[FIXED] Hey all I know late bloomer but I couldn't find a fix anywhere so I tried myself and it's so simple.
So it wasn't Skype, Chrome, nor my webcam! I have left a link of a video I made on a simple fix.

Really hope it works for you!

https://youtu.be/ld_v7xjTbP0
 
Last edited:
#10
Hey everyone,

Anyone managed to get this working? I tried everything and I still dont see LGP Stream Engine in OBS (32bit or 64bit).

I managed to make AverMedia C875 Capture work with my PS4 by turning off HDCP by going to settings > system > HDCP OFF, but it transfers video, but no audio.

I was excited when I got my LGP Lite today, and now im down because Im not able to make it working :((((

Thanks everyone for any help that will lead to success.
 

Harold

Active Member
#15
According to reports I've gotten, the use of the stream engine is no longer needed, you should be able to directly add the LGP to OBS as a video capture device without the need for the stream engine.
 
Status
Not open for further replies.
Top