Question / Help OBS crashing upon streaming/recording

ImminentSauce8

New Member
Hey, I've been having an issue for the past few weeks where my OBS is crashing whenever I start streaming or recording. Any help would be appreciated. I attached the crash log.
 

Attachments

  • Crash 2018-08-19 21-11-19.txt
    70.1 KB · Views: 358

RytoEX

Forum Admin
Forum Moderator
Developer
Could you post a regular log file for this crash as well?

That's a crash in the NVIDIA drivers, so it seems like a driver issue, an invalid encoder setting that's not being caught, or too many NVENC instances. If your drivers are outdated, try updating them. If they are up to date, try rolling back.
 

RytoEX

Forum Admin
Forum Moderator
Developer
Yes, that's what I was looking for. The NVENC parameters seem fine. I did notice that you're running OBS on your Intel GPU for some reason. You can try running it on your NVIDIA GPU instead to see if that prevents the crash. Otherwise, I'd check your NVIDIA drivers. Update, reinstall, or downgrade them as needed.
 

ImminentSauce8

New Member
I tried downgrading my drivers and using my NVIDIA GPU but it still crashed.
 

Attachments

  • Crash 2018-08-20 12-34-22.txt
    68.1 KB · Views: 54
  • 2018-08-20 12-33-38.txt
    5.5 KB · Views: 33
  • Crash 2018-08-20 12-34-22.txt
    68.1 KB · Views: 33

RytoEX

Forum Admin
Forum Moderator
Developer
That second log doesn't show OBS running on the NVIDIA GPU. Try plugging your monitor into your NVIDIA GPU instead of the Intel GPU (the motherboard/built-in/integrated GPU), and then try forcing OBS to run on the NVIDIA GPU either in Windows Graphics settings or in the NVIDIA Control Panel.

Don't set the GPU field to 1, leave it at 0.

The crash is still occurring in the NVIDIA drivers. Make sure you have NVIDIA Shadowplay disabled.

Please download GPU-Z and post a screenshot (the camera button in the program and upload to free image hosting). You may need to take one screenshot for each GPU page (the GPU can be selected at the bottom).
 

ImminentSauce8

New Member
GPUinfo.gif
 

ImminentSauce8

New Member
here's the most recent stuff just in case anything changed
 

Attachments

  • Crash 2018-08-21 22-07-13.txt
    75.6 KB · Views: 40
  • 2018-08-21 22-07-09.txt
    5.9 KB · Views: 32

RytoEX

Forum Admin
Forum Moderator
Developer
You've got a problem. GPU-Z indicates that CUDA isn't supported by your GPU, but it definitely should be, and your crashes are happening in nvcuda.dll. Here's an example of a working GTX 1060:
GPU-Z.png


At this point, I'd suspect you either have a bad driver installation or faulty hardware.

Use DDU to perform a clean driver installation of the latest NVIDIA driver. You can perform a clean driver installation for your GPU by following these instructions.
 

ImminentSauce8

New Member
It didn't work and I'm pretty sure I did everything correctly
 

Attachments

  • Crash 2018-08-22 20-29-46.txt
    77.6 KB · Views: 36
  • 2018-08-22 20-29-17.txt
    6.1 KB · Views: 24

Suslik V

Active Member
New screenshot from the GPU-Z required, to prove that you did it right. Maybe this is hardware malfunction.
 

RytoEX

Forum Admin
Forum Moderator
Developer
CUDA is definitely still broken. The common causes of this that I can find are:
  • overly aggressive antivirus/security software
  • CUDA disabled in NVIDIA Control Panel
  • UAC disabled during install resulting in a bad driver install
  • bad/corrupted driver install
  • corrupted OS files
  • faulty hardware
You can try disabling your antivirus/security software temporarily and re-running the driver installation normally to see if that changes anything in GPU-Z. If it doesn't, check the NVIDIA Control Panel for the CUDA setting (I think it's under Manage 3D Settings). If that doesn't help, check for PC BIOS updates. If that doesn't help, go through the DDU process again, but for both Intel and NVIDIA, and make sure Norton isn't enabled while running the installers (it shouldn't be enabled if you're in Safe Mode anyway).

If all that fails, I might be out of ideas. Of course, you could also use x264 instead of NVENC if you need to immediately record/stream, but that doesn't solve the underlying issue here of your NVIDIA GPU having features disabled.
 
Top