Question / Help OBS Capture issue.

Soort

New Member
Hello Guys,

I've started recording Assassin's Creed: Origins.
On my first video i had little spikes on the record, bc i spiked in game too, which is okay.

But now in my recordings, i'm having big laggs and freezes while i had not in the game.
Video Settings:: 1080p, 60fps, Lanczos (Sharpened Scaling, 32samples),
Recording settings: format mp4, rate control CQP: 18, profile 'high', using two-pass encoding.

Pc specs:
- I5 6600k - GTX 1060 6GB - 1TB HDD & 500GB SSD - Z170 PRO GAMING MBU - 2133Mhz Ram(DDR4).


I would like to know why it is hapenning. I mean there is probably something wrong with the recording settings, so if you can guys help me please do it, any idea's or opinions is welcome.


Cheers
Soort
 

Soort

New Member
Please provide a log from OBS when the issue occurs.
The thing is, there is no issue while i'm recording it. The issue is, when the recording is done.
When i look at the video that i recorded, there are freezes/laggs that i didn't have while playing the game.
 

Fenrir

Forum Admin
Yes, which usually means there's an issue with the recording process. Please get a log from OBS so we can see what might be going on.
 

Fenrir

Forum Admin
That log contains dozens of 2-4 second recordings that were started/stopped with a hotkey.

Is that what you intended to do?
 

Soort

New Member
That log contains dozens of 2-4 second recordings that were started/stopped with a hotkey.

Is that what you intended to do?
Definitelly not, i still got the video if u want to see it. The hotkeys are f9+f10 and i never use these while gaming.
 

Soort

New Member
That log contains dozens of 2-4 second recordings that were started/stopped with a hotkey.

Is that what you intended to do?
What i actually want to say is, that the video i recorded with OBS has kind of laggs/freezes when i watch it. But while i was playing the game in the record mode, i didn't have any laggs or freezes.

I'm trying to get to a solution why the recording's has freezes/laggs while i had not a problem ingame.

I've also seen that the desktop audio bitrate in the logs is 160 while i setted it to 320 in settings.
 

Fenrir

Forum Admin
Very, very odd.

Let's try a clean log file. Follow these steps carefully:

To make a clean log file, first restart OBS, then start your stream/recording for ~30 seconds and stop it again. Make sure you replicate any issues as best you can, which means having any games/apps open and captured, etc. When you're done select Help > Log Files > Upload Current Log File. Copy the URL and paste it here.
 

Soort

New Member
Very, very odd.

Let's try a clean log file. Follow these steps carefully:

To make a clean log file, first restart OBS, then start your stream/recording for ~30 seconds and stop it again. Make sure you replicate any issues as best you can, which means having any games/apps open and captured, etc. When you're done select Help > Log Files > Upload Current Log File. Copy the URL and paste it here.
I'm back with the log file you asked for. So the record is like 21second, ingame i had not any laggs again but in the recorded video i have alot of freeze/laggs.

Url: https://gist.github.com/ce0f11a1ed71525c057e196c2ad199f7
 

Misterarther

New Member
I have a similar issue
Did you check your fps in OBS on the buttom right? Mine can't stay consistend with demanding games (in OBS tho but the game is perfectly smooth)
 

Soort

New Member
I have a similar issue
Did you check your fps in OBS on the buttom right? Mine can't stay consistend with demanding games (in OBS tho but the game is perfectly smooth)
My FPS stays at 60, but i didn't test it when recording it. I will update you, gonna try to find the problem.
 

Soort

New Member
Update:

FPS in OBS is around 4-20 while ingame (not recording).
So i think the FPS of OBS is the issue.
I seperated the screens in 2, i was checking AC Origins and my OBS screen(game capture), i saw that my game in OBS was lagging but on the real screen it wasn't.

Is there any solution to this?

Cheers Soortgames
 
Last edited:

Misterarther

New Member
Disable the preview in OBS and tell me if that helps
ALSO: on which Slot is your GPU mine is on the lower one as it wouldn’t fit otherwise

We have pretty much the same problem and right now even Lirik from twitch got the same problem even though he has a 2 pc streaming setup - seems like there is a deeper problem - maybe the latest NVIDIA DRIVERS are causing this problem but I’m not sure
 

Soort

New Member
Disable the preview in OBS and tell me if that helps
ALSO: on which Slot is your GPU mine is on the lower one as it wouldn’t fit otherwise

We have pretty much the same problem and right now even Lirik from twitch got the same problem even though he has a 2 pc streaming setup - seems like there is a deeper problem - maybe the latest NVIDIA DRIVERS are causing this problem but I’m not sure
Hello mister,

My gpu is on the upper slot, it can fit on any slot. There is a chance that nvidia drivers are causing this, but we're not sure.
Coming back to my test, i turned vsync to adaptive mode in AC: Origins, its alot better and the fps is more around 45-60 now and not 4-20fps.

No idea what Aero mode is about but i will search about it soon.

Cheers Soort
 

Misterarther

New Member
Windows aero mode is to disable the fancy task bar and all the windows „effects“ which steal a small amount of performance and sometimes cause trouble for OBS
 

Soort

New Member
Windows aero mode is to disable the fancy task bar and all the windows „effects“ which steal a small amount of performance and sometimes cause trouble for OBS
Its awkward that such a program is causing trouble. I'm going to leave aero as it is.

Update: Record is alot better now and the fps of OBS. Trying to find sollution for 100% guarantee.

Cheers Soort
 

Fenrir

Forum Admin
Also check if disabling Aero mode in windows helps
He is on Windows 10. You can't disable Aero on Windows 10, and it doesn't cause the same issues like it does on Windows 7.

I'm back with the log file you asked for. So the record is like 21second, ingame i had not any laggs again but in the recorded video i have alot of freeze/laggs.

Url: https://gist.github.com/ce0f11a1ed71525c057e196c2ad199f7
From your log:

Code:
23:54:55.330: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 10 (0.7%)
23:54:55.332: Video stopped, number of skipped frames due to encoding lag: 542/1342 (40.4%)
Since you're using NVENC to encode, this indicates that your GPU is simply overloaded. Make sure you're capping FPS or enabling vsync in the games that you're playing to avoid the GPU becoming maxed out.
 

Soort

New Member
Since you're using NVENC to encode, this indicates that your GPU is simply overloaded. Make sure you're capping FPS or enabling vsync in the games that you're playing to avoid the GPU becoming maxed out.
Okay so its nothing about Aero.
Coming back to the GPU, i was using GPU TWEAK to OC my Mhz of GPU. Is that a problem?

Also my CPU (i5 6600k) is working on 90-100% while recording+playing AC: Origins. Can 100% CPU cause problems such as spikes or freezes in OBS?

About NVENC, should i stay as it is or not? If i change to x264, will be the graphics as good as it was, or what whill happen actually.

Thanks for responding!
Cheers Soort
 
Top