Question / Help OBS + Airpods + Sound siphon/sound issue? [RESOLVED + directions inside]

#1
Hey guys! I do live streams and interviews with OBS and I stream to youtube. I use sound siphon to capture my internal audio. And normally I use regular wired headphones to capture my audio. I was gifted apple airpods and I was hoping to use the airpods with OBS but it seems it doensn't work. While recording all the audio levels, and sounds are normal, I see no issues. But when I playback the recording, the internal audio sounds robotic and discorded. I'm not sure if there's a way to resolve this already? But using wireless Bluetooth headphones with OBS would be amazing if that's ever a possibility. Curious if anyone knows a work around or has any idea a way to solve this? thanks!
 

Narcogen

Active Member
#2
Can Sound Siphon play back your microphone into your wired headphones so you can monitor in realtime, outside of OBS? And then within OBS while recording?

In MIDI setup, are the airpods set for the same sample rate as OBS (44.1khz or 48.0khz)?
 
#3
when you turn on Bluetooth devices and connect your headphones do they show up in the audio in the list in system preferences >sound? if they do, then in preferences > audio settings on OBS do they show up in the drop-down box for mic/aux 1? make sure these are set to the airpods in obs and not default, even if you have switched the setting in system settings. you may have to connect the headphones each time before launching obs to make sure they show up if they are supported.
 
#4
Can Sound Siphon play back your microphone into your wired headphones so you can monitor in realtime, outside of OBS? And then within OBS while recording?

In MIDI setup, are the airpods set for the same sample rate as OBS (44.1khz or 48.0khz)?
sound siphon is a driver for the mac to allow OBS to recognize the system audio, its not like a standalone program.
 
#5
when you turn on Bluetooth devices and connect your headphones do they show up in the audio in the list in system preferences >sound? if they do, then in preferences > audio settings on OBS do they show up in the drop-down box for mic/aux 1? make sure these are set to the airpods in obs and not default, even if you have switched the setting in system settings. you may have to connect the headphones each time before launching obs to make sure they show up if they are supported.
They don't show up in the drop down. I tried making a multi output device in the audio midi so that OBS would use my audio into the airpods, and the system audio of the person I'm interviewing. But now the person I'm talking to says I sound like a robot but the audio sounds good on my end.
 
#6
Okay guys I figured it out and wanted to share on the off chance someone ever has this problem as well. I wanted to be able to use my apple AirPods while recording an interview with someone, and also capture the system audio as well. I kept having issues where either I sounded like a robot to the person I was speaking to, or afterwards in the recording my guest sounded like a robot. (ps I'm on an iMac running on Mojave).

First I downloaded iShowU audio capture: http://bit.ly/2S6CscS

Then I followed these steps to setup a multi output device under the audio midi settings: http://bit.ly/2R20l4c
*Now he only caveat is when you're looking at the "multi-output device" there's going to be three things listed, "ishowu", "your AirPods", and "built in output" Make sure only "ishowu "and "your AirPods" are selected on the left side under the "use" column. If built is audio is selected as well, its going to export your voice twice over, which is what causes that robot sound. Here are my settings:


Make use your sample rate for the multi output is ask 44.1 as well as that is what OBS's default setting is.

Now if you're using the AirPods after all of this and the volume is super low, you can't use the normal volume up buttons on your computer because you've made a custom device. You have to do back into the midi device setting and adjust it. Click "your AirPods" the one that says it has "2 outs". You'll have to increase the volume bar on 1 and 2, as it controls either ear bud independently.



I really hope this helps someone. It took me weeks of passively tinkering to figure it out.
 
Top