Bug Report OBS 0.8.2 keeps failing to stream


The new OBS keeps dying on me when I try to stream to twitch.

Log file doesn't seem to be very useful:
21:09:26: OBS 0.8.2 (mac)
21:09:26: CPU Name: Intel(R) Core(TM) i7-4870HQ CPU @ 2.50GHz
21:09:26: CPU Speed: 2500MHz
21:09:26: Physical Cores: 4, Logical Cores: 8
21:09:26: Physical Memory: 16384MB Total
21:09:26: OS Name: Mac OS X (NSMACHOperatingSystem)
21:09:26: OS Version: Version 10.9.5 (Build 13F34)
21:09:26: Kernel Version: 13.4.0
21:09:26: audio settings reset:
samples per sec: 44100
speakers: 2
buffering (ms): 1000

21:09:26: video settings reset:
base resolution: 854x480
output resolution: 852x480
fps: 24/1
21:09:26: output 'adv_stream' (rtmp_output) created
21:09:26: output 'adv_file_output' (flv_output) created
21:09:26: encoder 'recording_h264' (obs_x264) created
21:09:26: encoder 'streaming_h264' (obs_x264) created
21:09:26: encoder 'adv_aac0' (ffmpeg_aac) created
21:09:26: encoder 'adv_aac1' (ffmpeg_aac) created
21:09:26: encoder 'adv_aac2' (ffmpeg_aac) created
21:09:26: encoder 'adv_aac3' (ffmpeg_aac) created
21:09:26: service 'default_service' (rtmp_common) created
21:09:26: coreaudio: device 'JackRouter' initialized
21:09:26: source 'Mic/Aux' (coreaudio_input_capture) created
21:09:26: coreaudio: device 'USB Ear-Microphone' initialized
21:09:26: source 'Mic/Aux 2' (coreaudio_input_capture) created
21:09:26: source 'iMovie window' (scene) created
21:09:26: source 'iMovie' (window_capture) created
21:09:26: source 'Text (FreeType 2)' (text_ft2_source) created
21:09:26: Video Capture Device: Selected device 'FaceTime HD Camera'
21:09:26: Video Capture Device: Using preset 320x240
21:09:27: source 'Video Capture Device' (av_capture_input) created

Doesn't even say anything about twitch. It just dies when I hit the "Start stream" button.

It worked just fine in the previous (I think it was 0.6.4)


More info:
I have tried sending everything in through Jack; fails.
I have tried sending audio from a program through Jack and the microphone direct; fails.
I have tried to set up two audio channels, so the different things could be sent in via separate channels in Jack; jack never saw more than one input from OBS. Also did not work.


Update! It happens on "Advanced" streaming, but not on "simple" streaming.

Output -> output mode simple: Works
Output -> output mode advanced: Fails.

100% repeatable


Forum Admin
Forum Moderator
Could you tell me what specific settings you use in advanced?


Forum Admin
Forum Moderator
Wait; what version were you using when this happened? 0.8.2 is the latest version.


And it's still happening.

This is what I said:
Automatically reconnect
Retry delay 10 seconds
Max retries 20
Audio track 1
Encoder x264
Enforce streaming service encoder settings
Rescale 854x480 (hmm, I'm working with 854x480 anyways)
Bitrate 2000
Keyframe 1
CPU Preset ultrafast
Profile none
Tune none
no extra options