OBS 0.62b test 1

Status
Not open for further replies.

Jim

Jim
Developer
It's test build time! NO JIM NO

I need users to test out game capture for me with every (directx 9/10/11 and opengl) game possible. Bonus points if you test 5+ games that you know were already working. Mega-kill points if you test 10+ games. Please let me know if it's working okay with games that were already known to be working.

If you had your game crashing before while using other hook programs, try using it now. We now should be able to hook even when other hook programs are active (where as before it would crash the game).

Please report black screens where you didn't have them before, with the name of the game and such.

Notes: https://github.com/jp9000/OBS/releases/tag/0.62-test.1
Download: https://github.com/jp9000/OBS/releases/download/0.62-test.1/OBS_0_62b_test_1.zip
 
Last edited:

Jott

New Member
Just tried this build with CS:GO and EAC (easy anti cheat) running at the same time, still getting that blackscreen, i did check the "Anti-cheat compability" box aswell. I did also run both EAC and OBS as admin still no luck :/
 

Jim

Jim
Developer
Actually, I believe I have to have the DLL added as an 'exception' by EAC before it can be used with it.
 

Jott

New Member
Is that something that is being worked on? I know a lot of ppls that wants to stream their ladder games but can't since EAC/OBS is not letting them to.
 

Jack0r

The Helping Squad
Forum Moderator
AC4 - works
Arma3 - works
Batman AO - works
Batman AC - works
BF4 - works
CSGO - without EAC works
Crysis - works
GTA4 / EFLC - works
HL2 - works
Hitman AB - works
Hitman BM - works
JC2 - works
KF - works
L4D2 - works
LoD - works
Mafia II - works
NFS:Rivals - works
Papers Please - works
Plague Inc - works
Portal 2 - works
Quake3 - works
SE:ZA1 - works
SE:ZA2 - works
Tomb Raider - works
Universe Sandbox - works
 

Floatingthru

Community Helper
I'll update this post when I can test more games. Every game I list is working, and was working before. If I find a game that does not work that did before, I will explicitly mention that.

-Path of Exile (Steam)
-South Park: Stick of Truth
-Diablo III: Reaper of Souls
-Hearthstone
-Loadout
-Super Meat Boy
-Call of Duty: Black Ops II
-Dark Souls (No DSfix)
-Tera: Rising
 
Last edited:

Isegrim

Member
working:
1953: KGb unleased
FTL
Capsized
Door Kickers
Haunted Memories
Hotline Miami
Hydrophobia Prophecy
Krater
Loadout
Mirror's Edge
Sid Meier's Ace Patrol Pacific Skies
No More Room In Hell
Sniper Elite: Nazi Zombie Army 2
They Bleed Pixels
Warframe
The Withcher - Enhanced Edition Director's Cut

Not working:
Gemini Rue
White Day

Mod edit: These are very old games, and have never worked with Game Capture. Please do not report games that have never been supported by Game Capture as not working, since this is not helpful at all.

Edit from OP: Gemini Rue is from 2011. I'm not sure that you are familair with the games i posted. Just because it looks old does not mean it is. White day is from 2000, you can call that one old if you want. But you might want to check your facts.

Mod edit: Sorry, you are indeed correct. It is however an AGS game, and it doesn't seem to support running in Direct3D mode at all, only DirectDraw, which renders it incompatible with Game Capture anyway. There is a DirectDraw capture plugin on the forum that you may be able to use for it.
 
Last edited by a moderator:

XeiZ

Member
Working:
Half-Life
HL2
portal
Borderlands 2

not working:
pso2 (didnt work before, crash or simple black screen but no crash with the anti cheat option checked)
 

bilehazard

Member
Cool deal, can't remember what games didnt work with Game Capture, but ill make sure to add to the current lists if i come across anything.
 

Gol D. Ace

Member
Games that have worked previously and still work.

I Wanna Be The Boshy
Angry Video Game Nerd Adventures
Metal Gear Rising: Revengeance
osu! (DirectX and OpenGL)
Castlevania: Lords of Shadow - Ultimate Edition
Audiosurf
PCSX2 1.2.1 (r5875) with GSdx 5875 (MSVC 18.00, SSE41) 0.1.16 in Direct3D 11 (Hardware) mode
 
Last edited:

paibox

heros in an halfshel
Metin2 seems to be an Asian MMO, and probably features some sort of hacking protection which blocks game capture. The aim of this update is not to circumvent such protection, but to make it able to coexist with other overlay applications that hook a game or application, such as DXtory.
 

BatedUrGonnaDie

New Member
64 bit version crashes on startup for me.
Working on 32 bit:
Bioshock Infinite
Dishonored
Osu
Sonic Adventure 2 Battle
Terraria

Not Working (Not 100% sure these worked before the update):
Binding of Issac
Game Dev Tycoon
League of Legends
Spy Party

That's everything I have installed that someone else hasn't tested, if you need more I can install more tonight.
 

dodgepong

Administrator
Forum Admin
Binding of Isaac is a Flash game and wasn't able to be captured before.

League of Legends worked fine in the previous version, and I have a hard time believing it doesn't work in this version. It's possible something else is going on in your case.

I'm not sure if Spy Party or Game Dev Tycoon are OpenGL or DirectX 9+ games...it's possible they are not.
 

T6kke

New Member
Worked with

Civilization V(DX11, DX10 & DX9)
Serious Sam 3
Call of Juarez Gunslinger
Receiver
Risen
The Witcher 2
 
Tested 64bit version only, game capture works with
Titanfall
Borderlands 2
Bioshock Infinite

(note: i don't have any other windows games to test. anxiously awaiting obs-studio for linux!!!! currently using simplescreenrecorder and really missing compositing)
 

ntt4

New Member
Fail = No video when recording with Game Capture
Pass = Works as expected
Notes appended to test if required

OBS 0.62b-test1 (64-bit)
Games captured at 1440P, Quicksync enabled

Skyrim with ENB - Fail (Black Screen) (Works with 0.613b)
League of Legends - Pass (Requires Admin Escalation)

AaaaaAAaaaAAAaaAAAAaAAAAA!!! for the Awesome - Pass
Antichamber - Pass
Atom Zombie Smasher - Pass
Audiosurf - Pass
Bastion - Fail (Randomly locks up recording, usually just after loading game, might be computer related) (Works with 0.613b)
Batman Arkham Origins - Pass
Beatbuddy : Rise of the Guardians - Pass (Crash on first hook)
Binding of Isaac - Fail (Flash)
Binding of Isaac (Spidermod) - Pass
Bit.Trip presents.... Runner 2 - Pass
Darwinia - Pass
Dead Island - Pass
Dirt 3 - Pass
Don't Starve - Pass
Dota 2 - Pass
Euro Truck Simulator 2 - Fail (Oculus mode enabled when tested) (Works with 0.613b)
Fez - Pass
FTL - Pass
Garry's Mod - Pass
Grid 2 - Pass (AVX EXE/Instruction set enabled)
Guacamelee - Pass
Half-Life 2 - Pass
Half-Life 2: Episode One - Pass
Half-Life 2: Episode Two - Pass
Hitman: Absoloution - Pass
Hitman: Blood Money - Pass
Just Cause 2 - Pass
Left 4 Dead 2 - Pass
LEGO Lord of the Rings - Pass
Little Inferno - Pass
Loadout - Pass
Mark of the Ninja - Pass
Mirrors Edge - Pass
Monaco - Pass (Pain to alt+tab out of)
Poker Night at the Inventory - Pass
Portal 2 - Pass
Prison Architect - Pass
Race the Sun - Fail? (Crash on first hook, Computer had a bout of strangeness.) (Works with 0.613b)
Rock of Ages - Pass (Crash on first hook)
Rogue Legacy - Pass
Roller Coaster Tycoon 3 - Pass
Shadowrun Returns - Pass
Sid Meier's Civ V - Pass
Solar 2 - Pass
Sonic & All Stars Racing Transformed - Pass
Sonic Generations - Pass
SpaceChem - Pass
Spelunky - Pass
Team Fortress 2 - Pass
Tropico 4 - Pass
 
Last edited:
Status
Not open for further replies.
Top