Question / Help No Longer Captures My Capture Card [Razer Ripsaw]

#1
Hi,

A couple of days ago (after trash Win 10 update) OBS Studio stopped capturing my Razer Ripsaw capture card. It detects it but it doesn't show it on the preview. I've tried de-activating and re-activating it. Rebooted PC multiple times. And just now uninstalled Streamlabs OBS and reinstalled OBS Studio to see if that might help.

For whatever reason, OBS Studio will not display my capture card anymore. However, Streamlabs OBS was showing it until I uninstalled it.

I have to do a lot of new settings and work to get Streamlabs OBS the way I want it and I don't really want to do that right now. I want to continue using OBS Studio.

Any suggestions?
 
Last edited:
#5
I dunno what you mean. My local recordings save as flv.

As far as your question. I dunno. It's been working just fine until two days ago. And still works with SLOBS, just not OBS Studio.
 
Last edited:
#8
I'm facing the exact same problem. My Ripsaw no longer shows up in the dropdown after installing the latest Windows update. Reinstalling the driver didn't fix it. Also tried the 32-bit version of OBS, no dice.
 
#9
Well my card shows up in OBS as selectable and Activated. It just doesn't actually show as captured in the preview so it won't show up live or anything.
 
#11
lol Yeah I've already gone through that nonsense.

Microsoft is garbage for sure. I've been wishing someone would make a new OS that's as good or better than Windows and not Linux. =P
 
Top