Move transition

Move transition 2.3.1

NiceManiac

New Member
I am having a problem with this plugin where some scenes does not work with the transition, it just pops to black for the duration of the transition. this happens every time i use an image file.
 

mojyamon

New Member
Hey y'all! I'm wondering if there is a way to stop and reset a move loop when deactivating and reactivating the scene. I'm working on a nice movement effect for my overlay but can't seem to stop the loop from moving through when the source is deactivated.
 

mojyamon

New Member
I guess I'm trying to find out if theres a way to stop the next move when the source is deactivated and restart at the first move source when the source is reactivated
 

JEJ

New Member
@Exeldro I am not sure if it is how the filters work or if this is a bug...

When using the move source filter to loop sources I found that when I add the filter and assign all the settings it won't have an effect until I restarted OBS.
 

JEJ

New Member
On another note... The [minimum value] that 'Custom Duration' allows is [10ms]

Can this be changed to allow 0ms, or is there a reason why the minimum is 10ms?
 

JEJ

New Member
Is it possible to allow a definition setting to trigger when the Source becomes visible for the first time?

The definition must only apply once when the user makes the source visible.

This is to allow a delay on start before the filter routine starts.
 

Gerdty

New Member
I'm having an issue where if I am in studio mode, my program feed blacks out sometimes when I use move transition, and then comes back when the transition time finishes. If I am not in studio mode, the issue never occurs. Any suggestions on how to fix this?
 

NiceManiac

New Member
I'm having an issue where if I am in studio mode, my program feed blacks out sometimes when I use move transition, and then comes back when the transition time finishes. If I am not in studio mode, the issue never occurs. Any suggestions on how to fix this?
I'm having the same issue, would be great to figure out this issue, then i can use it on a production i have coming up.
 

eineke

New Member
I must be doing something wrong as this plugin only seems to cause my OBS to crash. If I set something up and restart OBS, which I always turn off my computer when I'm done, the plugin will fail and no longer work when trying to be commanded from OBS Tools on my StreamDeck. I'm trying to figure out the source of these crashes, but the logs don't seem to even detail much about why there's crashes/unresponsive events. I noticed that the StreamDeck OBS Tools will fail to command anything and am asking about that in the Discord Server for that software; but then when I manually trigger the filters in OBS by clicking the eye for something like a Move Source option, all that happens is OBS becomes unresponsive and may eventually unfreeze or simply crash.

I would be happy to troubleshoot, but I'm not sure where to be sending logs and things. If there's an email that's better to be sending to, please let me know.
 

Attachments

Wuzi

New Member
Really love the latest updates. All the new features got me playing with new ideas.
While doing so there's one thing I noticed: I don't really know what the "Switch Point" setting for the move filter does and no matter what I tried, it didn't seem to have any effect.What am I missing?
 

Exeldro

Active Member
@Gerdty and @NiceManiac can you check if disabling the duplicate sources option for studio mode fixes anything?

@eineke can you check if the new OBS 26.1 release candidate fixes the freezes?

@Wuzi switch point is useful when a source is switching layers during a transition. For example going from background to foreground.
 
your a wizard @Exeldro !!!
Im having a hiccup.
execution of the movements are perfect. The hiccup arises when I restart OBS.
I have to go into each of the movement filters and basically toggle one little piece of data.
(IE, change no ease, to ease-in, and Back again) for all the animations to work again after a restart.
I've tried with both Move End and Hot Key endings.
I might have missed something. but i have 1 entire scene that this is doing it on.
Im using a 2.1 download from yesterday, and obs 26.0.2
(im throwing some videos on dropbox, if that helps)

thank you sir.
 

NiceManiac

New Member
@Exeldro the issue does not persist when disabling duplicate sources in studio mode, but i need to duplicate sources to be able to change certain aspects of the scenes on the fly
 

Exeldro

Active Member
@NiceManiac In studio mode the duplicated source have no name at the moment so the move can not find the correct one.
I requested a change in OBS for those duplicated sources to have the same name as the orginal source to be able to find them.
This change can be followed here: https://github.com/obsproject/obs-studio/pull/3819
It can take a long time for the change to be accepted. After it is accepted it should be in the next version of OBS.
 

VexxJeff

New Member
Hi! I really love your work for this plugin!

I've encourter a problem while trying to select a source insinde of a groupe. I'm trying to flip a whole groupe and after flipping a single source inside of this groupe, but I can't find the option to select a single source insinde of a groupe.

Is there a way to do that?
 
Top