Resource icon

Free MIDIControl - Control OBS (and SoundBoard) with MIDI Input 1.2.4.1

Etuldan

Member
Works really well, but I feel like its missing a feature... There should be a way to bind a MIDI key to stop all sounds instead of having to tab out of your game and click the "Stop All Sounds" button on the GUI
For example if I press a midi key to activate some background music, but then at some point want the music to stop, I could either press the same midi key that I pressed to activate it to instead stop it, or just having a master midi key that stops all sound effects being played would work too.
Stop All Sounds MIDI keybind available in the latest version !
Enjoy :)
 

AdameK

New Member
Unfortunately, this option doesn't work for me. In the settings, I can't choose the device, but I have to write name and when I type the device and the key, nothing happens.
 
Uninstalled the latest version and reinstalled the one prior (before filters) and the transition setting is working again.
OK so any version above 1.2.2.3 (the last one before the addition of filters control) ignores any transition changes. It simply doesn't send any of them to OBS.

The only fix was to uninstall, and resinstall 1.2.2.3. Which is a real shame because I really want to use the new filters toggling! Is anyone else having this problem, or are other people successfully changing transitions on the newer builds?
 

Etuldan

Member
Unfortunately, this option doesn't work for me. In the settings, I can't choose the device, but I have to write name and when I type the device and the key, nothing happens.
It works on my side. Did you spell the device correctly ? Also, a reboot of the application may be needed.
 

Etuldan

Member
OK so any version above 1.2.2.3 (the last one before the addition of filters control) ignores any transition changes. It simply doesn't send any of them to OBS.

The only fix was to uninstall, and resinstall 1.2.2.3. Which is a real shame because I really want to use the new filters toggling! Is anyone else having this problem, or are other people successfully changing transitions on the newer builds?
Should be fixed on latest version ( 1.2.4.1 ) , sorry for that.
 
Should be fixed on latest version ( 1.2.4.1 ) , sorry for that.
Don't apologise! You're doing incredible work here.

Just found an obscure bug that might be related to this fix. When showing / hiding layers, the null transition cheat no longer works when a 'stinger' transition is set. I think it's because it fails to set that transition to be 0ms, so it just triggers the sting every time a layer is triggered to be shown or hidden. If that makes sense. Obviously a current workaround is just to make sure the transition is currently set to a Sting transition when triggering a source hide or show.

I don't think this was a problem in the past, but it is a pretty specific scenario.
 

SkylerGreene

New Member
Thank you so much for creating this!
This is SO much better than hotkeys and a mouse!
I really appreciate all the time you've put into creating such a useful plugin.
It is working really well for me (I'm using an Akai APC40 MKII on a Windows 10 PC).

I've noticed that when I program a button to toggle/show/hide a source, it resets my transition duration to 2ms.

If possible, here are some additional features I would find useful:
•Be able to save/load MIDIControl profiles (my save button doesn't seem to do anything.
•Be able to change function name while editing
•Be able to program a knob/fader to adjust transition duration up and down.
•Be able to program knob/Fader to control the Quick Transitions slider.

Thanks again for your amazing contribution and hard work.
 
Top