LocalVocal: Seamless Live Transcriptions On-the-Go

LocalVocal: Seamless Live Transcriptions On-the-Go v0.1.0

royshilkrot

Member
royshilkrot updated LocalVocal - Live stream AI assistant with a new update entry:

v0.0.4 - Subtitle files, external models, bugfixes, and much more

A very exciting release! We have improvements and new features all around:
  • Saving subtitles to .srt files
  • Saving subtitles aligned to OBS recordings (timestamp, filename)
  • Using external Whisper models
  • CUDA support for Windows
  • Disable on audio source mute
  • Fixing UTF8 characters for certain languages
  • Translation of the UI
If this plugin has provided value to you consider adding a ⭐ on the repo...

Read the rest of this update entry...
 

MartinBrieger

New Member
hmm indeed the labels are not coming up
It must be failing to load the en-US locale translation file.
I will look into it. Thanks for the feedback!
Ok,

I loaded the latest en_US.ini from the source and copied it to
/home/[stupid me]/.config/obs-studio/plugin_config/obs-localvocal/locale/en-US.ini

So, back to my usual problem. Probably the wrong path, cause nothing changed.
Where is the stuff supposed to be on UNBUNTU/Linux systems?
BTW, the initial en-US.ini contained only one line, but you fixed that.
 

royshilkrot

Member
Ok,

I loaded the latest en_US.ini from the source and copied it to
/home/[stupid me]/.config/obs-studio/plugin_config/obs-localvocal/locale/en-US.ini

So, back to my usual problem. Probably the wrong path, cause nothing changed.
Where is the stuff supposed to be on UNBUNTU/Linux systems?
BTW, the initial en-US.ini contained only one line, but you fixed that.
@MartinBrieger well according to the official guide https://obsproject.com/kb/plugins-guide all the plugin files need to go in ~/.config
But in reality on my Ubuntu 22.04 I only get it to work if they're in /usr/lib and /usr/share
So ‍i can't say
 

MartinBrieger

New Member
@MartinBrieger well according to the official guide https://obsproject.com/kb/plugins-guide all the plugin files need to go in ~/.config
But in reality on my Ubuntu 22.04 I only get it to work if they're in /usr/lib and /usr/share
So ‍i can't say
Roy,
I tried
/usr/share/obs/obs-plugins/obs-localvocal/locale
Only got Lemmons. Meaning it won't work. The model path per OBS log is
Model path in config: /home/[stupid me]/.config/obs-studio/plugin_config/obs-localvocal/models/ggml-base.en.bin
so I figured the locale should be in the neighborhood, but the Postmaster can't find it.

Strange ...
 

royshilkrot

Member
royshilkrot updated LocalVocal - Live stream AI assistant with a new update entry:

v0.0.5 - fixing UTF8 encoding on Windows for several languages

In this release I'm fixing an important bug with UTF8 characters not being handled properly on Windows. Also an change that allows for far faster builds.

If this plugin has provided value to you consider adding a ⭐ on the repo, subscribing to my YouTube channel where I post updates, and supporting my work: https://github.com/sponsors/royshil

Installers:
  • ...

Read the rest of this update entry...
 

Artsiefy

New Member
Anyone have any idea how to make the subtitles last a bit longer on screen as it is not even a second before they just disappear leaving people to not even get to read them, also how to get rid of the [Skip] Text that is constantly showing when the subtitles are not being generated?
 
Using VL 0.0.5 on Windows Pro 10, it doesn't show the subtitles option but Subtitles Output seems to include some other plugin options. Also, when I select 'Text File output,' define an output filename and close the filters window, it is not listed under Sources.

Screenshot_1.png
 

royshilkrot

Member
Using VL 0.0.5 on Windows Pro 10, it doesn't show the subtitles option but Subtitles Output seems to include some other plugin options. Also, when I select 'Text File output,' define an output filename and close the filters window, it is not listed under Sources.

View attachment 98888
i don't quite understand what is not working for you, can you explain again what you're trying to do and what's not working?
 

royshilkrot

Member
@royshilkrot As shown in the screenshot, there's no subtitles option listed in the Subtitles Output dropdown window, only 'Text File output'.
@OpenFields I can see the file output as well as a lot of Text Sources that you have in your scene - you can send the subtitles there.
Or you can select "Stream Captions" if you want them to be sent on your live stream (Twitch, YouTube)
 

royshilkrot

Member
@royshilkrot Thanks for responding. I guess I'm missing something. What do you mean by "you can send the subtitles there"? I understood that the plugin should list 'subtitles' as a standard output option.....
I just had a Text Source called "Subtitles" that's why you'd see that in the tut video.
The drop-down list shows: Off, File and all Text Sources in all scenes.
 

nadideerkuran

New Member
If OBS needs language support while transcribing, I use Transkriptor. It helps me with audio to text conversions.

I also use it in OBS related transcriptions where verification and correction are required.
 

andersonid

New Member
Hi! Could you please help me how to install on Fedora? I just got working urlsource plugin, and many others using this method:
Manually installing plugins on linux

Do one of the following
Build the plugin from source
Get the binaries as a zip archive
Get the plugin as a .deb file and extract it
Create the following directory structure:
~/.config/obs-studio/plugins/[plugin name]/bin/64bit
~/.config/obs-studio/plugins/[plugin name]/data
Copy the .so file to the bin/64bit folder and the data (locale etc.) to the data/ folder


But I cant get this working for localvocal. Could you please help me out which files should I copy to ~/.config/obs-studio/plugins/[plugin name]/bin/64bit ??? I cant find and .so file.
 

royshilkrot

Member
Hi! Could you please help me how to install on Fedora? I just got working urlsource plugin, and many others using this method:
Manually installing plugins on linux

Do one of the following
Build the plugin from source
Get the binaries as a zip archive
Get the plugin as a .deb file and extract it
Create the following directory structure:
~/.config/obs-studio/plugins/[plugin name]/bin/64bit
~/.config/obs-studio/plugins/[plugin name]/data
Copy the .so file to the bin/64bit folder and the data (locale etc.) to the data/ folder


But I cant get this working for localvocal. Could you please help me out which files should I copy to ~/.config/obs-studio/plugins/[plugin name]/bin/64bit ??? I cant find and .so file.
Generally this may work
But the .Deb is built for Ubuntu ish Linux distro.
The sure way to make it work is build from source.
It would be helpful though to see your logs.
You're welcome to open an issue https://github.com/occ-ai/obs-localvocal/issues or msg on the OBS discord server for realtime support
 

royshilkrot

Member
royshilkrot updated LocalVocal: Seamless Live Transcriptions On-the-Go with a new update entry:

v0.0.6 - Fix ALL unicode languages! + Min sub duration

In this release: Minimum subtitle display duration, removing the vexing [skip] message, fixing ALL unicode languages as well as Windows UTF8 paths for custom model files

If this plugin has provided value to you consider adding a ⭐ on the repo, subscribing to my YouTube channel where I post updates, and supporting my work: https://github.com/sponsors/royshil

What's...​


Read the rest of this update entry...
 
Top