Resource icon

Free LioranBoard Stream Deck/Animator 1.39

lioran

Member
I'm having a problem where I cannot edit or remove 4 decks that show at launch. Even if I delete the config.ini file, these decks are being loaded and shown. I also cannot save any changed to these decks with the DONE button in the Edit Deck interface. I'm assuming I have done something to bork things up, but I'm not sure what to do about it. I don't see anything in the USER folder anywhere that reflects settings for LioranBoard... if you can point me in the right direction, I'd really appreciate it. This problem started for me when I updated to 1.36, but I updated after I had to do a clean install of Win10 Pro 64b after a BSOD rekt my OS/Boot partition. I don't run LioranBoard from that partition, but I certainly realize the retkness of the drive could have contributed to whatever the heck is going on now. Thanks, in advance, for your time... and, for that matter, thanks for the sweet software.
user/%username/appdata/local/lioranboard
delete the configs file there.
this is most likely happening because your anti-virus either started blocking or unblocking lioranboard. But considering you deleted those that are in lioranboard folder and its not helping, then it most likely is that, lioranboard is unblocked and allowed to write in its own folder..Version 1.36 should warn you when such change occurs.
 

Galathir

New Member
user/%username/appdata/local/lioranboard
delete the configs file there.
this is most likely happening because your anti-virus either started blocking or unblocking lioranboard. But considering you deleted those that are in lioranboard folder and its not helping, then it most likely is that, lioranboard is unblocked and allowed to write in its own folder..Version 1.36 should warn you when such change occurs.
Thank you for the speedy advice! I was just going to say that's exactly what I had just done. Not sure why I didn't see the USER folder stuff before, but that has cleared it up! Again... thanks for the work and software... and all over again for being so responsive to support questions! You are epic, sir!
 

nerd404uk

New Member
Good Morning @lioran,
I am new new to your plugin, sent Via Nutty, and was wondering if there is direct control for RGB strips, like Phillips Hue from the Web interface please?

I am not running the App, i believe i am just running the receiver on my machine, as nutty suggested so that i can add extra actaions to my stream, but i would like for my viewers to play with the lights if possible. If not Hue is there an LED strip that does work pls?

I have run a couple of tests for scene switching from chat, so i have not gotten very deep yet,

Thanks
Nerd404uk
 

lioran

Member
Good Morning @lioran,
I am new new to your plugin, sent Via Nutty, and was wondering if there is direct control for RGB strips, like Phillips Hue from the Web interface please?

I am not running the App, i believe i am just running the receiver on my machine, as nutty suggested so that i can add extra actaions to my stream, but i would like for my viewers to play with the lights if possible. If not Hue is there an LED strip that does work pls?

I have run a couple of tests for scene switching from chat, so i have not gotten very deep yet,

Thanks
Nerd404uk
Although a javascript extension could do that,(lioranboard has a javascript api of sort)
Unless you're a programmer yourself, nobody has made an extension for that, and I don't have a Phillips hue.
so if you make one let me know.
 

lioran

Member
lioran updated LioranBoard Stream Deck/Animator with a new update entry:

Notification System

I've made a notification system for LioranBoard users to use freely. I've made using it as simple as it can get considering there is no way to easily give people my nested scene profile. Here is a short tutorial Install LB Notification System

Video of all the notifications

release 1.37 - 6/22/2020
-New Twitch trigger for amount of gifted subs
-added new...
Read the rest of this update entry...
 

RichardOnRetro

New Member
Ver 1.37 crash
___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Async Event: Networking
for object obj_host:

ds_list_size argument 1 incorrect type (undefined) expecting a Number (YYGI32)
at gml_Script_scr_websocket_inspect
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_scr_websocket_inspect (line -1)
gml_Script_scr_receive_websocket
gml_Object_obj_host_Other_68
 

Amedyr

New Member
Hey guys,

First of all, thank you so much for this tool, it made my stream 300% more fun.

I just have this issue where the sound effects play on speakers, instead of my headset, even though the headset is the default sound device. That way, OBS won't capture the sound and nobody can hear anything. Any ideas how to fix that?
 

lioran

Member
Hey guys,

First of all, thank you so much for this tool, it made my stream 300% more fun.

I just have this issue where the sound effects play on speakers, instead of my headset, even though the headset is the default sound device. That way, OBS won't capture the sound and nobody can hear anything. Any ideas how to fix that?
are you perhaps using voicemeter?
 

Amedyr

New Member
are you perhaps using voicemeter?
Nope!

Edit: Sorry for not elaborating, I'm just not using any sort of sound boards or anything, just some filters on OBS - all my games and music go straight to OBS without treatment
 
Last edited:

lioran

Member
Ver 1.37 crash
Lack of details of when, what, how is a bit high on this, but this sounds like either lioranboard is outdated or obs websocket is outdated

Nope!

Edit: Sorry for not elaborating, I'm just not using any sort of sound boards or anything, just some filters on OBS - all my games and music go straight to OBS without treatment
probably a bad sound driver that makes lioranboard not able to pick the proper sound driver, I don't have a fix for it unfortunately
 

lioran

Member
Can't seem to install the receiver. I keep getting SSL error. ''ERR_SSL_PROTOCOL_ERROR''
That's not an error related to the receiver, the receiver doesn't have any SSL in it. this is an external error unrelated to receiver.
I can't even speculate about what that error is but you might wanna look into that on your PC side.
 

Cowking

New Member
That's not an error related to the receiver, the receiver doesn't have any SSL in it. this is an external error unrelated to receiver.
I can't even speculate about what that error is but you might wanna look into that on your PC side.
You are right, I have to figure out why it's not letting me connect. I need to enable the connection somehow...

''The device or resource (localhost) is not set up to accept connections on port "29521"

Edit: FIXED. I just used another browser.
 
Last edited:

renziito

New Member
Can i get the message of the twitch points redeem and send it to command like a variable for a text source ?
 

Cowking

New Member
Just started with the app, it's amazing! I want mods to be able to change the source of the main cam. Anyways to do it? I am in Source Change Settings and tried different texts in sourceSettings ex: Device{e1eSoft iVCam}. Is this even possible?
 

lioran

Member
Can i get the message of the twitch points redeem and send it to command like a variable for a text source ?
Command Math: Trigger Pull , click -Help- at the top to know what to pull

Just started with the app, it's amazing! I want mods to be able to change the source of the main cam. Anyways to do it? I am in Source Change Settings and tried different texts in sourceSettings ex: Device{e1eSoft iVCam}. Is this even possible?
if you want to turn source on and off, use source change visibility, source change settings is not meant for that.
 

dnhstv

New Member
In our studio setup quite a few programs use standard hotkeys causing a lot of conflicts.
We would like to have the keyboard macros in Lioranboard as extended ALT characters not normally used like ñ (alt-164).
It took a while but we figured out how to copy and paste these characters into OBS Studio and they work well.
Is there a way we can input these types of characters into the Keypress dialog when editing a keyboard macro?
 

lioran

Member
In our studio setup quite a few programs use standard hotkeys causing a lot of conflicts.
We would like to have the keyboard macros in Lioranboard as extended ALT characters not normally used like ñ (alt-164).
It took a while but we figured out how to copy and paste these characters into OBS Studio and they work well.
Is there a way we can input these types of characters into the Keypress dialog when editing a keyboard macro?
Some keys aren't supported in general for macros, but some that dont exist on any keyboards are, such as F13-24
Obviously you can not type those keys since you dont have them, there is no easy way to put them in lioranboard other then trigger that key somehow through other means(it will show up as unknown if it succeeds.) OR you can edit the configs.ini file of that deck, you will have to find which button manually and edit the press1-99="?" valueto whatever the number of that key is, you will have to figure that on your own, they should all show up as unknown in lioranboard
If you don't want them to show up as unknown, you can edit the keys.ini file and just add them.
good luck
 

dnhstv

New Member
Some keys aren't supported in general for macros, but some that dont exist on any keyboards are, such as F13-24
Obviously you can not type those keys since you dont have them, there is no easy way to put them in lioranboard other then trigger that key somehow through other means(it will show up as unknown if it succeeds.) OR you can edit the configs.ini file of that deck, you will have to find which button manually and edit the press1-99="?" valueto whatever the number of that key is, you will have to figure that on your own, they should all show up as unknown in lioranboard
If you don't want them to show up as unknown, you can edit the keys.ini file and just add them.
good luck
Thank you this worked perfectly! We were able to add alt-128 through alt-138 to the keys.ini file and they showup and work great on our Lioranboard. Now we just need to get these extended keys to detect properly in OBS and Reaper.
 
Top