How to exclude any Audio using VAC

Status
Not open for further replies.

Jack0r

The Helping Squad
Forum Moderator
Check out the ressource:
Exclude Audio sources off your stream or recording

The thread below is old and uses a more complex setup.
Latest version of this Guide can be found here or here.

This is a rework of my older guide: How to exclude any Audio off your stream? Now split into two seperate guides.
You are reading:
Using a Realtek or VIA Audio Chip? Check:

EDIT: I also created a youtube Video showcasing a similar setup:

What we want to achieve: (You can replace Teamspeak with every program that allows you to select its own Output Device, music players, video players, games, etc.)

You will still be able to hear everything though your streamers will only hear game sound and for example music (referred to as Windows sound in the picture). Again I want to show you a picture to memorize what we have to setup.

First of all, you won´t need to setup VAC Line1 as your standard Windows audio device if all your games and software you want to be heard on stream have a setup option to output to a special audio device. I will show you how to use VAC as the standard device. This way the most customization is possible.

Lets start. You will have to deactivate Line 1 (Virtual Audio Cable) under Playback AND Recording in your Sound settings to activate more than one VAC Line:

System control panel -> Sound -> Playback -> right-click Line 1 -> Disable
then under Recording -> right-click Line 1 -> Disable

Now we can fiddle with the settings in the VAC control panel. While the devices are active this will not work in most cases. Start -> All programs -> Virtual Audio Cable -> Control Panel
In the upper left adjust the Cables settings to 2/3 or even more if you would need to and hit the "Set" button, a second(third/...) line should appear in the lower half of the window just as shown here:

Exit the Program and activate all Lines under Playback and Recording in your Windows Sound settings.

Now this part can be left out if your game and software allows you to set Line 1 or 2 as the Main Audio Output without changing your Standard Audio device in Windows. And I will mainly talk about using 2 Lines from now on, to seperate more Sound Sources you can use more Lines as mentioned before. There are some games that don´t give you the option to choose which audio device is used for your Output.

Now we want to make sure VAC Line1 will be the device which gets all standard sounds of the Game and Windows Sounds (like music). So in the Playback Tab (Windows Sound settings) right click the Line 1 VAC device again and select Set as Default Device.

Now in the Program you want to exclude off Stream, I will refer to Teamspeak, set up your Audio to output onto VAC Line 2:

Last but not least we will have to get both sounds to your ears. The next step is my own approach as you could also use the repeater software VAC includes. Fiddling with the Audio Repeater (KS) and (MME) can be quite brain freezing from time to time. But you will find many youtube tutorials on how to use them if you want to!
But I am normally using the "Listen" function of Windows 7 as it never "crashed" on me like the audio repeaters did. To get one source to more than one Output, you will have to use a repeater! But this is the more simple setup. Open the Windows Audio settings again -> Recording -> Line 1 (VAC) -> right-click-> properties -> Listen:

As you see in the Picture, select Line 2 and be sure to click the check box (Listen to this device). Hit Ok and open the properties for Line 2 (still on the recording tab). This time select your Soundcard (I have two devices as you can see in the picture), in my case "Lautsprecher (USB PNP Sound Device)".
Sometimes you run into the problem that the listen to function would only work after restarting the PC, so if its not working at the first try, don´t mind it. Try a reboot and it should work.

Now you should be able to hear all ingame sound and your friends on the Teamspeak. XSplit/Fraps/DXtory should only pickup the standard Windows audio sounds and of course, all ingame sound but not your friends on the Teamspeak/Mumble what ever. If you didn´t set your VAC Line1 as the standard Windows audio device you will have to do a slightly different setup with the repeaters, but you should be able to do so on your own, you will also only need 1 VAC Line active (ran into problems? post a comment).

Very complex setups are possible using Virtual Audio Cable. Check my Guide on how to send different Audio Sources to different Audio Outputs. In the future programs like OBS and XSplit will probably also include such abilities, but until then, have fun fiddling around with VAC.
I hope everything is clear now but be sure to post a comment if you have questions. And as always you can find me in #t-h-s and #obsproject in IRC Quakenet!
 

Juin

New Member
Re: How to exclude any Audio off your Stream using VAC

Is there a way to exclude a Programs Audio which doesnt let you set your Output Device?
 

Jack0r

The Helping Squad
Forum Moderator
Re: How to exclude any Audio off your Stream using VAC

As discussed on IRC, there unfortunately is no way under Windows7/Vista to do this safely.
Some people are able to switch their default playback device while playback is active to split the Audio of two programs, but this does not work for everyone, and its not clear, why it works for some people.
For older WindowsXP users there was a software available to select the audio output device, but with the recent Audio changes in Vista and 7, this aint working anymore.
 

matoxx_

New Member
Re: How to exclude any Audio off your Stream using VAC

Hey Jack0r!
I know this guide is kinda old already, well.. I hope you or someone with more knowledge than me reads this :D
I use this method with VAC since yesterday and everything works fine for my stream. I can play games and play my music for the stream and still be on skype with my friends and nobody knows it - so thanks for the awesome guide!

Well I have 1 problem with this method and I can't figure out why it doesn't work that properly.
When I start a call in sykpe my whole audio gets scaled down so I have to push up the volume almost to maximum so I can hear anything. My stream hears the maximum volume as it should be though.

Its not that dramatic because I can scale down the sound in OBS so that the sound is fine for the stream but maybe there is a fix for this :)

I hope I could even make my problem clear for you guys, sorry for some bad english! :)
 

Jack0r

The Helping Squad
Forum Moderator
Re: How to exclude any Audio off your Stream using VAC

Oh you might wanna check your Communications Tab in the Windows Sound settings. (Control Panel -> Sound -> last tab)
Its probably set to reduce volume of other sounds by 80/50% as soon as Windows detects you use a Communication device (which you probably do with skype).
Also make sure skype is not set to auto manage the levels for your input or output, if possible. Thats in the Skype settings for your Audio devices.
 

matoxx_

New Member
Re: How to exclude any Audio off your Stream using VAC

Oh yea lol it was at 80%!
Thank you very much, works just fine now! :)
Take care!
 

xD4rkFire

Member
Re: How to exclude any Audio off your Stream using VAC

What if I want to set it up so that my viewers hear music on my stream, but I don't hear it?
 

Jack0r

The Helping Squad
Forum Moderator
Re: How to exclude any Audio off your Stream using VAC

http://blog.hemp-society.de/2013/02/how ... thout.html

in short:
Your music player has to allow you to choose which output it sends the music to. Winamp/Foobar/WindowsMediaPlayer etc can do this. Now you simply use a VAC Line to receive this audio. Lets say you use VAC Line1 for this.
In OBS you can choose Line1 as your Microphone device or add it to a Scene using the DirectShow Audio Plugin. If you use the first option, you might wanna send your Microphone input to VAC Line1 aswell, so your voice can be heard on stream.
 

Isaakske

New Member
Re: How to exclude any Audio off your Stream using VAC

Hello.

Thanks for this guide, it has helped me alot :)
I have one little problem doh. The sound I hear is late. I mean, I shoot, and I hear it 1/3 of a second later (small delay, but noticeable in lipsyncs and games). However OBS records the sound in sync. I shoot, I see the sound bar in OBS go up, and then I hear the sound (all relatively fast after eachother).
So my question is, any way to solve this ?
I have tried switching the lines and channels, but all I did was mess stuff up.
Please help me :(
 

Jack0r

The Helping Squad
Forum Moderator
Re: How to exclude any Audio off your Stream using VAC

Its hard to really tweak the delay. If you use a repeater and set it to buffer 100ms that should be 1/10 of a second. The listen to function for me works similar. To get rid of any delay and still be able to mix stuff you would else way need a external hardware mixer for example.
 

Isaakske

New Member
Re: How to exclude any Audio off your Stream using VAC

Jack0r said:
Its hard to really tweak the delay. If you use a repeater and set it to buffer 100ms that should be 1/10 of a second. The listen to function for me works similar. To get rid of any delay and still be able to mix stuff you would else way need a external hardware mixer for example.
Well then how do you use the included repeater ? I used the Listen function of Windows 7 ....
 

Jack0r

The Helping Squad
Forum Moderator
Re: How to exclude any Audio off your Stream using VAC

Ok well thats pretty easy, I use the Repeater MME as the KS often gave me problems. You can of course try if it works for you.
ihqdtJuOYU2II.PNG

Wave IN has to be the device you want to send to your desired target. While Wave OUT specifies this target.
Sample rate and Bits per sample should be set to your Audio device settings. You can find this info in the properties of your sound device:
ibyKhO7up7Sjov.PNG

Now total Buffer is the time your input will be delayed in ms. Going lower than 100ms results in too many overflows on my hardware, which can be heard as a cracking sound instead of the real sound. So you have to test the values and see what works for your hardware.
Total buffer 100, Buffers 12, Priority High, worked best for me so far.
 

xD4rkFire

Member
Re: How to exclude any Audio off your Stream using VAC

Is VAC something that I need to download or is it something I can do in Windows by default? Also, as far as streaming music without listening to it myself, will there be any delays in terms of audio from doing this?

edit: nevermind... I found out that VAC is a download :)
 

Gol D. Ace

Member
Re: How to exclude any Audio off your Stream using VAC

xD4rkFire said:
edit: nevermind... I found out that VAC is a download :)

A download that costs money when you don't want to hear trial every few seconds.
 

Jack0r

The Helping Squad
Forum Moderator
Re: How to exclude any Audio off your Stream using VAC

Yeah, until now I couldnt find a free alternative, if you know one, just tell me.
There was this Breakaway Live software, someone told it could be used over the evaluation period, but then you are limited to one line, and its ALOT more expensive if you want to buy it. VAC does its job very well, so i use it.

And you can also use the other guide, if your hardware allows it. (Needs stereo mix, etc) But many USB Headsets, and Soundcards wont allow this. I just recently helped someone with a laptop, he/she could have done everything hardware wise. But the Laptop speakers would have always been on while he/she used his headset.
The only way around this was using a simple VAC setup :)
 

xD4rkFire

Member
Re: How to exclude any Audio off your Stream using VAC

So as far as it goes for playing music on my stream without my viewers hearing it, would the Stereo Mix method be the free, no-download-needed alternative?

Jack0r said:
http://blog.hemp-society.de/2013/02/how-to-include-audio-on-stream-without.html

in short:
Your music player has to allow you to choose which output it sends the music to. Winamp/Foobar/WindowsMediaPlayer etc can do this. Now you simply use a VAC Line to receive this audio. Lets say you use VAC Line1 for this.
In OBS you can choose Line1 as your Microphone device or add it to a Scene using the DirectShow Audio Plugin. If you use the first option, you might wanna send your Microphone input to VAC Line1 aswell, so your voice can be heard on stream.
 

Jack0r

The Helping Squad
Forum Moderator
Re: How to exclude any Audio off your Stream using VAC

Exactly, a stereo mix allows us to use the attached sound device as a "clone" line, so we can add audio to a different device that has to be available as well. With OBS we can then simply select the device we want to hear in OBS.
 

xD4rkFire

Member
Re: How to exclude any Audio off your Stream using VAC

I can't seem to get the stereo mix working. I can still hear the music when it's played. I recorded myself following the guide so could you take a look at it and tell me what's wrong please?

Also, I couldn't touch the Realtek HD Audio 2nd Output because it was marked as unplugged and the only way to fix it was to plug a 2nd pair of headphones into my front panel audio jack.

My audio setup is that the headphones I wear are plugged straight into my mobo while my secondary pair of headphones are plugged into my front audio jack.

http://www.twitch.tv/ncix_xd4rkfire/b/421934815

=Edit 1= Following the same steps but having switched the headphones I wear into the front audio jack and my secondary pair to the mobo, it seems to work out okay. However, it'd be more ideal for me if you could help me get it set up with my wearing headphones plugged into my mobo because in this setup, I can't have Realtek HD Audio Manager do 7.1 for my headphones.

=Edit 2= I can't keep what I did in edit 1, it messes with my mic (creates a half second delay and messes with the mic quality somehow)
 

Jack0r

The Helping Squad
Forum Moderator
Re: How to exclude any Audio off your Stream using VAC

Hey I updated, split, and simplified the Guides a bit.
I think they were too complicated, but you were near the end result. In your case you should now be able to succesfully use my Stereo Mix guide. (Set the Stereo Mix temporary as your default recording device if it does not work right away, a reboot might be necessary)

For OBS the setup is pretty simple, the stereo mix/all you can hear device belongs to your "Speakers" Realtek HD Audio, this sound device will now be our "first/main" Soundcard. It also has to be your default Windows playback device to receive the game sound, and you will use it to plugin your Headset or Speakers. (If you cannot use this port for your headset, you probably want to take a look at the VAC setup again)
Now we need to send our Game sound to the secondary Soundcard, open the properties of your Stereo Mix device and on the Listen tab, check "Listen to this device" and select your secondary Soundcard in the dropdown.
In OBS you select your secondary Soundcard as the Desktop Audio device, and if you have not done this earlier, select the secondary Soundcard in Winamp or Foobar.

The new split Guide: http://blog.hemp-society.de/2013/06/how ... thout.html
And the VAC version: http://blog.hemp-society.de/2013/02/how ... thout.html

Sorry for the definitely confusing first version :D

PS: If you have problems with the 2nd Output needing something connected, try checking the "Disable auto popup dialog, when device has been plugged in" checkbox in your MSI Audio Control Panel (that should be hidden under the small button in the lower right). My Windows then decided to think it has something connected ;)
 

xD4rkFire

Member
Re: How to exclude any Audio off your Stream using VAC

It works (I used the split version).

As far as the PS goes, the option says "Enable auto popup dialog, when device has been plugged in" and I still have to have my secondary pair of headphones plugged into my front audio jack.

Either way though, thanks a million for helping me get it working! :)
 
Status
Not open for further replies.
Top