Question / Help Encoding Overload, but low CPU usage

Wishblade

New Member
Hello everyone

I've long had this particular issue, occasionally attempting to try to fix it by tinkering with settings but still no luck in being completely rid of it.

Whenever I record just about any game, even using a scene with only a single game as a source, no webcam or anything else, I occasionally get a few seconds of encoding overload, which results in a few skipped frames, maybe 1% at max but usually below that.

I'd understand this if my CPU usage was high but on OBS itself I'm below 10% and in the Task Manager I've been below 20%, when using World of Warcraft for testing.

Only test where this didn't happen so far, that I've come across today, was to record the files onto my SSD instead of my HDD. Although I'm hesitant to do this since I've heard that constant writing onto an SSD isn't the smartest idea, especially when it's my C drive.

But I'm very confused as to why I keep getting these overloads when it seems to me, and my limited knowledge, that my CPU should be just fine.

Bit of background info:
Recording with NVENC, settings down below along with Advanced Settings.
Two logs are for a few minutes of WoW gameplay, recording to either C (SSD) or D (HDD) drives.

CPU: Intel i7-8700K 3.70GHz
RAM: 32GB
GPU: GeForce GTX 1080

I record gameplay for Let's Play purposes and local recordings during streams (in which streaming is done with x264 and works well, other than the main issue).
 

Attachments

  • Settings.png
    Settings.png
    25 KB · Views: 505
  • Settings2.png
    Settings2.png
    22.4 KB · Views: 492
  • 2018-09-03 00-18-53.txt
    18.9 KB · Views: 143
  • 2018-09-03 00-25-31.txt
    12.5 KB · Views: 51

Wishblade

New Member
Putting multiple game/display capture sources in a single scene or scene collection negatively impacts performance.

At first I was curious as to why this was a factor since I did my two brief tests on a new scene with only 1 source, but taking another look I see that the logs say that all scenes are being loaded.

Imagined that only a single scene would be loaded at a time but I can see this being an issue if everything's loaded at the same time, OBS trying to manage all sources, even if they don't display a thing.

Guess I'll test both reducing amount of scenes and/or either removing sources completely or at least turn them off.
 

Narcogen

Active Member
If you want to isolate sources from each other, use separate collections-- all sources in all the scenes in a collection are loaded when you switch to the collection.
 

Wishblade

New Member
If you want to isolate sources from each other, use separate collections-- all sources in all the scenes in a collection are loaded when you switch to the collection.

This is a very good suggestion, thank you.

A while back, I didn't have as many scenes and eventually expanded my amount of scenes when I needed something specific and wanted to avoid messing up. But now that I've learned that all scenes are loaded together, and multiple of the same kind of source and duplicates can be a bad idea, learning of proper scene selection use is great.

Your advice has definitely helped out a bit in reducing the amount of overload I'm seeing, however, some still shows up on occasion.

Even a single scene with a single game source lead me to a tiny bit of overload. A few times the analyzer said there was overload but I couldn't find any by looking in the actual log, but this may be due to me not looking in a particular spot I suppose (attached log does show overload).

Not sure if there's much I can do about that other than the usual lowering of resolution/FPS, which I'd rather not for quality's sake.
 

Attachments

  • 2018-09-03 19-05-51.txt
    7.3 KB · Views: 111

Wishblade

New Member
Decided to bounce between a few settings to see if changing resolution and/or FPS did anything to help out and sadly, not even reducing both to 720p30 removed the few moments of overload.

Once again I find myself thinking that it's impossible to avoid entirely, except for lucky moments, but that still seems weird. Really curious as to what tiny detail somewhere could cause this, or what little tinkering could make it go away.
 
D

Deleted member 121471

Manually update to the latest version of OBS, disable gameDVR in your windows 10 settings, under gaming category, then retest.
 

Wishblade

New Member
Manually update to the latest version of OBS, disable gameDVR in your windows 10 settings, under gaming category, then retest.

Looked into this yesterday and should've gotten all the gameDVR disabled, I would think, at this point.

Gonna update later, since Check For Updates didn't seem to do so, and give it another try, reporting back when I can.
 

Wishblade

New Member
Sadly, after updating OBS and making sure that gameDVR is disabled, it still wants to pop out some overload on occasion.

Not sure if anything special happened I currently can't upload logs due to Failed to connect to obsproject.com port 443: Bad access.

Edit: Got to upload the log, no immediate warnings, so that's still good.

Also, something to note is that I also had this issue before getting a new PC a while back. So either my former and current PC have the same'ish issue or it's something related to OBS or my settings.
 

Attachments

  • 2018-09-04 15-57-57.txt
    18.9 KB · Views: 55
Last edited:
D

Deleted member 121471

A few things come to mind, related and unrelated to your problem:

1) Are you using multiple monitors? If so, what's their refresh rate?

2) Are you capping your FPS via VSYNC or ingame frame rate limiter?

3) Did you configure your NVIDIA driver for max performance and disabled its overlay?

4) Any reason to run OBS with process priority above normal?

5) Can you check in your game capture source properties if Crossfire/SLI is ticked off?

Unrelated to the problem, I really recommend the following:

1) Switch recording format to .flv or .mkv, in case a crash happens and you still want to recover the file, which is something not possible with .mp4. You can remux the file after the recording ends via the main OBS window--->File--->Remux recordings;

2) With your equipment, you're easily able to record using "High Quality" preset quite easily;

3) Run OBS as administrator;

4) Confirm windows 10 is in high performance mode, under power options;

5) Disable fast startup in your windows 10 settings, under power options (solved my personal issues with OBS);

6) Do try recording to SSD to see if it helps. While it does wear it out faster, modern SSD require quite a gigantic number of writes before any perceivable degradation, they were designed for these kind of operations, caching, etc...
 

Wishblade

New Member
A few things come to mind, related and unrelated to your problem:

Currently on break at class so can't quite confirm everything but for now I'll try to answer what I can.

Related:

1) Yes, one being 144hz, the other I'm unsure of.

2) Not sure if I'm doing so in all cases but done so when testing with WoW by limiting FPS on slider, but not by using VSYNC.

3) If by going into the control panel, then yes, and by overlay you refer to what I guess would be called Shadowplay, then also yes.

4) Not really, mostly a remnant of people in the past saying to go for Above Normal and own testing.

5) I'm quite confident they are but will of course check.

Unrelated to the problem:

1) After learning of remux I have thought of that and will probably do so.

2) Fair enough, High Performance is once again a remnant of my own testing, which hasn't done any real difference anyway.

3) Doing that now.

4) High performance is definitely on.

5) Quite confident I've done this.

6) Fair enough, this being something that seemed to help a little bit, but considering getting a separate SSD for it in that case, just to be safe.

Will of course re-check all of this when I have the time later tonight, along with testing, and I appreciate the many inputs and suggestions.
 
D

Deleted member 121471

1) Yes, one being 144hz, the other I'm unsure of.

Currently, there's a problem with multiple monitor setups when it comes to different refresh rates that can manifest as stuttering, inconsistent quality/load, etc... when streaming/recording. it also fixes other potential issues such as laggy cursor during normal use.

I have confirmed on my own setup and those of others I help on twitch that the only reliable workaround is to set each monitor's refresh rate and capturing FPS as multiples of each other. As an example, 144Hz doesn't divide evenly into 60Hz thus issues tend to arise.

In your case, I recommend changing your primary monitor, which I assume is the 144Hz one, to 120Hz, secondary monitor to 120/60Hz (whichever applies) and capturing FPS at 30 or 60 so they all divide evenly and sync correctly.

Finally, there's a Hail Mary solution that also works. Disabling HDCP has solved the problem for a number of people I've tried to help. Unfortunately, you lose access to any protected content from certain streaming services, such as Netflix.
 

Wishblade

New Member
I have confirmed on my own setup and those of others I help on twitch that the only reliable workaround is to set each monitor's refresh rate and capturing FPS as multiples of each other. As an example, 144Hz doesn't divide evenly into 60Hz thus issues tend to arise.

In your case, I recommend changing your primary monitor, which I assume is the 144Hz one, to 120Hz, secondary monitor to 120/60Hz (whichever applies) and capturing FPS at 30 or 60 so they all divide evenly and sync correctly.

I've gone through all your suggestions at this point and checked those off the list but testing will have to wait a bit more since I still have places to go.

My monitors are now confirmed as 144Hz and 60Hz for primary and secondary respectively.

I'm assuming that this specific issue can't just be fixed by changing their settings to 60/120/etc (which would only work for my primary since the secondary only has the option for 60)?
And in case of replacing a monitor, could I also go the other way and replace the 60Hz one with another 144Hz monitor so they both share the same refresh rate?
 
D

Deleted member 121471

My monitors are now confirmed as 144Hz and 60Hz for primary and secondary respectively.

I'm assuming that this specific issue can't just be fixed by changing their settings to 60/120/etc (which would only work for my primary since the secondary only has the option for 60)?
And in case of replacing a monitor, could I also go the other way and replace the 60Hz one with another 144Hz monitor so they both share the same refresh rate?

It would prevent a lot of issues outside of OBS, OBS preview windows stutter and so on but can't guarantee none would crop up in streams/recording due to 144FPS source being recorded at 60FPS, such as inconsistent quality.

Someone more familiar with how OBS captures sources is better suited to give you a definitive answer on this regard. I merely shared my own findings on what reliably works on my own setup(dual monitor 144Hz/75Hz stock down to 120Hz/60Hz) and those of others I've talked to without having to spend money.
 

Wishblade

New Member
It would prevent a lot of issues outside of OBS, OBS preview windows stutter and so on but can't guarantee none would crop up in streams/recording due to 144FPS source being recorded at 60FPS, such as inconsistent quality.

Any and all advice is worth receiving.

Now, after first getting OBS to work with me entirely, WoW not wanting to appear with Game Capture until I started up some other games apparently, I've now done some testing by recording to my HDD: Still some slight overload.

However, testing done while recording to my SSD continues to currently not show any signs of overload.

May have been that I should've just recorded to an SSD all along, who knows at this point with all the tinkering that's been done for as long as this has been an issue for me.

But for now, I think I'll just accept my fate and call it here.
Will likely look into another SSD, just to avoid wearing down my C drive faster than necessary and record onto that, hoping the overloading will be a thing of the past, or at least continue to stick to a minimum.

Thank you all for your help, really appreciate your input, and may you have a good day.
 

GrumbleGamer18

New Member
Was really hoping there would be a solution besides the SSD D: just found this thread, so grateful to have found it, I've been dealing with the same issue, cpu with no problems, but the encoding overload still happens. Seems I may need to get an SSD at this point
 

GrumbleGamer18

New Member
I may be wrong, and the OP may never see this but was your original hard drive nearly full? Mine was 2TB and had 400gb left on it, and I was getting the errors, but once I switched drives I stopped getting the encoding overload issue. I'm still using another hard drive, its just an empty drive. You may just need to keep it 50% empty
 
Top