Question / Help Despite cropping, still records full screen but black?

#1
Hi, first off thank you for this nice product, I'm a new user. I tried to record a video chat online (someone is tutoring me) using "display capture" (because I want to see what's on my screen, hear the other person's voice and my own), but I saw that it was about 250mb or so sized file at the end. I would have preferred something smaller, perhaps 100-150mb, as long as the person's face could be recognizable and voice heard, I was not big on high def quality. I looked at guides and googled my question but still could not figure out how to change anything. One thing I did think about though, was maybe I could crop it cause obviously the video was not the whole screen, it was maybe 2/3. So I thought cropping might help. I finally figured out was that under SOURCES, in display capture, if I right click it opens up filters and so I added crop filter, cropped it, and just now after I recorded our session, I realized it was the same size as before! Turns out it again recorded the whole screen just as before, except that this time where I cropped it, those areas are recorded as black.

Also, in case you're wondering, if I click on properties for the display, it offers me only one choice and that's my current screen resolution. So there was no way to change that to something less.

I have not made any changes to any settings.

So question 1, how can I actually make it record not the rest of my screen but only the part I had it cropped to?

Question 2, are there any other ways to reduce the size of the final file?

Thank you very much.
 
#3
Thank you, I'll try and let you know if it worked...

Edit: found the settings, it's in settings/video.
My base (canvas) resolution is 1366/768, and my output (scaled) resolution is 1092x600.

This number is different because, as I explained above, I cropped out the rest of the screen so I can just record my friend's video on that site, not my whole screen..which unfortunately did not work. In case it's still not clear what I mean, I took a picture now of my OBS as I'm writing this. As you can see, outside the cropped area is black. But if I were to record, it'd record that area still.



How I had achieved this was not by making any changes to SCENES on the left but to Display Capture box right next to it, by adding a filter and cropping it.

Anyhow, so how do I change these base and output numbers so I can solve my problem? Also there is a FPS value in that setting, which is 30. Should I change that too in order to reduce the overall size? To what number?
 
Last edited:

Suslik V

Active Member
#4
You need to change Base (Canvas) Resolution (reduce it) and set Output (Scaled) Resolution to the same value.
I recommend 25 fps if you live in Europe.

Also, you can crop by holding ALT key (easy way, easy cropping) and moving red bounding box of the source. Exact values of the cropping available at main menu Edit>Transform>Edit Transform...
 
#5
Sadly still records the black part outside the crop zone. I'll mention other things that might be the cause and someone might help me if I'm overlooking something obvious:
In the scenes window, I have Scene 1, no changes made to it. On the sources window, I have only "Display Capture" which I have only changed by adding a crop filter and cropping it. I just click on "start recording" and then stop, that's all.
 

Suslik V

Active Member
#6
Yor screenshot says that your Base (Canvas) Resolution has larger size than your 'Display Capture' source.
REDUCE Base (Canvas) Resolution to match the source cropped size. You can type new value in the Base (Canvas) Resolution field at widthxheight format.
 
#7
I know but that was the old screenshot, look at it now, it's changed, but still same problem:



I have also posted output (setting) and video (setting) to show you additional settings. FPS is also 25 as you suggested....
 

Suslik V

Active Member
#9
Your new source size (after cropping) close to 550x382 - type this value in Base (Canvas) Resolution field of the OBS Studio. Unfortunately, Crop/Pad filter never shows new source size (after cropping performed), so you need to calculate it manually.
Hope, this could be changed soon.
You can use ALT+mouse drag to crop the source, then exact crop values available under the main menu Edit>Transform>Edit Transform...>Crop (not under the filters).
Initial values of source size available under main menu Edit>Transform>Edit Transform...>Size.
 
Last edited:
#10
Thanks guys in particular Suslik. I'm getting closer apparently but still not quite there....
Here's a picture of both my OBS minimized and maximized after I put in 550x382 (which it reduced for some reason to 548x382)

 

Suslik V

Active Member
#11
From the screen I see that you forgot to crop the source itself. Base resolution is OK. Just select this source and go to the Edit>Transform>Edit Transform...>Crop and adjust the crop fields.
 
#12
From the screen I see that you forgot to crop the source itself. Base resolution is OK. Just select this source and go to the Edit>Transform>Edit Transform...>Crop and adjust the crop fields.
Suslik, sorry if my questions are stupid, I'm not good with technology, but just want to say is there a problem that I cropped my video with display captures filters already, and so I need to crop them again here? And secondly, you mind telling me how you calculated 550x382 above? Thank you.
 

Suslik V

Active Member
#13
It was simple - your posted screenshot was fullscreen (not resized) I count pixels via editor (it was Gimp or even XnView viewer - I don't remember).

If you really cropped source via Crop/Pad filter then it has red bounding box exactly as cropped (final) size. It is easier to crop sources by easy cropping feature, OBS Studio Help Guide: https://obsproject.com/forum/resour...ware-studio-multiplatform-help-guide-pdf.365/ look for easy cropping.
From the current screen I see that your source bigger than Base (obs preview window) - red bounding box of the source larger than Base (obs preview window). You need to crop more pixels.
 
Top