Free Chatty 0.8.4.1

Twitch Chat Client with Admin Panel and more

  1. tduva Member

    tduva submitted a new resource:

    Chatty - Twitch Chat Client with Admin Panel and more

    Read more about this resource...
  2. Sapiens

    Moderator

    Great work, thanks so much for contributing this.
  3. XeiZ Well-Known Member

    Nice work, was a bit turned off by .jar at first but it really is a nice and easy to use tool.
    Jack0r likes this.
  4. tduva Member

    tduva updated Chatty with a new update entry:

    Popout channels to view them side-by-side, a lot of smaller Improvements and Bugfixes

    Read the rest of this update entry...
  5. tduva Member

  6. XeiZ Well-Known Member

    That is a nice update. :)

    Livestreamer integration produces this though:
    Traceback (most recent call last):
    File "<string>", line 6, in <module>
    File "__main__.py", line 128, in <module>
    File "__main__livestreamer__.py", line 8, in <module>
    File "livestreamer\cli.py", line 462, in main
    File "livestreamer\cli.py", line 347, in handle_url
    File "livestreamer\plugin.py", line 95, in get_streams
    File "livestreamer\plugins\justintv.py", line 183, in _get_streams
    File "livestreamer\plugins\justintv.py", line 105, in _get_rtmp_streams
    IndexError: list index out of range
    PROCESS ENDED.

    Also it would be nice to be able to select the quality (maybe thats after that error appears?)
  7. tduva Member

    No idea what that error is, it's not from Chatty. Have you tried running the same command on the commandline?
  8. XeiZ Well-Known Member

    What command? I enter a streams name in the field in chatty and it fails with this error, livestreamer on its own outside of chatty works just fine.
  9. tduva Member

    Chatty executes a command that runs livestreamer, the output you see in the window mostly comes directly from the output of livestreamer. For example:
    The first and last line are from Chatty, everything else is from livestreamer.

    The error you had obviously occurs in Livestreamer, as for the reason I don't know. If the same command works on the regular commandline maybe Chatty needs to set some environment variables for executing the command. What OS are you on? It works fine for me on Windows 7.
  10. XeiZ Well-Known Member

    Windows 8, you might be right i'll look into the enviroment variables, didnt even think about that.
  11. tduva Member

    Have you actually tried running the same command as Chatty does on the commandline? Maybe you could try to just enter "-V" in Chatty, to test if it runs at all (Livestreamer should show it's version).
  12. XeiZ Well-Known Member

    livestreamer 1.4.2
    That is a really old version huh. The one i use is 1.8 something
    And yes i simply use "livestreamer twitch.tv/name source" with "normal" livestreamer, nothing fancy.
  13. tduva Member

    Are you meaning to say the version that comes up in Chatty when you enter "-V" is 1.4.2, but the one you usually use should be 1.8.1? That is strange, because Chatty literally just runs the command "livestreamer <whatever you entered>", so it should use the one that's defined in the PATH variable.
  14. XeiZ Well-Known Member

    Edit and cut the post: After a witch hunt through the registry i found some last remaining files of an older version of livestreamer which even overwrote the enviroment variables.... so if anyone ever gets that error, look for livestreamer related stuff everywhere... urg
    Last edited: May 29, 2014
  15. XeiZ Well-Known Member

    Another thing that keeps happening to me is that chatty just randomly closes, i tried reinstalling java but that didnt help.
    Most of the time it happens when im in the settings menu, sometimes it also just closes when im just typing in chat.
    Seems completely random about the time, so it sometimes happens within seconds of opening the settings or bringing chatty in focus and other times it takes minutes or doesnt crash at all.
    Any idea what might cause this? It might not even chatty related tbh but other java applications dont do this.
    http://pastebin.com/E15NM322
  16. tduva Member

    I don't think I ever had a crash like that with Java, so I'm not sure what to do with it. From the log you posted, it seems to be related to the "C:\Windows\SYSTEM32\atig6txx.dll" which apparently is related to your graphics driver.

    Code | Analyze
    # Problematic frame:
    # C  [atig6txx.dll+0x122bf]
    In a forum post for another program it is suggested for a similiar crash to update your graphics driver, or if that fails to use the parameter "-Dsun.awt.nopixfmt=true" which apparently disables the calls to the library that cause the error. (See also Bug JDK-6477756 which may be related.)

    Code | Analyze
    Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
    j  sun.awt.Win32GraphicsDevice.getMaxConfigsImpl(I)I+0
    j  sun.awt.Win32GraphicsDevice.getMaxConfigs(I)I+10
    j  sun.awt.Win32GraphicsDevice.getConfigurations()[Ljava/awt/GraphicsConfiguration;+69
    
  17. XeiZ Well-Known Member

    Thanks, completely wiped my drivers and reinstalled and seems to work so far.

    edit: well nevermind its back... i blame shitty amd drivers..., that parameter would have to go where? I guess the target line of a shortcut? Sorry i dont really know much about java.
    Last edited: Jun 2, 2014
  18. tduva Member

    I suppose this should do it:
    Code | Analyze
    javaw -Dsun.awt.nopixfmt=true -jar "H:\chatty\Chatty.jar" -cd
  19. XeiZ Well-Known Member

    Thanks, i feel dumb now...

    - that did the trick, if anyone ever has this issue, there is your solution/workaround.
    Last edited: Jun 4, 2014
  20. tduva Member