Bug Report Browser Source doesn't allow microphone consent dialogs

Tim Heuer

New Member
When using a browser source and the source has a microphone access request, it can't be used because the consent dialog doesn't show or now way to click it at least in interactive mode.

Is there a way to do this?

Example: webcaptioner.com as the Browser Source. (note: yes i know I can use a window source here, but prefer to use browser source if possible)
 

JettWilliams

New Member
You can start OBS from the command line with the flag --enable-media-stream

Windows cmd:
C:\Program Files\obs-studio\bin\64bit>obs64.exe --enable-media-stream

macOS terminal:
/Applications/OBS.app/Contents/MacOS/OBS --enable-media-stream
 
Last edited:

danieljaber

New Member
Hi. I have the same problem. Open OBS with --enable-media-stream in the end, in command prompt, working good for me. There is not any other easiest solution yet? I mean, some configuration that fix it at all and, when I start OBS from my desktop shortcut, it's already with enable media stream?

Thanks.
 

carlmmii

Active Member
Hi. I have the same problem. Open OBS with --enable-media-stream in the end, in command prompt, working good for me. There is not any other easiest solution yet? I mean, some configuration that fix it at all and, when I start OBS from my desktop shortcut, it's already with enable media stream?

Thanks.
You can create a desktop shortcut to OBS with that flag in the target field.
 

Advansys

New Member
Can someone confirm this command line approach works? I can see it has worked for @carlmmii, which is great. I am also trying to use Webcaptioner and yet even with starting with the command line parameters, it won't allow the permissions for the micrphone.
 
Boa Noite estou com o mesmo problema citados acima tenho dois notebook que de inicio 01 parou de receber o audio, apesar de reconhecer a placa de captura da roland ou x32, agora meu outro notebook tbm nao recebe o sinal de audio, e ja executei essas acoes acima mas nao resolvem.
 

Attachments

JettWilliams

New Member
Boa Noite estou com o mesmo problema citados acima tenho dois notebook que de inicio 01 parou de receber o audio, apesar de reconhecer a placa de captura da roland ou x32, agora meu outro notebook tbm nao recebe o sinal de audio, e ja executei essas acoes acima mas nao resolvem.
Looks like the space in Program Files can cause problems. Try
cd "C:\Program Files\obs-studio\bin\64bit"
Followed by
obs64.exe --enable-media-stream
Note: it will use the default microphone in Windows sound settings.
 

JettWilliams

New Member
You can create a desktop shortcut to OBS with that flag in the target field.
Or simply right click on your OBS desktop shortcut -> Properties, and paste --enable-media-stream at the end of the Shortcut -> Target field. Something like this:
"C:\Program Files\obs-studio\bin\64bit\obs64.exe" --enable-media-stream
 
Top