Question / Help Black screen game capture on PC, no SLI option


New Member
Hi all,

I've done a lot of searching on how to fix my OBS black screen issue. When I try to capture a game window, it is rendered black, and earlier today it did the same to my webcam, but that got fixed by removing and re-adding the source. I *think* my problem is that I need to set my GPU to Intel and not Nvidia. However, I'm unable to do this as I don't have the option to "Set the preferred graphics processor for this program" when I go to the 3D setting on the Nvidia control panel.

Is anyone able to help? My log file can be found below.


Many thanks.


New Member
Running OBS 22.0.2 here and also having similar issues. There is a work-around though...

Two bugs in OBS seem to be triggered by hardware configs with multiple GPUs that share a single display (ie. MSI gaming laptop with Intel+nVidia GPU in my case)... black screens with sound, and capturing only part of the screen with sound are the result. The problem is that the game starts on the Intel GPU, then switches to the nVidia GPU after a few seconds, and this seems to confuse OBS. Display capture just can't figure out which GPU to capture from despite the fact that both GPUs use the same display, and GameCapture+ForegroundWindowWithHotKey almost works, but captures only part of the screen — ie. the game's render-resolution of 1280x720 is cut out of the top-left corner of the stretched 1920x1080 display (mistakenly trimming away the right- and bottom-edges of the frame, making the resulting video rather useless.)

The only workaround I could find is this, and it's a bit inconvenient as you have to add a capture source for each game, but it works... To add the capture source, start the game and leave it running, but alt-tab out of it. Then, start OBS, and add a new GameCapture source in SpecificWindow mode... pick your running game in the Window drop-down, then for matchMode choose MatchTitleOtherwiseFindWindowOfSameExecutable and leave all the checkboxes below unchecked. Save your config. After doing these steps, it's business as usual for every other session where you're going to capture/stream... start OBS first and minimize it, start the game and play, then hit your start-capture/stop-capture shortcuts as needed...

This work-around produces a perfect capture (on my rig.)
Last edited:


New Member
And... If your capture suddenly decides to become a shrunken-down screen off in a corner of your captured video, try right-clicking the source and go transform→FitToScreen ... :)