Question / Help Avermedia lgp lite gl310 not showing anything on OBS

I bought an Avermedia lgp lite gl310 and I am using OBS Studio V 24.0.3 (64 bit) on Windows 10.
I have tried the 32 bit version of OBS as well. Same result.

The capture card works with the Avermedia software, and in OBS I do see it in the list of
video capture devices, but the feed is either missing, or it is stuck on 1 frame.

I once got it to work while streaming from a laptop after several failures, but on a 2nd attempt it failed.
I get the same error streaming from my PS4 or another computer. I seem to have slightly less luck on the PS4 than the other PC though.
I have attached the log file of one of these sessions.


I found a workaround...
A. Make sure HDCP is turned off on your PS4 or console.
As I tested the workaround suddenly it worked normally... but
in case I have this problem again... open the ReCentral software for the card.
Go to "capture", set that to full screen(on a second monitor preferably), and then
feed that monitor to OBS... problem solved. It works.