Audio sometimes shattered for a second

carlmmii

Active Member
Code:
19:53:32.064: audio settings reset:
19:53:32.064:     samples per sec: 44100
19:53:32.064:     speakers:        2

19:53:32.644: WASAPI: Device 'Speakers (Gioteck HC3 stereo headset)' [48000 Hz] initialized
19:53:32.644: [Loaded global audio device]: 'Desktop Audio'
19:53:32.688: WASAPI: Device 'Microphone (Gioteck HC3 stereo headset)' [44100 Hz] initialized
19:53:32.689: [Loaded global audio device]: 'Mic/Aux'
19:53:32.689: Switched to scene 'Scene'
Set all of these to the same sample rate.

For OBS, this is in the Settings -> Audio pane.

For your devices, go to Windows Settings -> System -> Sound -> Sound Control Panel, then open the properties for each device, go to the Advanced tab, and change the format to match the sample rate desired.
 

wkdc

New Member
Code:
19:53:32.064: audio settings reset:
19:53:32.064:     samples per sec: 44100
19:53:32.064:     speakers:        2

19:53:32.644: WASAPI: Device 'Speakers (Gioteck HC3 stereo headset)' [48000 Hz] initialized
19:53:32.644: [Loaded global audio device]: 'Desktop Audio'
19:53:32.688: WASAPI: Device 'Microphone (Gioteck HC3 stereo headset)' [44100 Hz] initialized
19:53:32.689: [Loaded global audio device]: 'Mic/Aux'
19:53:32.689: Switched to scene 'Scene'
Set all of these to the same sample rate.

For OBS, this is in the Settings -> Audio pane.

For your devices, go to Windows Settings -> System -> Sound -> Sound Control Panel, then open the properties for each device, go to the Advanced tab, and change the format to match the sample rate desired.
After doing it I can only say that the audio shatter it's smaller, but still present, unless I have missed something.

Log of last time:
 

carlmmii

Active Member
You could give it a shot, but it sounds like this isn't a sample conversion issue.

Can you give a recording of the actual issue you're experiencing? Would probably be easier to diagnose if we know exactly what you're getting in the recording.
 

wkdc

New Member

wkdc

New Member
I did the 3 things: set audio bitrate to 320, change all samples rate to 44100 and also installed AAC Audio codec.

Still nothing. I still get the issue and truly believe it has absolutely no solution. Thanks anyway for the help. In case that matters, I am using a Windows 10 version unupdated since 7 months (last update ruined my PC and I had to format). Also I record with headphones plugged for noise reasons.

Log: https://obsproject.com/logs/T2agqOTE0WEZcyFp
 
Last edited:

carlmmii

Active Member
One last thing to try.... what happens if you save a replay? You say you're having this issue about every 2 minutes in recording, so try saving a 4 minute replay and see if it has the same issue. Don't record at the same time, just have the replay buffer going.
 

wkdc

New Member
One last thing to try.... what happens if you save a replay? You say you're having this issue about every 2 minutes in recording, so try saving a 4 minute replay and see if it has the same issue. Don't record at the same time, just have the replay buffer going.
I don't understand what do you mean, What's the difference? How do I save a replay without recording?
 

carlmmii

Active Member
Set up the replay buffer (in settings -> output), make sure it's set to record at least 4 minutes (240 seconds). Then set up a hotkey to save your replay buffer.

Then, start the replay buffer, and go about your normal gameplay. Once you've reached 4 minutes, hit hotkey to save the replay.

The reason for this is because when using the replay buffer, OBS stores the encoded data directly to RAM, and only does disk writing once it needs to save the replay... as opposed to writing all the data to disk as it's created. Doing this is a way to isolate any potential issues with OBS writing to disk (for troubleshooting purposes -- this obviously isn't a sustainable method for actual recording).
 
Top