Bug Report Audio Pops, Sizzle/Fry, Stutters From Avermedia Live Gamer Ultra GC533

kaiservongrauer

New Member
When I'm capturing audio from my Avermedia Live Gamer Ultra GC533, I get these occasional audio sizzles/fry, small pops, and stutters. Here's my setup:

MacBook Pro (15-inch, 2018)
2.9 GHz Intel Core i9
32 GB 2400 MHz DDR4
Radeon Pro 560X 4096 MB
Intel UHD Graphics 630 1536 MB
MacOS Mojave Version 10.14.2

Here's a list of everything connected to the MacBook Pro:
Xbox One X > GC553 > Apple Thunderbolt 3 USB-C Cable > MacBookPro
Mixamp Pro TR > Focusrite Scarlett 2i2 > USB Cable > CalDigit TS3Plus Hub > Apple Thunderbolt 3 USB-C Cable > MacBookPro
Logitech C922 Camera > USB Cable > CalDigit TS3Plus Hub > Apple Thunderbolt 3 USB-C Cable > MacBookPro
ElGato StreamDeck > USB Cable > CalDigit TS3Plus Hub > Apple Thunderbolt 3 USB-C Cable > MacBookPro

Here's an example of the sizzling/popping sound, coming through on a twitch recording:
https://www.twitch.tv/videos/346111640

This happens when I create a source for Audio Input Capture and set the device to the GC553. In the mixer, if I raise or lower the volume for this source, the sizzle/fry sound raises and lowers on that channel.

I was even able to reproduce the issue on a different MacBook Pro using the same setup.

I managed to figure out a workaround by deleting the Audio Input Capture via the GC553 and capturing the game audio through the Mixamp Pro TR. It works but my game audio, chat, and chat mic all come through the same channel and I'd like to be able to adjust the channels through OBS.

I contacted Apple support (got upgraded to Tier 2, went back and forth with their engineers) and this was their final verdict:

After looking over the data, the issue they are reporting is related to one of their USB audio devices having a clock rate or sync issue.

The logging is indicating that a USB audio device is ‘falling behind’ meaning that its clock is not in sync with the master clock and the sample rate is going out of sync, creating the distortion they are hearing.

This is indicated as such:

2018-12-14 09:25:44.030919 -0800 kernel USB Sound assertion (Input Fell Behind) in /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleUSBAudio/AppleUSBAudio-315.6/AppleUSBAudioDevice.cpp at line 6502

The reference to the basic Apple USB Audio driver indicates that the device is a class compliant device, but as most USB Audio devices are, or can be, sadly that doesn’t help narrow down which is specifically having the issue.

However, right off the bat, we can see that their Live Gamer Ultra-Audio, CalDigit devices, and their Scarlett 2i2 are set to different sample rates.

Live Gamer Ultra-Audio:
Input Channels: 2
Manufacturer: AVerMedia
Current SampleRate: 48000
Transport: USB
Input Source: Default

CalDigit Thunderbolt 3 Audio:
Manufacturer: CalDigit, Inc.
Output Channels: 2
Current SampleRate: 48000
Transport: USB
Output Source: Speaker

CalDigit Thunderbolt 3 Audio:
Input Channels: 2
Manufacturer: CalDigit, Inc.
Current SampleRate: 48000
Transport: USB
Input Source: Default

Scarlett 2i2 USB:
Default Input Device: Yes
Input Channels: 2
Manufacturer: Focusrite
Output Channels: 2
Current SampleRate: 44100
Transport: USB
Input Source: Default
Output Source: Default

The system is reporting (as seen above) that the AVermedia and CalDigit devices are set to 48kHz and the Scarlett is set to 44.1kHz. If these devices are both being used by the same app, or are configured as an ‘aggregate’ audio device with themselves or another device, then there will be unmatched sample rates that will lead to issues like the customer is describing. And there is an aggregate showing in their configuration that is set to 48kHz sample rate as seen below.

Aggregate Device:
Input Channels: 6
Manufacturer: Apple Inc.
Output Channels: 2
Current SampleRate: 48000
Transport: Unknown
Input Source: Default
Output Source: Default

We would suggest that the customer set their Scarlett 2i2 to a 48kHz sample/clock rate and assure that all devices are in a class compliant mode to assure they are all using nonconflicting standard USB audio drivers.

They’ll also want to make sure they have the most current firmware for their particular devices, especially the AVermedia and Scarlett as they both would be the most ‘involved’ in creating an issue like this.

Outside of that, the customer will want to continue working with both the developer of OBS (for configuration assistance with the app itself an its sample rate settings, etc.) and the manufacturers of their other devices (CalDigit, AVermedia and Focusrite).

The good news, is that this is related to one of the USB audio devices, or simply its configuration, not the computer itself.

So as to not interrupt their current install, they may want to create a new test partition on their internal HDD and install a clean installation of macOS Mojave and setup the devices and test various configurations there. Then, once they find the culprit (be that a simple configuration issue, firmware issue, or even having an issue with the HW on one of the USB devices noted) they can isolate it and go back to their main install and adjust the changes there.

Though we can’t 100% resolve this one for the since it is pointing to one of the USB devices (or its configuration) as the source of the issue, I do hope this helps them get back up and running and configured correctly, or helps them locate which piece of USB audio hardware is causing the conflict

Alright then. Yes, all of my firmware on everything is up to date. I went into OBS > Settings > Audio and changed my sample rate to 48khz. Then on the Mac I went into Audio Midi Setup and changed as much as I could to 48khz:

CalDigit Thunderbolt 3 Audio 1 Output > Format: 2 ch 16 bit integer 48.0khz
CalDigit Thunderbolt 3 Audio 2 Input > Format: 2ch 16 bit integer 48.0khz
Live Gamer Ultra-Audio > Format: 2ch 16 bit integer 48khz

But these two... this was as close as I could get:
Scarlett 2i2 USB > Format: 2ch 24-bit integer 48.0khz
C922 Pro Stream Webcam > 2ch 16-bit integer 32khz

I can't change the bit depth on the Scarlett 2i2, and I can't change the sample rate on the C922 Webcam to anything higher than 32khz. Could this really be the problem? I'm not even capturing audio from the webcam but I recognize how it might be a problem. Do I need to get a new mixer or a fancier webcam? Or are some of my settings in OBS just off or wrong?

And the weird thing is if I remove the Live Gamer Ultra as the audio capture source for game audio and capture the audio through the mixamp pro tr > Scarlett, I don't hear any pops.

I'm pulling my hair out over here. Any ideas?
 

Attachments

  • 2018-12-20 11-46-08.txt
    13 KB · Views: 57

Narcogen

Active Member
If you make a new scene collection and unplug everything from the hub, and build the scene collection piece by piece, one source at a time, plugging them in as you go, when does the problem occur? Right away, after the first device? After all are connected?
 

kaiservongrauer

New Member
If you make a new scene collection and unplug everything from the hub, and build the scene collection piece by piece, one source at a time, plugging them in as you go, when does the problem occur? Right away, after the first device? After all are connected?

Ok, I just tried it with only the GC553 plugged in (not even power supply) and it happened. New scene with only video capture and audio capture sources both set to the GC553. Log attached.

Here's a video of it happening with that corresponding log file:

https://youtu.be/6JAs6z_Suq8

Thoughts?
 

Attachments

  • 2018-12-22 18-15-03.txt
    15.3 KB · Views: 29

kaiservongrauer

New Member
I've been in touch with Avermedia support and they're attempting to reproduce the issue on their end.

In the meantime, I got an Epiphany Av.io 4k, hooked it up AND I GOT THE SAME BUZZING SOUND.

So here's the score to date:

1. Caldigit says it's not their problem (and it probably isn't because it happens without the hub plugged in)
2. Apple thinks one of the USB devices has a clock or sync issue. (probably not that because it happens with only the capture device plugged in)
3. Avermedia - they're attempting to reproduce the issue on their end
4. I was able to reproduce the issue with the Avermedia device running on an early 2018 i7 MBP
5. I was able to reproduce the issue using a completely different capture device - an Epiphan Av.io 4k.

At this point I'm beginning to think this is a bug with OBS.

Again, whenever I create a source for an audio input capture and I set it to be the same device as my video input capture device, I get intermittent buzzing from the audio input capture source.

Please let me know if there's any other info I can provide, settings I can try, or whatever.
 

kaiservongrauer

New Member
I dragged my MBP and the Avermedia upstairs and connected it to an older Xbox One. I created a new scene, added the GC533 as the video capture device and also as the audio capture device. I turned on monitoring, waited a bit, and heard the buzz.

I guess my next move is to see if I can reproduce the buzz with different capture software.
 

kaiservongrauer

New Member
I tried using Avermedia's Recentral Express and the darned thing barely runs on my Mac, even after rebooting. I just couldn't get it to run. Next, I tired Wirecast and after an hour or so of puttering around with it, I couldn't get any sound at all. At first the meters weren't showing any activity at all; later they were but I couldn't figure out how to get any sound from Wirecast to come out of my Mac. So, you know, kudos to OBS, lol!
 

kaiservongrauer

New Member
I installed bootcamp on my Mac and installed Windows 10 Pro (Please forgive me, Steve). I plugged everything in, let Windows detect everything, let it reboot and gave it a shot.

I installed OBS and when I used the GC553 both as a video source and an audio source, the sound from the GC553 would work ok for maybe 10 to 30 seconds and then would either stop completely or begin to stutter and lag really bad. It's really hard to describe but suffice it to say, it didn't work. Next I gave Streamlabs OBS a shot and got the same result.

There's just way too many variables with running bootcamp and Windows 10 Pro on a Mac with all these devices plugged in and using OBS for me to troubleshoot, so I uninstalled bootcamp, took a walk around the neighborhood in the rain, and kicked back with a series of strong cocktails to attempt to forget the whole bootcamp thing ever happened.
 

kaiservongrauer

New Member
Ok big update on this issue from CDM.com

Apple’s latest Macs have a serious audio glitching bug Peter Kirn - February 18, 2019

Apple has a serious, unresolved bug that causes issues with audio performance with external interfaces across all its latest Macs, thanks to the company’s own software and custom security chip.

Following bug reports online, the impacted machines are all the newest computers – those with Apple’s own T2 security chip:

  • iMac Pro
  • Mac mini models introduced in 2018
  • MacBook Air models introduced in 2018
  • MacBook Pro models introduced in 2018
Impacted hardware of this and possibly other bugs includes most external USB 2.0 audio hardware. We have have some reports of issues over FireWire, which initially had seemed like a refuge. Perversely, readers are also reporting widespread issues with Apple’s own internal audio (speakers and headphone jack).

The T2 in Apple’s words “is Apple’s second-generation, custom silicon for Mac. By redesigning and integrating several controllers found in other Mac computers—such as the System Management Controller, image signal processor, audio controller, and SSD controller—the T2 chip delivers new capabilities to your Mac.”

The problem is, it appears that this new chip has introduced glitches on a wide variety of external audio hardware from across the pro audio industry, thanks to a bug in Apple’s software. Issues with the way the new chip synchronizes timing causes dropouts and glitches in the audio stream. (It seems basically all USB 2.0 audio interfaces will be impacted. This of course unfortunately leads users to blame their interface manufacturer, but the fault lies with Apple.)

Switching off “Set date and time automatically” in System Preferences will reduce, but not resolve the issue. Nebulae aka Abid Hussain, an Ableton Certified trainer, writes in comments:

Unchecking the time sync only reduces the dropouts. You need to also uncheck the location sync in the Time Zone tab, but even then you’re only reducing the dropouts. Any time the T2 chip tries to sync, it will overload the USB2.0 bus, causing dropouts. There is no way any musician should go on stage with a 2018 [Mac] and a USB2.0 audio interface directly connected to it. The only solutions are 1) Get a Thunderbolt or USB3.0 audio interface, or 2) Use a Certified Thunderbolt 3 powered hub (not a bus-powered or cheap non-certified hub) – Cable Matters has a solution for $169 on Amazon, but most of those hubs are at least $200-300. Using a certified TB3 hub creates a separate external USB2.0 bus, in which you can run your USB2.0 audio interface. The cheap hubs do not work because they don’t run on the TB3 bus, and therefore they don’t create their own separate USB2.0 bus, which means you’re going to get dropouts.​
To clarify: all T2-based Macs, that is all Mac models from the 2018 generation, are evidently unusable with USB 2.0 audio interfaces, irrespective of vendor. Audio interfaces using FireWire or Thunderbolt are reportedly unaffected by this particular bug, but USB 2.0 is for the moment the most popular bus for audio devices, so nearly all owners of the new machines are encountering the issue. (There are also some reports that USB3 devices are unaffected, but I can’t confirm that and those devices are rare. Note that even some audio interfaces with USB-C connectors do actually make use of the USB2.0 bus.)

This of course has led some users to simply buy a new Thunderbolt 3 audio interface. But this situation is unacceptable – plenty of standard, inexpensive PCs have no such issues with Thunderbolt and USB audio hardware. Apple has shipped their entire computer line with buggy firmware that renders those machines unusable for the majority of people working with sound (so music, video, and audio production), and have lagged in finding a solution for months after shipping these expensive machines. Not only that, but is anyone clear on what problem the T2 security chip even solves? Apple now loves crowing about its “custom silicon” often without even explaining to us why anyone needs it.

Anyway, for now that’s the set of choices, until Apple ships a comprehensive, tested fix:
1. Mac users on older machines should postpone upgrading.
2. Mac users in the market purchasing a new machine right now should consider a comparable Windows machine.
3. Users stuck with these models should use a Thunderbolt 3 audio interface, adapter, or hub, or attempt to return the computer in favor of an older Mac or new PC.

More:
https://www.reddit.com/r/apple/comments/anvufc/psa_2018_macs_with_t2_chip_unusable_with_external/

https://discussions.apple.com/thread/8509051

https://www.logicprohelp.com/forum/viewtopic.php?t=138992

https://www.gearslutz.com/board/music-computers/1232030-usb-audio-glitches-macbook-pro-2018-a.html

https://openradar.appspot.com/46918065

This represents another serious quality control fumble from Apple. The value proposition with Apple always been that the company’s control over its own hardware, software, and industrial engineering meant a more predictable product. But when Apple botches the quality of its own products and doesn’t test and resolve creative audio and video use cases, that value case quickly flips. You’re sacrificing choice and paying a higher price for a product that’s actually worse.

Apple’s recent Mac line have also come under fire for charging a premium price while sacrificing things users want (like NVIDIA graphics cards, affordable internal storage, or extra ports). And on the new thin MacBook and MacBook Pro lines, keyboard reliability issues.

Some of those mainstream PC vendors do now test with third-party pro audio hardware (I’ve talked to Razer about this, for instance). And that’s to say nothing of vendors like pcaudiolabs who custom-configure each machine for the actual DAWs. Apple clearly has the resources to do the same, and they make a DAW of their own (Logic Pro). This appears to be an issue they could possibly have reproduced and corrected before shipping.

Updated: The 2018 iPad Pro also suffered from audio issues, which appear to be software related. This seems not to have any direct relation to the issue with the Mac line, but is further evidence of some quality control and testing issues involving real-time audio performance and Apple firmware and software.

If you do have one of these machines, let us know if you’ve been having trouble with this issue and if this workaround (hopefully) solves your problem.

I'll be testing this workaround later today and will report back.
 

kaiservongrauer

New Member
Ok, so I've got everything plugged into the CalDigit TS3 Plus hub and the hub is connected via Thunderbolt 3 Cable. I disabled set date and time automatically and disabled set time zone automatically using current location. Gah, still happening.
 
Last edited:
Top