Question / Help After Updating (21.1.0 > 22.0.2), QuickSync no longer an option


Hi, I hadn't streamed in awhile and didn't realize OBS Studio didn't auto update, so I manually downloaded the installer and overwrote the installed files. Opened OBS64 and noticed in the settings output tab I only have x264 and NVENC, no more QSV? It worked fine on 21.1.0 and I have a Skylake CPU with QSV enabled in BIOS (obviously since it was working before the update). Tried restarting Windows, it still fails to appear in the dropdown menu.

The log file for some reason shows my NVidia card twice instead, comparison of log files


03:15:45.192: Initializing D3D11...
03:15:45.192: Available Video Adapters:
03:15:45.195: Adapter 1: Intel(R) HD Graphics 520
03:15:45.195: Dedicated VRAM: 201326592
03:15:45.195: Shared VRAM: 1711276032
03:15:45.195: output 1: pos={0, 0}, size={1920, 1080}, attached=true
03:15:45.196: Adapter 2: NVIDIA GeForce 940M
03:15:45.196: Dedicated VRAM: 2093875200
03:15:45.196: Shared VRAM: 2147610624
03:15:45.200: Loading up D3D11 on adapter Intel(R) HD Graphics 520 (0)
03:15:45.208: D3D11 loaded successfully, feature level used: 45056


03:30:23.625: Initializing D3D11...
03:30:23.625: Available Video Adapters:
03:30:23.634: Adapter 1: NVIDIA GeForce 940M
03:30:23.634: Dedicated VRAM: 2093875200
03:30:23.634: Shared VRAM: 2147610624
03:30:23.634: output 1: pos={0, 0}, size={1920, 1080}, attached=true
03:30:23.635: Adapter 2: NVIDIA GeForce 940M
03:30:23.635: Dedicated VRAM: 2093875200
03:30:23.635: Shared VRAM: 2147610624
03:30:23.642: Loading up D3D11 on adapter NVIDIA GeForce 940M (0)
03:30:24.596: D3D11 loaded successfully, feature level used: 45056


Ok I fixed this by going into the Nvidia control panel and forcing OBS to use the "Integrated Graphics". Not sure why OBS is defaulting to Nvidia now?

EDIT: I see the changelog actually says that the program now opens with Nvidia GPU by default now on laptops, this seems to not allow QSV encoding however.
Last edited:


Forum Admin
Forum Moderator
As of OBS Studio 22.0.0, OBS tries to prefer running on the discrete/high-performance GPU to accommodate the new browser source hardware acceleration. This is because in our pre-release testing, the browser source hardware acceleration did not work well or at all on Intel integrated GPUs. In order to achieve the most viable configurations, OBS was configured to attempt to run on the high-performance GPU if available.

For some reason, on your laptop, this is causing Windows to tell OBS that your systems two GPUs are both NVIDIA GeForce 940M cards. That's not normal, but that's likely a side-effect of a driver installation issue or the hardware configuration of that laptop. If I recall correctly, the 8xxM/9xxM series (and AMD switchable graphics laptops) in particular have some odd hardware configurations. You shouldn't have to run OBS on the Intel GPU to get QuickSync available (I don't on mine), but if the system doesn't show an Intel GPU for some reason, then OBS probably wouldn't be able to use QuickSync in those situations.