advanced scene switcher on Linux


New Member
Greetings all: Not sure what is going on, but my version of Advanced Scene Switcher only has 4 tabs, general, macro, network and scene group. I am trying to follow a tutorial to switch between two scenes by timer and there is no "sequence" tab. Tried installing flatpak and downloaded the plugin from here as well. What is likely the reason those tabs aren't showing? Any help is appreciated.


New Member
Hey! I've run into this issue, and you can actually do the timer-based scene switching on your current version of Advanced Scene Switcher with the 4 tabs. (I don't know why the plugin looks so different though, it might just be a different version)
I'm currently using it for a Pomodoro stream, so the implementation is likely similar to what you're looking for.

Go into your Macro tab, and click the "+" button at the bottom left:

Screen Shot 2022-07-03 at 2.04.37 PM.png

Then, name the Macro whatever you want. From what I understand, a Macro basically defines a condition (e.g. when you are on Scene 1 for a certain number of minutes) and an action to execute when that condition is fulfilled (e.g. switch to Scene 2). So, in the Macro you just made, click the "+" sign under the first section on the right to create a new condiiton:

Screen Shot 2022-07-03 at 2.09.04 PM.png

And then you can define your condition however you want. Since you want to switch scenes based on a timer, you should click the clock symbol next to the "If" "Scene" dropdowns, and customize the amount of time you want to spend on the scene. Then, select the scene using the "--select scene--" dropdown.
Then, click the "+" sign under the bottom section on the right to define a Macro action, and switch the scene to whichever scene you want to switch to.
Once that's done, you can also create a second Macro (in the left hand Macros column) to switch back to the previous scene if you want.

Hope this helps!


New Member
Hola! me paso lo mismo. Al parecer es donde actualizaron la versión del plugin. Baje una más antigua y me funcionaron todas las pestañas.

Espero te ayude. Saludos.

Hello! The same happened to me. Apparently it is where to update the version of the plugin. I downloaded an older version and all the tabs worked for me. I hope it helps you. Greetings.