Source Record

Source Record 0.3.4

I used in past but awful now some reason it closed my games now even though didn't have issue before and change anything. Only issue before was audio sync but I was able to fix each time in editing software.
So far I have downloaded it and installed it into the right folder I would like to say over 10 times now. I love the concept and would love to have this work properly for me. But even before I updated my obs version the plugin still wasn't working. If the plugin can be updated to 27.2.4 that would be wonderful. But so far sense I have no way of directly telling if it is (because in the overview it only shows the plugin version and not the version compatibility) I won't be able to use it. If I could have help figuring out why it won't show up, that would be great. If it's just the version compatibility then I will just have to hope the creators can update it soon enough.
I like to use this amazing plugin, but in reality it is limitedly useful, because each grab have a lot of audible "cracks", and this never changes, despite of trying every possible configuration, even in the resetted config. (Meanwhile, the main Recording has no crack at all)

I would suggest:
- To heal this bug.
- to create an option "Record and break", and another "Record (no break)" because it keeps recording while the main recording is on pause... So the duration of the source recorded file is different and this is a big problem, it makes very difficult to edit!
- To create an option "Audio Only" (just to capture the original sound and minimize GPU use and Disk space.
Notice that my OBS has crashed by shutting down OBS after installation of the Plugin.

But the idea of this plugin ist really fantastic, and I encourage the author to make these revisions! thank you a lot for all the other plugins, especially Audio Monitor, my preferred Plugin!

Thank you a lot!
hallo, this is a good plugin. if you guys find any issue like :
1. OBS crashes when close the app after installing this pluing = close the games first then close the OBS (in this case I've using source record in game capture)
2. when you can find hot key to activate replay buffer for source record = make sure to close the OBS, then launch the game, open the OBS and set game capture to capture the game u want to stream or record then close the game first and now the OBS, and launch the game again following OBS, then bind the hotkey for replay buffer of Source record.
3. if u facing encoder overload try to use HEVC encoder in source record to capture and let the H264 for stream.

and that's it. follow my twitch: twitcht.tv/kuebastard
This is a sorely needed plugin. But problem is that source record videos are sped up and not in sync with the main OBS video recording. So it really makes it kind of useless. I hope this will be addressed soon.
Firstly want to say thanks to Exeldro for making this plugin. It has been very useful despite it's caveats.

I have found a solution for those who have latency problems between recordings.

Firstly, identify which sources that have the latencies by doing a test recording.

Once you have identified the sources, add a render delay of 60 milliseconds (ms) before the source record filter.

Whilst the sources will still have skipped frames (a little bit of the time being cut off the master-feed), it should now be in sync.

This plugin does cause quite a few crashes, but it happens less when I've added a "-disable-shutdown-check" parameter on my OBS shortcut.

Unfortunately Exeldro has said himself that to rectify these problems he would need to redesign the whole project, which I wouldn't be surprised if he doesn't do it.

So hope this fix is a good one and helps people with their projects!
It worked until I added the GoXLR mini to my system.

Now, the second I add "Source Record" filter to any source, the Music channel starts glitching and goes silent. Removing the Source Record filter or exiting OBS fixes the problem. Or even if I toggle visibility of the plugin ("eye" icon) my music cuts in/out.

I've tried the "Different audio track" option with all possible values and same results, same with hardware/software encoding. The second I add the plugin my audio gets messed up.

AMD Ryzen 9 3900XT
RTX 3060
GoXLR Mini
Mackie PRoFX10v3

Log: https://pastebin.com/GmkrV86u
Exeldro
Exeldro
For audio issues see the known issues and use different audio and select an audio track.
So I currently also have the problem that the plugin does not record the single source where the filter is active, but the whole scene. I have also made the test that I put the filter on a whole scene and then activate another scene. Again, it records the active scene. I think your plugin in is currently not working correctly.
Exeldro
Exeldro
Are you using as encoder nvenc new? because that is a known issue stated on the plugin page and the forum thread, try using an other encoder. If that is not the issue can you please provide me more information about the settings and setup your are using.
This plugin doesnt work with obs version 27.2.1
I have tried pretty much anything and i cant get it to start recording the source that i have chosen
My OBS Studio (27.2.4) does not launch after installing this plugin.
Problem is only fixed after removing it from obs-plugin folder.

Any ideas why this is happening?

Thanks


Processor Intel(R) Core(TM) i7-9700F CPU @ 3.00GHz 3.00 GHz
Installed RAM 16.0 GB
GPU NVIDIA GeForce GTX 1660
The idea behind this is incredible. This tool adds something that's severily lacking in OBS natively. Being able to record specific sources in various ways, enables both features such as dedicated recordings for post editing; or on the fly instant replays.

Unfortunately it is severely broken in a lot of aspects. For example it does not apply settings to your filter once the settings is applied. You have to turn the filter visibiltiy on and off. It also resets hotkeys every time you do that, or restart your OBS.

There's also an issue with it taking longer and longer to save a buffered footage, as your stream goes on - so it'll start with taking a second to save it - and 5 hours is it suddenly takes 22 seconds. (This goes back to 1 second if you hide/show the filter - which then resets your hotkeys).

It's a bit of a mess at the moment. Hopefully it'll improve once the developer finds time to take a look at it. Great idea, but still needs some work.
i cannot for the life of me get it to work with replay buffer, ive tried changing the encoders, i verified the settings, ensured replay buffer was enabled, checked settings again, and still nothing. it works if i use replay, but how i record things is mainly highlights and clips. but im at a loss at this point. this seemed like a saving grace to my issues but it seems not :(
This seems to work fine if you want to constantly record a single source. Unfortunately, I only wanted this to record gaming clip highlights without my streaming overlays via the replay buffer feature. This was for a possible alternative to Shadowplay. I have tried for 3 days going through every config I can think of, but no matter what I do, I cannot get this feature to work. It will not record the source replay buffer. Regular OBS replay buffer works fine, but the source record replay buffer feature does not ever output anything when I hit the hotkey.
Still randomly breaks for no apparent reason. Also somehow messes up the active/visibility signal for the entire OBS Studio instance, which makes almost everything stop working correctly.
Fantastic Plugin!! Only missing two key features that would make this a must have for every OBS user wanting this type of functionality. The ability for the recordings to support multi track audio recording as well as the ability for the recordings and the replay buffer clips to be optionally auto remuxed to MP4 when recording in MKV these features would just add that cherry on top to an already incredibly useful plugin.
I have done it, I have finally managed to configure the camera separately from the PC, thank you very much!
Using it with multiple cameras, and it's like having the ISO recording feature of BlackMagic ATEM MINI PRO ISO, without any of the limitations or the hefty price tag.
Hello, I have been using this plugin for the better part of a year. It took a bit to get used to and actually get things optimized for the setup i'm running, but it works great. There were some issue at the start with obs crashes and it not recording properly but I've solve the problems. Make sure to not use on game capture, instead use on a group with a set resolution and with the game capture plus whatever other game sources you use. I do the same thing for my camera. This is an excellent way for me to upgrade my videos and how I make them.
Really neat concept but doesn't work.

I'm encountering a problem where the length of the recordings do not sync up. The original has the full duration, but the source recordings are both shorter. The footage looks sped up and the audio is desynced because of it. I've tried using Software encoder, as well as x264 encoder, with the exact same settings across all recordings, but nothing seems to fix the issue.

I also have been experiencing a similar issue when it comes to replay buffer recordings, as well as an odd bug where sometimes it will only capture 1 (or sometimes none) of the source recordings. The times it does capture all of them during replay buffer recordings, the duration of all of the recording are always completely different from each other.
So much potential! Excellent when it works, but been having lots of problems with footage being sped up, and audio not syncing up. To the point where source record is several seconds SHORTER than the original recording. Wondering if a fix will be available soon!
Top