Resource icon

Microphone Echo (FIX) [If you're wanting to hear yourself]

So after long periods of thinking and trying to get this to work, I've come across a very simple solution to this problem that I see many people are having with no answers. I was also having this issue as I'm a streamer and like to play music during my stream, and also play other media (Youtube Videos, Spotify..) through "Desktop Audio" on my mixer in OBS.

In detail, I wanted to hear myself while I had my gaming headset on. The issue with this was that OBS doesn't quite have a separator for what gets picked up in "Desktop Audio", so when I turned on audio monitoring (to hear myself), it was not only going through the "Mic/Aux" channel, but also the "Desktop Audio" channel because I was hearing myself through the current default speaker. This created unbearable amounts of echo.

So the question at this point was: How can I make it so the sound of my mic is both - going through one channel AND sending feedback to my headset?

Firstly, you want to just delete the "Mic/Aux" channel from the Mixer entirely and turn on "listening" for your mic through windows. Once that's done, in OBS your "Desktop Audio" channel should be picking up your microphone.

Here's how to do it:
-Go to the start Menu
-Search for "Sound" and click the first option.
-A window should appear. When it does, click the "Recording" tab at the top.
-Right click on whatever microphone you're using in the listing, and then click on "Properties"
-Another window should appear. When it does, click the "Listen" tab at the top.
-Check "Listen to this device"
-Click APPLY once you've checked the box.

-Go back to OBS
-Make sure that "Desktop Audio" is added to your Mixer, and set it so the sound playback goes to your default speaker which could be either your headset or through speakers you may have.

The functionality of these steps pretty much makes it so the mic sound isn't going through OBS's "Mic/Aux" channel AND "Desktop Audio" at the same time which is making the mic echo. Instead, this way, all of the sound is going through the "Desktop Audio" in one clear sound.

I personally think this is a better option. I think there are a lot more ways to also edit how your mic sounds this way rather than using OBS Filters (no offence ily)

This is a good fix until OBS comes up with a direct solution to this which, I imagine, is a hard task to complete.
  • Like
Reactions: MilkyTech
Author
Lifewater
Views
37,446
First release
Last update
Rating
1.00 star(s) 1 ratings

Latest reviews

Could be useful but it's so terribly explained that it's an utterly useless post.
Top