Stream laggy when my viewers watch it

Discussion in 'Questions and Help' started by ItsNoxy, Jul 20, 2013.

  1. ItsNoxy Member

    Hello, I am a streamer who streams Minecraft on twitch.tv

    For some reason my stream is laggy when viewers watch it. I dont lag in game but when you watch it its kinda choppy. I have tried to use 30, 40, even 60 fps but still wont work.


    PC SPECS:
    Intel(R) Pentium(R) CPU B980 @ 2.40GHz
    4.00 GB RAM
    64-bit Operating System
    Intel(R) HD Graphics


    OBS Settings:
    Encoding - Video
    Quality = 5
    Use custom bitrate= checked
    Use custom buffer size= unchecked
    Max bitrate = 2600

    Encoding - Audio
    Coding = AAC
    Bitrate = 128

    Broadcast settings -
    Minimize Network Impact = checked

    Video -
    Custom = 1280x720
    Resolution Downscale = 1.50 (852x480)
    Filter = Bilinear(fastest)
    FPS = 40
    23:37:08: Open Broadcaster Software v0.541b - 32bit (´・ω・`)
    23:37:08: -------------------------------
    23:37:08: CPU Name: Intel(R) Pentium(R) CPU B980 @ 2.40GHz
    23:37:08: CPU Speed: 2395MHz
    23:37:08: Physical Memory: 3941MB Total, 1227MB Free
    23:37:08: stepping id: 7, model 10, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 2, total cores 2
    23:37:08: monitor 1: pos={0, 0}, size={1366, 768}
    23:37:08: Windows Version: 6.2 Build 9200
    23:37:08: Aero is Enabled
    23:37:08: -------------------------------
    23:37:08: OBS Modules:
    23:37:08: Base Address Module
    23:37:08: 00230000 OBS.exe
    23:37:08: 67CE0000 OBSApi.dll
    23:37:08: 744F0000 DShowPlugin.dll
    23:37:08: 744D0000 GraphicsCapture.dll
    23:37:08: 744B0000 NoiseGate.dll
    23:37:08: 74490000 PSVPlugin.dll
    23:37:08: ------------------------------------------
    23:37:08: Adapter 1
    23:37:08: Video Adapter: Intel(R) HD Graphics
    23:37:08: Video Adapter Dedicated Video Memory: 33554432
    23:37:08: Video Adapter Shared System Memory: 1711276032
    23:37:08: =====Stream Start: 2013-07-18, 23:37:08===============================================
    23:37:08: Multithreaded optimizations: On
    23:37:08: Base resolution: 1280x720
    23:37:08: Output resolution: 852x480
    23:37:08: ------------------------------------------
    23:37:08: Loading up D3D10...
    23:37:08: Playback device Default
    23:37:08: ------------------------------------------
    23:37:08: Using desktop audio input: Headset Earphone (Afterglow Universal Wireless Gaming Headset)
    23:37:08: ------------------------------------------
    23:37:08: Using auxilary audio input: Microphone (Afterglow Universal Wireless Gaming Headset)
    23:37:08: ------------------------------------------
    23:37:08: Audio Encoding: AAC
    23:37:08: bitrate: 128
    23:37:08: Using graphics capture
    23:37:08: Using custom x264 settings: "opencl=true"
    23:37:10: x264: OpenCL: Unable to find a compatible device
    23:37:10: ------------------------------------------
    23:37:10: Video Encoding: x264
    23:37:10: fps: 30
    23:37:10: width: 852, height: 480
    23:37:10: preset: superfast
    23:37:10: CBR: yes
    23:37:10: CFR: no
    23:37:10: max bitrate: 2600
    23:37:10: ------------------------------------------
    23:37:10: using memory capture
    23:38:27: Total frames rendered: 2109, number of frames that lagged: 76 (3.60%) (it's okay for some frames to lag)
    23:38:27: =====Stream End: 2013-07-18, 23:38:27=================================================
    23:38:27:
    23:38:27: Profiler results:
    23:38:27:
    23:38:27: ==============================================================
    23:38:27: frame - [100%] [avg time: 12.543 ms (cpu time: avg 4.252 ms, total 8968.75 ms)] [avg calls per frame: 1] [children: 62.2%] [unaccounted: 37.8%]
    23:38:27: | scene->Preprocess - [0.0319%] [avg time: 0.004 ms (cpu time: avg 0 ms, total 0 ms)] [avg calls per frame: 1]
    23:38:27: | video encoding and uploading - [62.2%] [avg time: 7.797 ms (cpu time: avg 1.192 ms, total 2515.63 ms)] [avg calls per frame: 1] [children: 57%] [unaccounted: 5.17%]
    23:38:27: | | CopyResource - [1.87%] [avg time: 0.234 ms (cpu time: avg 0.2 ms, total 421.875 ms)] [avg calls per frame: 0]
    23:38:27: | | conversion to 4:2:0 - [3.6%] [avg time: 0.451 ms (cpu time: avg 0.007 ms, total 15.625 ms)] [avg calls per frame: 0]
    23:38:27: | | call to encoder - [51.5%] [avg time: 6.455 ms (cpu time: avg 0.977 ms, total 2062.5 ms)] [avg calls per frame: 0]
    23:38:27: | | sending stuff out - [0.0638%] [avg time: 0.008 ms (cpu time: avg 0 ms, total 0 ms)] [avg calls per frame: 0]
    23:38:27: | Convert444Threads - [289%] [avg time: 36.269 ms (cpu time: avg 0.577 ms, total 1218.75 ms)] [avg calls per frame: 0]
    23:38:27: ==============================================================
    23:38:27:

    Advanced - General
    Process Priority Class = Normal

    Advanced - Video
    x264 CPU Preset = superfast


    Speedtest:
    http://www.speedtest.net/my-result/2810553269



    Code | Analyze
    23:37:08: Open Broadcaster Software v0.541b - 32bit (´・ω・`)
    23:37:08: -------------------------------
    23:37:08: CPU Name: Intel(R) Pentium(R) CPU B980 @ 2.40GHz
    23:37:08: CPU Speed: 2395MHz
    23:37:08: Physical Memory:  3941MB Total, 1227MB Free
    23:37:08: stepping id: 7, model 10, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 2, total cores 2
    23:37:08: monitor 1: pos={0, 0}, size={1366, 768}
    23:37:08: Windows Version: 6.2 Build 9200 
    23:37:08: Aero is Enabled
    23:37:08: -------------------------------
    23:37:08: OBS Modules:
    23:37:08: Base Address     Module
    23:37:08: 00230000         OBS.exe
    23:37:08: 67CE0000         OBSApi.dll
    23:37:08: 744F0000         DShowPlugin.dll
    23:37:08: 744D0000         GraphicsCapture.dll
    23:37:08: 744B0000         NoiseGate.dll
    23:37:08: 74490000         PSVPlugin.dll
    23:37:08: ------------------------------------------
    23:37:08: Adapter 1
    23:37:08:   Video Adapter: Intel(R) HD Graphics
    23:37:08:   Video Adapter Dedicated Video Memory: 33554432
    23:37:08:   Video Adapter Shared System Memory: 1711276032
    23:37:08: =====Stream Start: 2013-07-18, 23:37:08===============================================
    23:37:08:   Multithreaded optimizations: On
    23:37:08:   Base resolution: 1280x720
    23:37:08:   Output resolution: 852x480
    23:37:08: ------------------------------------------
    23:37:08: Loading up D3D10...
    23:37:08: Playback device Default
    23:37:08: ------------------------------------------
    23:37:08: Using desktop audio input: Headset Earphone (Afterglow Universal Wireless Gaming Headset)
    23:37:08: ------------------------------------------
    23:37:08: Using auxilary audio input: Microphone (Afterglow Universal Wireless Gaming Headset)
    23:37:08: ------------------------------------------
    23:37:08: Audio Encoding: AAC
    23:37:08:     bitrate: 128
    23:37:08: Using graphics capture
    23:37:08: Using custom x264 settings: "opencl=true"
    23:37:10: x264: OpenCL: Unable to find a compatible device
    23:37:10: ------------------------------------------
    23:37:10: Video Encoding: x264
    23:37:10:     fps: 30
    23:37:10:     width: 852, height: 480
    23:37:10:     preset: superfast
    23:37:10:     CBR: yes
    23:37:10:     CFR: no
    23:37:10:     max bitrate: 2600
    23:37:10: ------------------------------------------
    23:37:10: using memory capture
    23:38:27: Total frames rendered: 2109, number of frames that lagged: 76 (3.60%) (it's okay for some frames to lag)
    23:38:27: =====Stream End: 2013-07-18, 23:38:27=================================================
    23:38:27: 
    23:38:27: Profiler results:
    23:38:27: 
    23:38:27: ==============================================================
    23:38:27: frame - [100%] [avg time: 12.543 ms (cpu time: avg 4.252 ms, total 8968.75 ms)] [avg calls per frame: 1] [children: 62.2%] [unaccounted: 37.8%]
    23:38:27: | scene->Preprocess - [0.0319%] [avg time: 0.004 ms (cpu time: avg 0 ms, total 0 ms)] [avg calls per frame: 1]
    23:38:27: | video encoding and uploading - [62.2%] [avg time: 7.797 ms (cpu time: avg 1.192 ms, total 2515.63 ms)] [avg calls per frame: 1] [children: 57%] [unaccounted: 5.17%]
    23:38:27: | | CopyResource - [1.87%] [avg time: 0.234 ms (cpu time: avg 0.2 ms, total 421.875 ms)] [avg calls per frame: 0]
    23:38:27: | | conversion to 4:2:0 - [3.6%] [avg time: 0.451 ms (cpu time: avg 0.007 ms, total 15.625 ms)] [avg calls per frame: 0]
    23:38:27: | | call to encoder - [51.5%] [avg time: 6.455 ms (cpu time: avg 0.977 ms, total 2062.5 ms)] [avg calls per frame: 0]
    23:38:27: | | sending stuff out - [0.0638%] [avg time: 0.008 ms (cpu time: avg 0 ms, total 0 ms)] [avg calls per frame: 0]
    23:38:27: | Convert444Threads - [289%] [avg time: 36.269 ms (cpu time: avg 0.577 ms, total 1218.75 ms)] [avg calls per frame: 0]
    23:38:27: ==============================================================
    23:38:27: 
    
  2. freakymarek Member

  3. alpinlol Well-Known Member

    not going to happen... laptop with dualcore and no actual gpu. at least you wont get anything to work which is actually enjoyable to watch. its not that you drop or lag frames but i could bet your cpu is peaking a 100% usage a lot.

    should try something like

    fps 20
    preset ultrafast
    aero disabled
    leave the output resolution as it is and hope it works.
  4. ItsNoxy Member

    actually no my cpu is around 50-60%

Share This Page