obs game capture = black screen

Discussion in 'Questions and Help' started by mrgreaper, Mar 10, 2013.

  1. mrgreaper Member

    ok so i was told obs is better then xsplit and decided to give it a try, first thing i found out is that it doesnt even support the haupauge hd-pvr one of the most used capture devices for the last year, but hey thats in video capture mode, we cant expect a free piece of software to be at the same standard as a paid for one i hear you say...ok but when i found this out i discovered that it cant even came capture capture.exe of the total media software that comes with the hdpvr.

    if i game capture the software using xsplit the image is right there straight away
    if i game capture using obs i get a black screen!

    if i screen capture the software in xsplit i see the image clear as
    if i window capture the software in obs i get black screen ..... wierdly i can capture the menu of the program etc but the bit where the preview window is...the bit i need to capture..is blank on the stream and preview

    i did a test with a game called "dont starve"
    using obs windowed mode worked fine but when i made it full screen and tried game capture mode i got a blank screen!

    the laptop im doing my capturing from is new, it has an i5 processor, nvidia 630m graphics(1gig dedicated) 8gig of ram

    xsplit runs fun but right at the limits, i was told obs is a better solution...so far im very unimpressed

    i even tried using the latest test build...but still just black screen

    windows 8 home edition 64bit
    latest directx installed
    latest graphics drivers installed

    is this program just not ready for everyday use yet?


    edit
    tried removing virus program ....no change
    tried 32bit and 64bit ....no change
    windows update confirms windows is fully updated ... still no go
  2. Vrse Member

    Yes, this issue is reoccurring after the game crash fix in the latest build.

    I'm having the same exact problem.
  3. Warchamp7

    Admin

    Make sure OBS and whatever you're capturing is being forced to run on the Nvidia card.
  4. mrgreaper Member

    ??
    there is to my knowledge only one card in my laptop no idea how you force something to use it
  5. Warchamp7

    Admin

    You have the dedicated Nvidia card and also a standard integrated one, likely by Intel. There's a program called Optimus that generally comes with those types of laptops for doing what I said, though I don't really know the detailed steps
  6. mrgreaper Member

    your quite right i do have two (only had the laptop for a few days now)
    i went into the nvidia page and found a way to force things to use the nvidia card, there is a notification app that shows if programs are running on nvidia and sure enough both "capture.exe" which displays the feed from my capture device and obs are running now on nvidia
    however
    still get a black screen when i attempt to:
    gamecapture capture.exe
    entire window capture (this time i dont even see the menu around the preview window...its just all black!)
    inner window

    if i capture monitor 1 i can see the preview window inside the capture window...... how ever this is far from ideal even if i full screened the preview window i also need to keep an eye on the streams chat etc same as i can in xsplit.
    i tested 472b 32bit/64bit and 473b 10 64bit all set to use the nvidia card
    this is really frustrating

    also tested "dont starve" full screen with gamecap on all 3 obs versions listed above with it set to nvidia....same black screen
  7. Hellhog New Member

    I am having the same issue, it doesn't matter what setting I am using, I cannot get OBS to capture the game video, but it does capture the audio. Everything else captures fine except Game Capture. Now, I have an Intel i7-3610QM CPU and Nvidia GTX 675M GPU that is optimus enabled. In the settings it is set to use the Nvidia card. I also force the application to use the Nvidia card. No matter what, it doesn't seem I can get video. And I'd rather not have to use windowed mode.

    Any ideas?
  8. Hellhog New Member

    Nevermind, just fixed it finally. For anyone else trying to record or stream with OBS and has an Nvidia Optimus enabled GPU on their laptop, use the following settings:

    -In settings for OBS, set your integrated Intel GPU as the recording GPU, I also have Aero disabled on OBS startup.
    -When you launch OBS, right click (if on your desktop or start menu) or shift + right click if in your taskbar and choose run with graphics processor and choose the Nvidia GPU.
    Nero senpai! likes this.
  9. mrgreaper Member

    its not what youll want to hear but i never managed to solve it, the developer does not view this issue in any high regard or priority so youll have to pay for xsplit, its the only option. Sorry to be the bearer of bad news.

    (to be honest i saw that this had a reply and had hoped that the issue had been solved, hence my speed of reply, i cant afford to keep giving xsplit money)
  10. mrgreaper Member

    oh, im sure i tried that at the time but will try again


    didnt work for me
    no ability to turn aero off (windows 8)
    when i right click or shift right click no option to choose run with graphics processor

    oh well back to waiting with luck the dev will one day fix, cant complain too much that a free program wont work for me just frustrating
  11. Hellhog New Member

    At first it didn't work for me, but I had to alt tab sometimes to get it to show. I hope you can figure it out. I don't know if aero needs to be disabled, I do because one of my scenes is the desktop. I'm not sure if it is something different with Windows 8 or not (because I am on 7). But if you can't manually force it when launching go into Nvidia Control Panel and set obs.exe to launch with NVidia graphics. If it doesn't show up, browse for it. I hope you can get it to work.
  12. Aleiexjr New Member

    I had the same problem and was able to fix it by doing the following:

    -Set your game and OBS to run on your dedicated video card (Nvidia)
    -Start your game
    -Run OBS as admin
    -On global sources > add > Add Game Capture > Enter name > Select game application > OK
    -Back on the main window, in the box besides your Scene, right click > add > global source>last entry you created
    -Now check that box and preview, you can add everything else (webcam screen or whatever you want) and stream directly

    :D


    I hope this helps someone else!

    BTW, I'm running windows 8 on a laptop with an NVidia dedicated card.


    cheers!
  13. nabukustor Member

    same problem ......
    i have been follow step by step your comments and still cant get preview on League of Legends
  14. Jim

    Jim Developer

    For those of you who experience black screens on laptops, please read this post. This is not actually a bug with the app. It never has been, it's a hardware conflict due to the fact that common laptops run on two graphics adapters. What happens is OBS is running on one adapter, the game/target on the other adapter, and thus, because they are on separate adapters, black screen capture. The "image" of the target cannot be acquired because it is not available on the device OBS is on. This is explained in that post. OBS and the target both have to be running on the same graphics processor to get a proper capture. "Compatibility mode" with window capture is currently the only way to force a less-efficient "cross-adapter capture", which causes the image to actually download off of one GPU and upload to the other.

    Don't jump to conclusions thinking that I "don't care" or something, I do care, and I've tried to explain the situation with laptops as best as I could, and I want to try to present easier ways to solve the problem, but laptops do not make the situation easy if you actually want an efficient capture as OBS was designed to do. It requires some effort on the part of the user, but that effort is worth it because the speed and efficiency of a proper capture means less strain on your system, and thus, better streaming.
  15. mistermorriss Member

    What about us that have the exact same problem on PC? (With only one graphics card and onboard integrated disabled)?
  16. dodgepong esports architect

    Moderator

    You should make a new post in the Questions and Help section and post your log.
  17. Jim

    Jim Developer

    This doesn't apply to regular desktops. Laptops are a special case because of the way they are designed, desktops do not share the same issue in the same way.

    Though if you run a game on one adapter and OBS on another you will get a black screen, so you must use the adapter selector in OBS' video adapter drop-down for desktops.
  18. bluefire New Member

    I created an account just to post this - As far as laptops go, I've found that if you get the game into a borderless window, and use Capture window instead of game capture, you can stream/record the games just fine.
  19. dodgepong esports architect

    Moderator

  20. Nero senpai! New Member


    Thanks Worked for me =p

Share This Page